Weird surge in power used overnight


#1

I’ve had a weird issue with the push data sent to PV Output overnight for the past two nights.

At around 11:50pm it’s tracking a massive surge in power used. Everybody in the house is asleep and I don’t think even with everything in the house turned on we’d be able to pull ~500kW in one go.

Date Time Energy Efficiency Power Voltage Energy Used Power Used
21/10/2018 23:55 60.957kWh 6.157kWh/kW 0W 250.7V 61.045kWh 573,060W
21/10/2018 23:50 60.957kWh 6.157kWh/kW 0W 251.1V 13.290kWh 0W
21/10/2018 23:45 60.957kWh 6.157kWh/kW 0W 251.3V 13.290kWh 0W

And:

Date Time Energy Efficiency Power Voltage Energy Used Power Used
20/10/2018 23:55 61.365kWh 6.198kWh/kW 0W 250.6V 61.447kWh 420W
20/10/2018 23:50 61.365kWh 6.198kWh/kW 0W 250.5V 61.412kWh 532,152W
20/10/2018 23:45 61.365kWh 6.198kWh/kW 0W 250.2V 17.066kWh 0W

Running a Fronius Primo with smart meter/data logger. Gas hot water so it’s not that coming on at 12pm.
Solarweb isn’t showing up the surge and haven’t had any issues before Saturday 20/10 night.

Any ideas what the issue might be would be much appreciated.


Fronius Push
#2

The spike in power is due to the increase in energy from 17.066kWh to 61.412kWh in 5-minutes which works out to the 532,152W

How is the push data configured?

It is advised to remove auto=1 on the meter push if also using the hourly LogData push as this may be causing inconsistencies, i.e. logdata push recording 17.066kWh up to 23:00 then the 5-minute meter log push send 61.412kWh


#3

The push is configured with Inverter, Meter and Log Data Push

Inverter - 5m:
/service/r2/froniuspost.jsp?sid=SID&key=KEY

Meter - 5m:
/service/r2/froniuspost.jsp?sid=SID&key=KEY&v6=Voltage_AC_Phase_1&auto=1

Log Data Push - 1h
/service/r2/froniuspost.jsp?sid=SID&key=KEY

Has been configured like this for months (July at a guess) so it seems odd that the spike has only occured for the last three days (20/10-22/10).

I had added the auto=1 as there were some discrepencies between what I had showing up in Solarweb and PVOutput


#4

I’m seeing the exact same thing, oddly. Last 3 days only, 5 minutes earlier each night and no configuration changes aside from adding a log update about a fortnight ago (it was fine after that through until 3 days ago). There’s nothing coming on at night that would be doing that and it’s also not reported in Solar Web.

Inverter - 1min
/service/r2/froniuspost.jsp?sid=xxx&key=xxx&dayenergy=1

Meter - 1min
/service/r2/froniuspost.jsp?sid=xxx&key=xxx&v6=Voltage_AC_Phase_1&auto=1

Log - 1h
/service/r2/froniuspost.jsp?sid=xxx&key=xxx

Date Time Energy Efficiency Power Average Normalised Temperature Voltage Energy Used Power Used
20/10/18 23:55 24.706kWh 6.085kWh/kW 0W 0W 0.000kW/kW - 235.9V 24.704kWh 48W
20/10/18 23:50 24.706kWh 6.085kWh/kW 0W 0W 0.000kW/kW - 235.5V 24.700kWh 112,680W
20/10/18 23:45 24.706kWh 6.085kWh/kW 0W 0W 0.000kW/kW - 234.0V 15.310kWh 48W
20/10/18 23:40 24.706kWh 6.085kWh/kW 0W 0W 0.000kW/kW - 235.0V 15.306kWh 108W
Date Time Energy Efficiency Power Average Normalised Temperature Voltage Energy Used Power Used
21/10/18 23:55 17.566kWh 4.327kWh/kW 0W 0W 0.000kW/kW - 235.0V 17.573kWh 252W
21/10/18 23:50 17.566kWh 4.327kWh/kW 0W 0W 0.000kW/kW - 234.6V 17.552kWh 48W
21/10/18 23:45 17.566kWh 4.327kWh/kW 0W 0W 0.000kW/kW - 234.3V 17.548kWh 130,320W
21/10/18 23:40 17.566kWh 4.327kWh/kW 0W 0W 0.000kW/kW - 234.9V 6.688kWh 84W
Date Time Energy Efficiency Power Average Normalised Temperature Voltage Energy Used Power Used
22/10/18 23:55 22.711kWh 5.594kWh/kW 0W 0W 0.000kW/kW - 233.4V 22.759kWh 180W
22/10/18 23:50 22.711kWh 5.594kWh/kW 0W 0W 0.000kW/kW - 233.7V 22.744kWh 108W
22/10/18 23:45 22.711kWh 5.594kWh/kW 0W 0W 0.000kW/kW - 235.0V 22.735kWh 120W
22/10/18 23:40 22.711kWh 5.594kWh/kW 0W 0W 0.000kW/kW - 234.8V 22.725kWh 173,244W
22/10/18 23:35 22.711kWh 5.594kWh/kW 0W 0W 0.000kW/kW - 234.9V 8.288kWh 336W

#5

I’ve just removed auto=1 from the meter push, will see what happens tonight.


#6

My data from yesterday looks fine.


#7

Kept &auto=1 on last night and didn’t get the ~2350 spike.
Related to the maintenance last night?


#8

It’s possible they are related, the system is performing well at the moment after maintenance, lets see over the next couple of days.


#9

Seems like it’s sorted now. No spikes since 23/10.
Cheers.


#10

So what was the outcome on this.
Did you end up making any config changes as I have also had the same issue since the 22nd Dec

https://pvoutput.org/intraday.jsp?id=5101&sid=62382&dt=20181229&gs=0&m=0


#11

Adding the Log Push will generally fix these Fronius push data issues.


#12

Is that the LogDataPush?

I have the following:

SolarAPI v1 - Current Data -Inverter
/service/r2/froniuspost.jsp?sid=xxx&key=xxx&v6=Voltage_AC_Phase_1&v3=None

SolarAPI v1 - Current Data - Meter
/service/r2/froniuspost.jsp?sid=xxx&key=xxx&v6=Voltage_AC_Phase_1&n=1

SolarAPI v1 - Logdata - Data
/service/r2/froniuspost.jsp?sid=xxx&key=xxx


#13

The push config is correct.

However, looking at your Log Push data is sent in 30 minute intervals instead of expected the 5 minute intervals. We may have to make enhancements to the service to handle this.


#14

My config is currently set to 1 hour.
This is the minimum that it is letting me choose.


#15

No, this is correct, leave it 1 hour. i.e. Fronius will send data each 1 hour.

The issue is the data is provided at 30 minute intervals -

10:30  
11:00
11:30
12:00

So there is missing 25-minutes worth of data. The change will be to the PVOutput service to handle this.


#16

That makes sense now.

So any reason why this has just started to happen recently?
I have had it set up for a few months and only had these spikes the past few days


#17

No changes on the PVOutput side, check that the inverter firmware hasn’t been updated


#18

It may have updated.
I do have it set to automatically updates.

I might have to see if I can roll back to a previous firmware (if safe to do)


#19

PVOutput will now handle 30-minute intervals from the Log Push. Spikes today 31-Dec have been fixed with the 11:00PM push.

Not much can be done about the spike at 6:35PM, since Fronius is not providing 5 minute data.


#20

Wow.
Thanks so much.
Such a great community here. Keep up the great work