Fronius Push

dangerousdave, hi are you using the Fronius power management tool with a relay to set your times for heating or something else, say a mk2pvrouter or something different altogether ??

Just realised that my post wasn’t strictly on topic… ie it wasn’t about the push facility. I thought I’d made a related post on here before but I suspect it was actually on Whirlpool.

But in response to your query Jim… I’m using the Fronius Smartmeter’s load management facility. I had it wired up to my hot water when it was installed. It works well

You’re probably familiar with it… but I can only tell it when the required amount of heating should be completed… there’s no option for the starting point… ie it starts at midnight.

I’m not familiar with the mk2pvrouter but have had a look at various other ways to control things. My setup is all or nothing in terms of energy used to heat the water. If starting again, I might go for one of the ones that can send power to the element at less than its maximum capacity. But what I have works pretty well and I doubt I will save much money (or mains electricity) with the considerable investment required.

bankstownbloke hi for the last 3 days my system has been showing a time lag between the fronius push and PVorg of between 20 to 45 min, my system is no 51134. i have checked all the different time clocks in the systems and have checked post is working on time,but the updates are not showing up on pvoutput for some time later. i am in west Australia Perth time so no daylight saving here and the problem only seems to hapen after about 3 pm to 6.30pm it also seems to pick up the missing data on the hour and then start again with the lag, thanks for your help Jim

This has just started no changes to system .
about 11pm to 12pm get huge spike power used .

Any ideas.
I don’t have pv push settings handy but been working fine last 8 months

@nitrox1971, also discussed at

Related post below, feel free to continue that thread so it does not get lost here -

Hi All, normally I like to work things out for myself, but this meter is driving me crazy. My live ‘power used’ is way too high and seems to be influenced by the ‘power generated’. I think I’ve tried every combination of parameters listed in this thread, but I just can’t get it to track power consumption accurately. Current settings are:

Fronius Symo 5.0-3-M version fro28500
Smart Meter (feed in point) version 3.10.3-1

Inverter Push - &dayenergy=1
Meter Push - &v6=Voltage_AC_Phase_1&auto=1

SolarWeb seems to be producing the correct values, but it is only updated hourly.

Any ideas most welcome.

It is recommended to add a third push hourly “LogData” push. This is the same data that the inverter reports to solarweb hourly.

Thanks for the tip. I’m happy to push the Logdata hourly, but I can view that data on SolarWeb. It’s nicely presented and free. I was hoping to get pvoutput to display live data.

your push from inverter and meter should be set to every 5 minutes ( live data)
the log data push it to tidy up any discrepancies. and that should be set hourly

give us a link to your system so we can see the actual issue

Hi, I am very pleased to report today’s results look much closer to the SolarWeb data (within ~100w). I rebooted the inverter/meter last night, but I also changed the push settings and added the hourly update, so I don’t know what actually fixed it.

Anyway I wish to rescind the derision shown towards my smart meter. I now love my smart meter. :slightly_smiling_face:

Thanks for your help.

Hi All,

New to PVoutputs - Cannot seem to get the Push working. I have followed the instructions to a tee, ensured the SID and API key’s have been placed in the relevant fields etc, even reset the datalogger.

I dont have a fronius smart meter but just wanting to push my generation to pvoutputs, can anyone recommend things I can do or even let me know if there is anything I am doing wrong?

Hi is your push service looking like this,

go to inverter screen, log in to settings then push service, you should see.

{State: Successful 1 minutes ago} or 2-3-4-min ago ,if not set it all up again may be the best way to fix it

because the push from your inverter end is not working-- also the help section on this site --Push services Fronius post Jim

I just got a Fronius Symo installed, I have donated. During the day the generation and power used is correct, hovers around 3-500W for power used. However when I check the next morning the power used and energy used seems to try and be around what the generation is which is of course very high and not correct. I’ve read a few of these threads but confused myself on what I should change. Not sure if the nodayenergy bit should be used, my push scripts are:



I have a Symo as well. It took me a while to settle on what seems to work. Even then I see anomalies in the live data chart that magically disappear later in the day, so my settings are probably not ideal.

In my meter push setting I have n=1 rather than auto=1. But after reading the help page I perhaps should change it to auto=1.

My delay=5 setting is in the inverter push but not in the meter push.

It’s not clear to me which push settings should have the delay set, the meter push or the inverter push, or both, or neither?

The help section of example configurations I find confusing. Are they examples of inverter push, meter push or log push?

I initially used this article for what to do

However the image at the top shows the exact issue I have which is… interesting as the consumption follows the generation. During the day the consumption figures are all correct, its only when generation stops that it suddenly starts “changing” all the consumption figures. I’m just not sure what to change to troubleshoot. The &nodayenergy=1 in the article isn’t noted anywhere that I’ve found so no idea there either.

  • nodayenergy=1 is only used for on the Inverter push.
  • Remove the delay from the inverter, delays are used for meter push only to ensure inverter data is processed before net meter data.
  • If auto=1 does not work after 24hrs, try n=1 instead.
  • LogData push will fix discrepancies every hour.

I have a Fronius Symo 5.0-3-M and the following settings work fine for me. After I added the ‘auto=1’ term it took overnight for things to settle down.




Thanks I’ve removed delay on the inverter and changed to n=1 on meter I’ll report what happens.

Yeah, my delay setting was on the inverter push and not on the meter push. I’ve swapped mine around, Maybe that’s what was causing the strange live chart readings which later on would disappear.