Wattvision issues


#1

Anyone else having issues with Wattvision? I see data is populated in rainforestcloud, but not Wattvision


Is there a way to batch-upload net power data?
#2

Yes

There’s a thread started on the Wattvision board, but no response. I tweeted Wattvision, no response yet


#3

Thanks! Couldn’t find their board for some reason. Have switched over to Eagle Post for now.


#4

How do you configure “Eagle Post”. I have the Eagle 2 and looked at the documentation here but cannot figure out what I need to do:
https://pvoutput.org/help.html#push-eaglepost

Would someone be so kind as to give me a step by step or a picture of their settings? I’m assuming this needs to go in the eagle right?


#6

You want to add a custom upload destination like below. Change your Site ID and API key to match what is on your account.

/service/r2/eaglepost.jsp?sid=123&key=098203984092839048&tz=US/Pacific


Power consumption spikes every 15 minutes
#7

Thanks very much, that worked for me!


#8

Can somebody explain more clearly how to do this “Eagle Post” thing?

Does this work only with the Eagle 200 or the older Eagle as well?

If it works with the older Eagle, where do I enter all this?


#9

Yes, same request. The posts above don’t appear in my Eagle. Think the images are from a Eagle-200. I have the Legacy Eagle and only a service URL input in the Cloud Settings interface. I am trying to find the API key string for the Legacy Eagle and can’t find it. What is my SID for example?


#10

It also isn’t possible to delete the Wattvision cloud service by removing. Tried multiple times to set to None for Cloud so that I could delete the Wattvision cloud and it generates an error message that it can’t be removed.

I tried to set up the Eagle Post cloud with the examples provide in the Help file and all I get is a HTTP 401 error.

Beginning to think the limitation is in the Legacy Eagle device.


#11

OK, I just found an old post explaining how to do this.
Jul '17
could you please tell me explicitly how to achieve this Eagle Post you keep referring to.

See https://wattvision.readme.io/docs/rainforest-eagle-setup-1 30

Change the wattvision url shown above to -

https://pvoutput.org/service/r2/eaglepost.jsp?sid=[pvoutput_system_id]&key=[your_pvoutput_api_key] 2

Replace both -

[pvoutput_system_id]
[pvoutput_api_key]
Via https://pvoutput.org/help.html#api-getting-started 10

I went to my Settings page at PVOutput.org and found my System ID down at the bottom under Registered Systems. Right above that is the API key for my system. I just put replaced the values in the brackets with my system values and then copied and pasted that URL into the Eagle add cloud server configuration line and labelled it as PVOutput.org. Created the new cloud server and then changed the Cloud Server away from Wattvision to the new PVOutput.org cloud server. It initialized the Eagle cloud server and I got a connected confirmation.

Now just have to await new consumption data showing up at PVOutput.org for my system. I turned off the Secondary Upload device which was previously configured for the Eagle to be sure that data is coming from Eagle POST and not from the scrape of my data from my rainforestcloud.com account.


#12

@kmeyers95963
Thanks for the instructions.

You said you turned off the “Secondary” device.

In which case, how does pvooutput know to do the “Net” calculation?


#13

From the Help section on Eagle Post.
"Restrictions and Limitations

Negative power values are treated as export, positive values import.
All power is treated as Net by default. Import and Export will be merged with existing Gross generation data to calculate gross consumption.
The d parameter can be used to ensure gross generation data is uploaded prior to merging net data.
This service is only available in donation mode."

So any data that Eagle POST pushes up to PVOutput.org is considered NET.


#14

Well the Eagle is being flaky. After changing to Eagle Post and waiting a while before checking so that there would be data, I found no data being uploaded.

So took a look at the Eagle and found that no Cloud server was configured. Went back to the picklist and found at least that the bad penny Wattvision server was finally purged from the list. I was fighting to remove that for the past couple of hours.

Saw that my new PVOutput.org cloud server was still in the picklist and selected that again. See that data is finally going back up to PVOutput.org again. Will have to keep monitoring and see if it sticks.

Bankstownbloke said that Eagle POST was the preferred method to get data from the Eagle upstream. But the Eagle Auto Uploader as Secondary device was working quite well since last night once I set it to send data every hour instead of five minutes. No break in the consumption data till I started messing with the Eagle POST configuration.


#15

After following your steps, it seems to be working fine for me.
Good riddance to Wattvision!


#16

Good to hear.

On another note . . . . did anyone else loose their temperature reporting at 19:40?


#17

Eagle POST is the preferred method as the data is uploaded directly from the Eagle to PVOutput.

The Auto Uploader method has to go through rainforest cloud but these requests are actually sent to the individual Eagles which may not be available to respond due to internet connectivity issues etc.


#18

Thanks for explaining the distinction between the two. I did not know that the Eagle Uploader actually pulled from the individual Eagle device. I thought it pulled from rainforestcloud.com.

I did discover that changing the Uploader to use the 1 hour History upload instead of the normal instantaneous 5 minute uploads was more consistent without as many data breaks. I figured the lesser amount of times that PVO has to pull the data from rainforestcloud.com the better.


#19

Thank you everyone for these posts, especially for the screenshot showing the Eagle Push configuration (via RFA “cloud” website) . That fixed it for me.

I also have the Eagle 200 (Version 2 with 5 lights) and like all of you, were in the same boat (using Wattvision as data proxy to PVO).

Given Wattvision has responded to 0 out of 3 support requests over the last year, including this one, they can pound sand. I am canceling my monthly plan with them.

Thank you everyone!


#20

Hey Keith. Weather is working for me, however mine comes from the inverter on the SolarEdge side. I previously use the WU API, so details are still in the screenshout, but don’t think they’re being used. This is how I am configured and temp details show on PVO.


#21

Thanks all for posting the steps on the POST method. I’ve changed over and have started to get data uploaded. Good riddance to Wattvision