Fronius Push - Inverter+Meter Daily Logdata


#41

Sorry, the &nodayenergy=1 option is now default, please use &dayenergy=1 to explictly enable the recording of DAY_ENERGY


#42

Thanks for the screenshot, when the log data push was added, did the meter push have &n=1 option or &auto=1 ?

You’re currently using &n=1


#43

I tried both options over two separate days. Up to now I have always used &n=1 as I have had no issues with the push to PVOutput, but when I saw the data log push option, I changed to &auto=1 as that was what people were using.

This is with &auto=1 for both inverter and data push running for the day:
auto%3D1

I thought that the &auto=1 was not working for me, so I then reverted back to the &v3=none for both inverter and data push and kept it running for the day:
%26n%3D1

I have since reverted back to the &v3=none for the inverter pushing to PVOutput and the log data push to froniuslog.jsp which is still currently running for the last few days, and my PVOutput looks normal
Snap3


#44

The auto=1 setting should be set at the start of the day (or the day before) since it relies on the first push of the day to work out how much as been imported/exported during subsequent pushes.

Enabling auto=1 in the middle of the day would produce some strange results.

Another combination of pushes to try is the following -

  1. Inverter Push (froniuspost.jsp)
  2. Meter Push (froniuspost.jsp?n=1&delay=10)
  3. Log Push (froniuspost.jsp)

The froniuslog.jsp push can be stopped.


#45

I have stopped the log push to froniuslog.jsp. I will change the inverter push and log push to PVOutput to auto=1 now (from v3=none), this evening, to let it roll over for the start of the day, as previously, both instances were started in the morning. We will see how it goes.
My meter push is currently set up as n=1&delay=15 which has been working fine.

Update

After making the change to auto=1 yesterday evening, my feed was fine until 13:15 this afternoon when consumption data was incorrect for 25 minutes:


Snap4

Now this is the weird thing. The hourly log data push fixes this bad data, as shown here from the push at 15:00:


Snap6

but the next inverter push at 15:05 makes the bad data reappear again until the next hourly data log push.

As per your suggestion, I then stripped off the settings for the inverter and log data push (removed &auto=1), but after the hourly update, the bad data still comes back on the next inverter/meter push:
Snap8.

I have now removed the hourly push and reverted my inverter push back to v3=none for the time being.


#46

This is probably due to the net delay, the meter net pushes are being held for 15-minutes after the log pushes corrects the data, then overwrites it.

It should be okay to reduce delay down to 5-minutes i.e. &delay=5.

However, the next log push one hour should fix this again, but the 0W still exists.

The log pushes don’t seem to be pushed every 1 hour for this system -

e.g. processing times in Perth time 11/Jul and it has not sent any more log pushes since.

  • 12:01
  • 13:01
  • 14:00
  • 15:00
  • 16:01
  • 16:37
  • 16:41
  • 17:00
  • 17:07
  • 17:21
  • 17:22

#47

The erratic log pushes after 16:00 is me testing to see what happens. I do not understand why a log push at 16:00 fixing bad data seen at 13:30, is then reverted back to bad data by a 5 minute push at 16:05. I removed teh log data push after 17:22. I have put the log data push back and changed the meter delay to 5 minutes.


#48

Please keep the settings that is currently working.

Will have a closer look at this, it maybe the combination of log push and net data that is causing issues.

Thanks for your help and patience.


#49

No problem. Appreciate the quick response. The log data push is now reinstated and immediately fixed the bad data between 13:15 and 13:35 when it pushed at approx 19:46, but again the 5 minute meter / inverter push at 19:50 reverted back to the bad data between 13:15 and 13:35.


#50

Found the issue with this, the net data pushes actually keeps the entire history of net pushes received, this would refresh all existing records and overwrite the log data push with incorrect history net data.

This has been fixed to only use the last 40-minutes for Fronius meter net push data.


#51

Excellent. Well spotted and corrected.
I left the three pushes running, and the data for yesterday is now only showing the good data.
Outstanding investigation and solution sourced as usual.


#52

Looks good, this is finally working as expected. Hourly log data is fixing the 0W recorded by the net meter push and is not being overwritten.


#53

Guinea pigs for the greater good is never an issue. We are always happy to test.


#54

I have the “last hour” problem with the LogPush again, no values after 22:55
https://pvoutput.org/intraday.jsp?id=64909&sid=57693&dt=20180715&gs=0&m=0

And the Day before

I disabled the log push since 2 days.

Some spikes at 00:10 every day are now under my investingation, may be it is the Filtercycle from the Whirlpool.


#55

Just added a change that will specifically handle the last hour of 0W readings when using auto=1.

Please give this another try.


#56

Ok
LogPush is on


#57

Hi all, jumping in on this topic. I just got my Fronius Smart Meter installed today and I’ve got a massive spike in the middle of the day which of course is an error. Am I right in guessing this is because with the auto=1 setting it has gone wacky due to it being set in the middle of the day. Should it be right starting with a fresh day tomorrow? Also, is editing that spike out a possibility?

I’ve got my meter push set to /service/r2/froniuspost.jsp?sid=#####&key=#####&v6=Voltage_AC_Phase_1&auto=1 and my inverter push set to /service/r2/froniuspost.jsp?sid=#####&key=#####&v3=None

Do these look correct?

(I’m using a Fronius Primo inverter)


#58

i had the same effect once,

https://pvoutput.org/intraday.jsp?id=64909&sid=57693&dt=20180618&gs=0&m=1

when i switched to auto=1


#59

now it works fine

is it possible to change the 00:05 zero value whitch is from auto=1, to the real value with the last LogPush of the day?


#60

Know of a way I can edit the 3.55pm figure?

https://pvoutput.org/intraday.jsp?id=67655&sid=60134