Enphase Auto Uploader - Migration from v2 to v4

Enphase Energy will phase out the existing Enphase v2 API used by PVOutput out on 16 Aug 2022, 31 Oct 2022, 18 Jan, 2023

PVOutput has implemented support for the new v4 API via the testing discussion thread below -

System owners need to explicitly authorize PVOutput access to Enphase v4, so it is not possible to automate the migration. This should be done before 18 Jan, 2023.

Key dates for the migration as follows -

  • 02 Jul 2022 - Saving Enphase v2 system details no longer possible.
  • 16 Jul 2022 - Email notices sent to active system owners still on Enphase v2 about the change.
  • 17 Jan 2023 - PVOutput Enphase v2 auto uploads disabled
  • 18 Jan 2023 - Enphase v2 will stop working

UPDATE - Enphase have delayed v2 decommission date to 31 Oct, 2022
UPDATE - Enphase have delayed v2 decommission date to 18 Jan, 2023

1 Like

Hello, when I performed the steps mentioned the last step was to save the system. The save was clicked but I can’t tell if it saved anything. I neither see a confirmation save was done or if there was an error in saving and the web panel does not close. Did the save work? Also is there a code I need to manually update on the system profile that your instructions DID Not suggest other than perform a save? The enlighten id and enphase user id seemed to stay the same. I see the PRIMARY DEVICE as Enphase v4. If I have 2 system names do I have to do the login into EPHASE steps for both systems or does doing it for 1 take care of both? I did it only for the below system yet I see V4 refernence on both. On the Enphase site when successfully authorizing it said SUCCESSFULLY AUTHORIZED PVOUTPUT TO READ TO READ YOUR ENPHASE SITE DATA WITH CODE nnnnnn. I did nothing with this code otherwise.

I think the save wanted me to first enter in the by RETRIEVE the weather station location parms. The save worked after redoing the authorize. I DID NOTHING with the code the ENPHASE site mentions so the question stands…DO I need to use that 6 character code or did you take care of it automatically somehow?

The authorization is automatic after allowing access on Enphase.

Saving the PVOutput system enables Enphase v4 downloads. Saving only possible after successfully allowing access.

You only need to authorize for once and it will apply for all systems under your Enphase account.

Additional PVOutput systems under the same account won’t need to authorize again, just save the system to activate.

Note that “Enphase v4” is automatically chosen when you open an “Enphase v2” system, but still needs to be saved to activate.

There was a bug that won’t let you save the second Enphase v4 system, but that has now been fixed.

Actually once I authorized my 2nd system in my list successfully I went into the first system and it showed V4 which must be what you state is automatically shown instead of the v2 but maybe not yet actually saved…that could be a little confusing because that is what led me to believe it was auto done but based on your response you say I should still do a save which I have now done for my first system in the list. I will monitor both for some days. Thanks.

Yes, there is a PVOutput popup message with instructions to Authorize and save when you open an existing Enphase v2 configuration.

The change to v4 cannot happen without authorization Enphase and saving on PVOutput.

I have been using the v4 uploader for several months now but from 29 Sep I have not had any generation data loaded. I cannot see any issues on the Enlighten site and it is showing up to date data. Is there anywhere I can look to see if this is an issue with within my setup/pvoutput/enphase?

Enphase servers started returning “User is not authorized” for several hours and subsequently PVOutput disabled the download.

You may have to go through the authorization process again to reactivate. i.e. Revoke access from PVOutput, then click ‘Authorize’ button to login to Enphase and allow access, save the PVOutput system to reactivate the download with the new authorization.

Has anyone else seen any consumption data downloaded from enphase since 4:15pm AEDT 20th October - I’m presuming this is related to the scheduled maintenance mentioned in the enlighten app? Everyone else seeing the same thing?


I am see this also…


I saw also no consumption data since october 20th 7am french Time.
Any ideas about what happened ?

Hi. I updated mine from v2 to v4 last night and now I don’t show any consumption, only generation.


Tried to go back to v2 but it does not work.

Under “Enphase v4”, is your Direction set to Both?

1 Like

Enphase have delayed v2 decommission date to 18 Jan, 2023

Add me to the list of testers. I am using v4 atm, Still understanding how it all works. Thanks.

So as of yesterday my export is also showing as my my generation. This is not right as I am not exporting 100% of my generation. Previous to yesterday it worked fine.

I am using v4 of the autouploader.

Here is todays example:

4.753kWh 0.401kWh/kW 4.753kWh 5.209kW 8:30AM Cloudy 43 to 50F Updated 09:28 UTC-6:00