Xively and CurrentCost Energy Meter


#41

I can’t find that team


#42

Question for Bankstown Bloke. I have just changed over from using an Envir to download my data via Xlively to using a Rasberrypi and Measureit. It only took me 6 days but finally I’ve some data registering on PVoutput. Thanks for your great work in providing this service fror we sloar generators. My system number is 4879. Previously I had been getting my temperature data not from the Envir but from the weather station at the Adelaide Bureau of Meteorology. Now that I’m using Measureit the temperature data is being transmitted from the Envir. Can you help with this problem as I would again like to derive my temperature data from the BOM?


#43

In the search box put
UK Team
and you should see several teams starting UK.


#44

I put it in each sensor to start with and it didn’t work.
Then I read that in general you only need to put it in the System Settings, unless you want to direct some sensors to different PVO accounts.


#45

All I can suggest is the obvious and check the API key is correct. Failing that generate a new API and cut and paste that in.


#46

I created a new PVOutput account and got that working ok. Then went back to the original and tried again. This time it worked, but I don’t know what I did differently!
Thanks


#47

Only the API key and system id is required to access

Test access details by going to the following web address -


#48

Use the Weather Auto Upload device in the PVOutput system configuration instead of Xively.

The measureit temperature upload will need to be disabled.


#49

My system identifier is 4879. Thanks for your help so far. Your previous email solved one problem but now I have another. I have activated the Weather Auto Upload. I’m investigating how to disable the measureit temp via the Measureit Google forum. At the moment I’m getting a temperature pulse, on PVoutput, similar to a square wave.The trough represents the weather station temp and the crest represents the temp at the Envir. This is acceptable for the time being.

The problem that I would like assistance with is that my Conergy inverter uses a little power to keep the system alive during the time its not generating solar power. This power data is shown as solar generation during the night. Previously when PVoutput was receiving its inputs from Xliverly I was able to edit this generation out by using Xlively power rule. This feature appears not to be available under the Weather Auto Upload. The only adjustment I can see is under the Extended Data system rule. I can’t work out how I can reduce my solar generation using this feature. Can your provide any suggestions or is it another question for the Google forum?

Reg


#50

Hi

All good things come from Bankstown!

pv 11696

I have 6 years of data using the lively, PV system:(((((

I have a 4.2 Power one inverter 6 years old and 6.28kw system, gold coast qld

How can i get the power use/solar gen to record now, BTW I use Mac

Hope you can help

JOHN


#51

This was previously possible with Xively since PVOutput was downloading the data and was able to apply the rule prior to uploading and recording it.

The rule logic would need to be done in measureit before sending.

It is currently not possible to use the rule after data is received as this rule may have already been applied by the Auto Uploader.


#52

The current options are -


#53

I have my CC Envir showing it’s raw data on the c2 terminal. I have installed PV integration service but am not seeing any consumption data uploaded. Is there a step I missed? (I use ocley solar app to upload generation from my sma inverter)


#54

John942 I’m in a similar situation as to what you had. No data is uploading even though in the settings my API is correct (though no where to put the system id). I’ve tried adding the individual API and system id on the position tabs even though B.B. said it isn’t necessary but what the hell I tried that. Still no joy.

Ok here come a few stupid questions:

  1. On the Pi I added two sensors, number 1 for the power used and number 9 for the pv generated. I then added two positions which I’m assuming is another word for tab? I didn’t add a clamp. Is this right?
  2. On the Pi home page I have 3 sections, one called null and the other two I created. The null one I didn’t create and I can’t delete it. And it’s not reading any data (highlighted in red). Do you experience this.
  3. I think I’ve bored you enough so I’ll shut up

#55
  1. As I understand it, you only need one position for each sensor, unless you want to send the data from one sensor to more than one PVO system. I’ve been struggling with the positions, I find that if I create a new position its tab appears at the top in place of the existing tab for that sensor. Then I can’t get the original tab to reappear without deleting the new position/tab. Also, the new tab copies the settings from the original, then if I change the PV system ID in the new tab I can’t see if the original position/tab has retained its original settings. It doesn’t seem to, because with two tabs on my solar sensor the data is only going to one PVO system. So I’ve given up with positions, just keeping one per sensor.
    The extra clamps are if you have more than one clamp (current transformer) attached to one trasmitter sending data to the EnviR. The transmitter has three connections for clamps, I always thought they were just for 3 phase supplies.
  2. I don’t have a Null. I think that will be because you’ve added two sensors. I only added one for solar and used the existing Sensor 0 for my consumption. I’ve renamed the positions/tabs to Consumption and Solar, so I have Home, Consumption, Solar and Setup tabs. The sections shown on the Home tab are consequently labelled Consumption and Solar also.
  3. No problem, glad to try and help.
  4. I assume that you are following the instructions and clicking Save and Restart Grabber after changing the API and System ID settings.
  5. Some data seems to be appearing on your system NOW!

#56

Yes something has certainly sprung into life. Every change I made I did indeed save and restart grabber. My simple head is minced, but in short I have created two sensors on channel 0 and 9. Then I created a position for each. Then I added a clamp for each. I think B.B. will read this and marvel at my stupidity. But it’s working and I’m off to bed. Round 2 tomorrow when the sun reappears and the fun and games commence for the pv generation.
A big thanks for your help


#57

The serial port can only transmit to one receiver at a time, ensure the c2 terminal software is stopped and restart the PVOutput Integration Service.

Check the pvoutput.log under the logs folder file for errors / messages.


#58

Current Cost Xively Alternative Dashboard Real-time hub with free manufacturer’s dashboard and auto upload to PVOutput easily done. No pairing or unpairing of LCD Monitors required.


#61

BB do you have any ideas as why my solar generation stops uploading to PVoutput at the start of every day. When I look at the Pi web interface page, the solar power generation figures are displayed, as are my consumption figures, but only the consumption figures upload. I have tried restarting the grabber but that doesn’t seem to work. I then discovered if I delete a solar position, then recreate it and then restart the grabber, the solar figures then start uploading.
I’m out my depth with this, so a little help would be greatly appreciated.


#62

There is no reason for the data to no be accepted unless it is invalid, i.e. power or energy generation is too high for system size and time of the day.