Xively and CurrentCost Energy Meter


#1

I have a CurrentCost Envi energy monitor which uses Xively to store data (and this is, in turn, pulled to PVOutput).
Xively just announced that they are discontinuing their “personal” accounts. Does anybody know if this will affect CurrentCost? (I’ve sent them a message but it appears they are mostly dormant.)

Any suggestions for moving CurrentCost data from Xively? I’d be happy to just directly report it to PVOutput from my meter but this looks like it might be complicated/not possible.


Help with runnning on a Linux Server
#2

Mmmmm? Worrying as I too have a current cost meter to post my data to PV output. I’ll send them an email. Usually get an answer after a few days. I’m using data direct from current cost although I appreciate that they use Xively to host/transport their data.

Wonder if there’s an alternative?

Maybe I can collect and publish the data direct from my Fronius inverter?


#3

I sent Current Cost the notice from Xively. They didn’t know about the service disconnect.
We’ll see if they come up with something.
Meanwhile I’m exploring posting directly from the meter.


#4

From the following thread, the Xively personal service which Current Cost bridge data is uploaded, is set to be retried on January 15, 2018

PVOutput retrieves Current Cost data via the Xively feed which means, the PVOutput Auto Upload service using the ‘Xively’ device will stop working after the above date.


#5

I’m looking at trying to get the Envi meter to report directly to PVoutput.
One approach (more complicated) would be to reprogram the Arduino CC Bridge but this requires adding a boot loader and drivers for ethernet, etc. then send to PVoutput.
I’m thinking it would be easier to just use a Raspberry Pi Zero to read the serial output of the Envi meter, massage the data and send it to PV output. This seems much simpler. The serial output of the Envi is documented so a script should be able to read it and send it on.


#6

RPi would be the simplest solution - PVOutput Integration Service can be run on the Pi to read from the CC via serial port.


Current Cost and PVBC USB Setup
#7

I received the following reply from current cost.

We are currently in discussions with Xively to find a solution.

I’m sorry but I don’t have any more information to offer you at the moment.


#8

In the same boat here. I have used Home Automation Hub (http://www.homeautomationhub.com) to send the CC data to PVOutput via Xively for 4 years now. That has really been a set and forget project. Till now.
Just crossed my mind couldn’t CC send data to PVOutput via ESP8266. It has more computing power than Arduino, costs only a few dollars and connects directly to home router via Wi-Fi, no Ethernet needed. Did some quick research on the Internet. Only this link came up https://plus.google.com/+RoganDawes/posts/6TXHraQJMHB
I think many of us would be ready to pay for such a solution if someone could come out with it.


#9

I’ve been using an Eco-Eye uploading to Xively every minute and then PVOutput pulling the data from Xively, its been running great for years now. I can change it to upload directly to PVOutput quite easily (luckily) but my questions is that Xively seems to be doing the averaging of the 5 minutes to give us more accuracy. I upload every minute and when it gets to PVOutput its the average of the 5 mins, if I upload once every 5 mins to PVOutput direct I’m going to lose a lot of granularity. This must be an issue for others facing the same move from Xively no? Any suggestions?


#10

I’ve just moved over to a raspberry pi running the ‘pvoutput integrated services’ script to send direct to pvoutput.

https://pvoutput.org/help.html#integration-service

Chris


#11

Good to know that this works. I’m going to try to get this installed this week.


#12

I’m in the same boat i.e. exporting via a current cost bridge and xively. A raspberry Pi seems to be the way to go however I’m an electronics dumbo with enough computing experience to have setup the pvoutput window interface alone. I’m living in the eastern suburbs of Adelaide. Is there somewhere I could buy the required raspberry computer already setup to interface with the current cost Envir monitor. I’m worried about soldering the interface cable and the programming of the raspberry.


#13

I’d be very interested in the RPi solution if someone gets it working with the current cost bridge. I’m no expert so would need some good guidance to get it working. Hope the clever people get it sussed.


#14

Wrestling with getting this installed.
Since you had a problem with 1.5.2, I installed 1.5.1.1
When I run /bin/pvoutput.sh I get an error message:
Could not find or load main class org.pvoutput.integration.Controller

(I assume that this is part of the org.pvoutput.integration.jar file which is present in /lib )

The installation instructions don’t specify installation directory so I just put everything under /home/pi/pvoutput


#15

pvoutput.sh uses relative paths, it assumes ./pvoutput.sh is run from the installation directory i.e. /home/pi/pvoutput

Otherwise you can edit pvoutput.sh and replace all instances of …/lib with /home/pi/pvoutput/lib


#16

I don’t understand the situation.
I was running ./bin/pvoutput.sh from /home/pi/pvoutput and it couldn’t find the java file.
However, when I run ./pvoutput.sh from pvoutput/bin, it seems to find everything and start the server.
(Now I have a problem that I get a startup error invalid API key or site ID message and it shuts down. I’m using my site ID and API key and these appear in the log file.)


#17

Yes, it should be run from the bin directory where the pvoutput.sh script is located.

Check that the PVOutput system id and api key is the same as - https://pvoutput.org/help.html#api-getting-started


#18

There are two API keys. One for my account and another within the system. I was using the Xively API key from the system. It works with the API key for the account.

I’m now getting an error: (Seems to be trying to load a i686 version of librxtxSerial.so )

Java HotSpot™ Client VM warning: You have loaded library /home/pi/pvoutput/lib/Linux/i686/librxtxSerial.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It’s highly recommended that you fix the library with 'execstack -c ', or link it with ‘-z noexecstack’.
java.lang.UnsatisfiedLinkError: /home/pi/pvoutput/lib/Linux/i686/librxtxSerial.so: /home/pi/pvoutput/lib/Linux/i686/librxtxSerial.so: cannot open shared object file: No such file or directory (Possible cause: can’t load IA 32-bit .so on a ARM-bit platform) thrown while loading gnu.io.RXTXCommDriver


#19

Might have to download it using apt-get command as per @chrisstenton post below -

and https://www.raspberrypi.org/forums/viewtopic.php?t=12452#p287206


#20

I managed to apt-get the offending file. It gives a version mismatch on startup but the server seems to be running.
However, it’s not reporting data.
I’ve just about given up trying to debug this Integrated services application. It’s not ready for prime time and I’ve spent too much time trying to get it to work.
I think I’ll go back to my original plan. It should take about 10 lines of Python script to do the same thing.