Xively and CurrentCost Energy Meter


#21

Of course, I couldn’t just drop it so I dug into the log files and it seems the default configuration (localhost:8888) specified /logs for the location of log file. I changed this to …/logs (since it was started in ./pvoutput/bin and miracle of miracles it seems to be working!
It’s even capturing the temperature data but unfortunately, it’s thinks the reported value is in C so it multiplies by 9/5 to get an unrealistic F value. I’ve tried to change the temperature from C to F on the localhost:8888 page but it just keeps reverting to C when I save.


#22

So it doesn’t add 32 to get the proper F reading?


#23

Good to hear it is working.

In currentcost.ini add / uncomment

temperature-unit=F

This means temperature is recorded in fahrenheit on the device, this converted to C and uploaded. Set your temperature as F in PVOutput account settings to display temperature in F.


#24

Thanks very much. That took care of it.
Between my novice Linux skills and general confusion, this has been a difficult journey but it the result now is that it is working. I really appreciate the PVOutput site and community.


#25

Hi,

as I’m in the same situation just out of curiosity have you received any further replay from CC?
I’m about to send them email tomorrow when presumably our PV outputs stop reporting.
Thanks!


#26

Here are my notes on getting this running on Raspberry Pi.
I’m not an expert and this involved a fair amount of fiddling and head scratching.
This may be of use to others.

PV Output Integration Service Installation notes:

  • I used a Raspberry Pi 2 B which has wired ethernet port.
  • Install latest Raspbian image (full image)
  • Boot and use raspi-config to enable SSH and change password

I installed the files in /home/pi/pvoutput (subdirectories: bin, conf, data, doc, lib, logs, src)
Installation

  • Extract or upload the following directories from the installation -
    logs
    conf
    data
    lib
    bin
  • Execute chmod 755 bin/pvoutput.sh

Patch librxtx library
You need to patch the librxtx library with a newer version.
https://www.raspberrypi.org/forums/viewtopic.php?t=12452#p287206
Install Lib:
sudo apt-get install librxtx-java
Copy the file librxtxSerial.so from /usr/lib/jni/
to: /home/pi/pvoutput/lib/Linux/i686/librxtxSerial.so
(or create a symbolic link as in the forum post)
(On startup you will get a version mismatch error but it seems to work anyway.)

API Setup
sudo nano conf\pvoutput.ini and replace the values shown in red below
Request an API key from the pvoutput.org ‘Settings’ menu option
key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Your System Id is shown in the pvoutput.org ‘Settings’ menu option
sid=0

CurrentCost Configuration
Open conf\currentcost.ini and replace the port, rate and channels properties with your current cost device settings. (these were OK)
Example 1 - monitor whole house consumption
sensor=0
direction=in

Running
The install instructions say:
Run bin/pvoutput.sh to start the process. (but this didn’t work… I needed to:
cd ~/pvoutput/bin
./pvoutput.sh (or bash pvoutput.sh)
(sudo nano /etc/rc.local #add these lines to start automatically)

(may need to Alt-F3 to get a new shell)
startx (to start desktop)
localhost:8888 to view config page
change Log file location to …/logs

My CurrentCost meter is in F so I needed to change this:
In currentcost.ini add / uncomment
temperature-unit=F
This means temperature is recorded in fahrenheit on the device, this converted to C and uploaded. Set your temperature as F in PVOutput account settings to display temperature in F.

Reboot system


Help with runnning on a Linux Server
#27

I approached from another way than MSPOH’s detailed description. It has only taken me 4 days to work out and I’m still not completely setup. QUESTION BELOW. I downloaded the image file

https://mega.nz/#!nF9DzbSL!anydV-E2hABtLI08HOMt244XOgthb8ivmFH4NHX2wYA

from the lalelunet/measureit web page, copied it to a FAT32 formatted SD card using https://elinux.org/RPi_Easy_SD_Card_Setup#Using_the_Win32DiskImager_program, placed the card in the Rpi and turned it on. This installed Raspian lite without a GUI which I then found on the Web and installed. I then went to my laptop, typed the IP address of my Rpi into the menu bar of my browser, and there, low and behold, I was connected to the measureit web page. I still haven’t connected to pvoutput as I’m waiting for a new serial cable to arrive so that I can connect my Envir to my Raspberry.

QUESTION
The Measureit PVoutput setup asks me to insert my PVoutput API code which I can’t find. How do I find this? When I click on the size of my system below the production graph I only get information as to the sighting, number of panels etc no other setting information is shown.


#28

Click on Settings in the top level menu and it will be toward the bottom - scroll down - you may have to ask for a new key since it hasn’t been used before. Also enable it of course - make sure you save afterwards.


#29

See https://pvoutput.org/help.html#api-getting-started


#30

Can anyone help me with my configuration as I was trying to revert from the bridge to usb and somehow have stuffed up my setup in PVBC and it has now stopped uploading to PV output?


#31

Just wanted to share my positive experiences with Measureit. If anyone is experiencing difficulties uploading CC data to PVO with RPi it is definitely worth to take a look at https://github.com/lalelunet/measureit
Very easy to set up, great user interface, works out of the box. I set it up yesterday, works like a charm.


#32

I have been able to get the configuration for the solar generation working any tips for the consumption / Current Cost usb configuration in PVBC?


#33

Hi All, I have a contact Email for who appears to be the only person currently working for Current Cost in the UK. I Emailed him last night and his reply is below. I’ve spoken to him in person before and he has been VERY obliging, I think this is a big shock to him too.

Dear Graham,

I regret to inform you that on January 15th 2018 LogMeIn shut down the Personal Xively server.

As a result the ‘my.currentcost.com’ online portal and all redirected portal services will cease to operate, we apologise for the short notice, but we have only just been made aware.

We are currently looking for a replacement server and hope to have news shortly

Please accept our apologies for the loss of service.

Kindest regards
Steve Messenger


#34

I know absolutely nothing about how to program a Rasp pi. I have however got my hands on one and downloaded what I think is the program, unzipped it and that’s as far as I’ve got. I haven’t got a clue how to “run it”.
Also how do I plug the EnviR into the Pi? Is it via the enerthnet connection or do I use an ethernet to usb cable and plug it into a usb port in the Pi?
Apologies for bothering you, but a few seconds of your time will save me bloody hours of faffing.


#35

Hi,
Looks like I’m about 1 day ahead of you on this :grinning:
You need a CurrentCost data cable to connect the EnviR to the RaspberryPi USB. I already had that.
Using a PC you need to flash the measureit image file onto the SD card. I used a utility called Etcher to do that.
Put the SD into the RPi, connect everything up and switch on. You don’t need a keyboard/monitor/mouse on the RPi because you can’t do anything direct, apart from see the bootup progress.
Now remote onto the RPi from your PC, maybe at 192.168.0.102 but mine isn’t so I used Advanced IP Scanner to see the IP addresses of everything on my LAN, and you will see your Measureit.
That’s where I’ve got to, now I’m struggling to connect it up to to PVOutput :frowning:


#36

Really appreciate that. I’ll crack on with it tomorrow


#37

You’re welcome.
If you manage to get PVOutput running again, perhaps you could join the UK - Yorkshire team?


#38

How do I link PVOutput to my Raspberry Pi running measureit?
Measureit is showing the data from my CurrentCost EnviR.
I have generated a new API key on PVOutput and entered it in System Setting in measureit.
This isn’t working. Is there something else I need to do?
@bankstownbloke


#39

Have you entered the PVOutput System ID into each of the sensors settings, Restarted the grabber and then refreshed your web page. I also initially missed the sensor type box at the bottom of the sensor settings which requires you to set whether the sensor consumes or produces power.


#40

Had an issue with the image not working. In the end I flashed the microsd again and the Pi sprung into life. I can now access the Pi via the web address. I noticed that the PV API key needs to put input for every sensor and on the system settings as well (this has just been mentioned by another chap).
I have yet to connect my EnviR because I just connected to the wrong power pack and fried it. If I was to say I’m stupid it would be derogatory to stupid people. So I’m waiting for another EnviR to arrive. What a &£*#ing idiot.