PVOUTPUT Not Showing Full Enphase history for 3/29, about 3hrs behind


#1

Seems PVOUTPUT is not able to or is having issues extracting the full days worth of data from ENPHASE via its API. Seems the last reading is off by bout 3 hrs or its slowly getting the data from enphase for some reason and I hope it catches up before mid night NY USA east coast time.
Its 6:10pm now and the last reading was 3:10pm in pvoutput for example for this system.
And enphase has all my data sent to it up through 7pm NY time.


#2

me 2 !! my output stopped at 12:00 noon Los Angeles Time and no updates since. I’m also Enphase : (
My Enphase apps are all working ok though getting data from their db with no issues.


#3

I’m west coast united states and my last update is 12:05 PM today 3/29.
Enphase local data is working.


#4

Snap. In Sydney nothing showing from Enphase from 06:00 :-1:

image

Enlighten is fine :-1:
image


#5

In Melbourne Australia have consumption on which has a last update 6am Melbourne time. So almost 7 hours ago.
Snap uinvestigate
so 6AM for you as well.
I played revoking and re adding no luck


#6

me three…

I’ve also removed and re-added the API auth to the system, but no dice… I’m assuming there’s an issue with the Enlighten API, but don’t have the smarts to find out aside from knowing that PV Output isn’t working as it was …

my generation numbers stopped feeding in at about 6am AEST…

@bankstownbloke - do you know if it’s a Enphase thing or a PVOutput thing?


#7

Bloke, in my first post I noted that all data is shown on my Enphase web site as being received up through 7pm last reading from my home. So yes the enphase site shows me all my data. But the pvoutput api is only showing readings up through the time I noted for the sample system. So whether or not its your access to enphse via its API or enphases API itself IDK.
As a side note and unrelated to this API I noticed an alert on the enphase site top banner suggestion that field reps were having conenct problems with their field tools so just wondering are you having connect issues too nut for retrieving the data you get for pvoutput?


#8

To make it worse not only did yesterday Friday never atch up its 9:45am NY time Saturday and it has not even shown up on PVOUTPUT yet my home generted “Today 1.92 kWh” on my enlighten and matches what enphse web site shows me live and not yet on PVOUTPUT. So there is indeed API problems either on PVOUTPUT side or Enphase handling your request.


#9

me too. exact same symptoms in San Diego.

will try manual backload method.

–kevin


#10

backload worked. lost the eagle data though.


#11

Same problem here in the San Francisco Bay Area since before noon yesterday. I checked locally and I can still get data from Enlighten API so it seems to suggest the problem is on PVOutput side. Eagle data is also missing from PVOutput for most of yesterday but it restarted late yesterday.

Does anyone know of anything that can collect data locally from Enlighten and Eagle and backfill PVOutput as needed? It’s a PITA to manually backfill data.


#12

i wrote a perl script that pulls from enlighten and loads to pvoutput. in runs under ubuntu. wrote it 5 years ago. dont remember all the library linkages tho. uses enlighten API and PVO API. thats how im backloading.

–kevin


#13

It seems we are hitting the monthly request limit with the Enphase API key used by PVOutput.

The workaround for now is to reduce the polling time to Enphase from 15 minutes to 30 minutes.

Based on the error responses the limit will reset on the 1st of April


#14

Any update about this error?


#15

See the comment above, Enphase will re-enable downloads after 2019-04-01 00:00 UTC

A request to Enphase has been made to increase the monthly quota for PVOutput, this may or may not be granted. In the meantime, polling rates to Enphase has been reduced to 20 to 40 minutes.


#16

Thanks for the update. Do you expect the data to catch up after April 1, or should we expect to have to manually export from the Enphase site and backload here?


#17

BLOKE, I am a little confused. At one time Enphase went to a storage timeline of more than 5 mintues for new systems in their storage area causing our PVO bell curves to look like steps for a given day, but I will say I was one of the early adopters and they allowed for 5 minute captures from my home to their site and reset storing it as such. Then you read their site via API to store in PVO. So up to this month what has changed specific to my system? And when you say change the reading interval from PVOUT into Enphase site are you saying to change the reading interval in LIVE SETTINGS STATUS INTERVAL from 5 which I have now to i.e. 15 or 20 for each system I may have setup to cut down on the number of reading calls you make to enphase? And if I did will you still be getting all the data of my stored 5 minute intervals from Enphase which I know they have though it would now be delayed in the new PVOUT interval setting of 15 to 20 minutes pickup? Or what am I missing? I dont care if it takes less calls further apart to get the data from enphase but by the end of any day I want to ensure that PVO gets all my 5 minute interval data from Enphase as the goal.


#18

I guess it’s good that there’s enough new Enphase sign-ups for this to happen (that’d be me, sorry folks!)

It’s loading live data again now, however it only seems to have back-loaded the last 24 hours (ie from 10:10AM yesterday, Darwin time). I’m guessing that’s just a setting within the query, as the historical data is still there in Enlighten… Would it be possible to extend the backloading to also cover the whole previous day we’ve missed?


#19

Mine still not working noticed other systems around me are.
Revoked and re added twice
Is there still a problem


#20

Unfortunately a manual backload is required, only the last 24hrs will be retrieved.