Fronius Push

Sorry there was a change around handling negative consumption on the auto=1 parameter which doesn’t seem to work very well with the push data from your system.

The change has been reverted back.

Looks normal again this morning. Thanks!


Can someone help with the push data

i have put in both inverter and log data


there’s a parameter nodayenergy for inverter. what does this do and do i need it? im guessing i just put &nodayenergy=(0 or 1) at the end of the link

now is the log data to show the correct averages and update it if anything hasn’t be added??

There is 2 parameters Mode and auto. do i have to set them and if so to what?

I have the inverter connected before my metering device so it is gross consumption
i have a flukso to read my gross consumption

so i need the setup to show all generation then work out how much was import or export.

also the metering device i have hooked up to the flukso is a pulse output so could that actually be connected to the Inverter in meter setup as the “S0 Inverter 1” instead of the fronius smart meter and get all the benefits of having them both hooked in together?


@B-Man this is the line in my inverter (Note NOT meter):

And this produces the green line in

If you’re running the latest version of firmware in the inverter (in ‘system information’ tab mine says 'Software version 3.10.2-1 ', and the firmware update button says theres no newer firmware available) then the ‘day energy bug’ should be fixed, and so you probably want ‘dayenergy=1’ to get the inverter’s idea of what cumulative energy has been generated, rather than have PVO calculate it from the 5-minute power values.

I think the ‘mode’ and ‘auto’ parameters are only relevant to meters, not inverters, so I’m not using them in my inverter push settings.

(more on ‘day energy’ - the data retrieved from the inverter each time includes current instantaneous power (PAC), and cumulative energy generated by the inverter for the day, for the year, and for its total lifetime: see Fronius Push above for what this looks like.
In older firmware, the DAY_ENERGY value had issues, so a flag was put in to the push URL to prevent PVO using it, and instead have PVO calculate day energy from the power - this is the ‘nodayenergy’ flag. The bug seems to have been fixed, but the default is now to not use the DAY_ENERGY value, so ‘dayenergy=1’ is required to make PVO read the DAY_ENERGY value rather than recalculate it from scratch, which introduces errors if a sample or two is missed, and if the power varies significantly between 5-minute samples).


yes updated to the latest version
appears to be running fine with the Inverter and log data. i setup.

I did add the &dayenergy=1 to the inverter push and all still seems fine. thanks.

ill be looking at hooking up my smart meter ABB B23 pulse output device to the fronius just unsure if i will use that or continue using the flukso to post my data. depends if it works as expected or not.

Can somebody please summarize what the best inverter and meter push settings are for a Fronius Primo running the latest available inverter fro28500.upd and datalogger 3.10.2-1 firmwares?

The defaults should work fine, if the firmware has fixed DAY_ENERGY issues then add &dayenergy=1 to the inverter push.

The ‘Log Data’ push should be added if account is donation enabled.

is there somewhere that shows the parameters you can use for the inverter push, log data push and meter push.
and apart from that is the link the same?

i saw someone had voltage in theirs

The inbuilt Fronius uploader doesn’t report voltage. There may be a different monitoring system using an external PC/Pi/something that extracts deeper data and then uploads it to PVO, or it might be a different brand inverter (SMA or something) that does report voltage somehow. My voltage comes from the Tesla battery, not the inverter (or it did until the last Tesla firmware update, thats had my extended data broken for two weeks grr)

Yes it does, although for some odd reason PVO does not show it by default. You have to add &v6=Voltage_AC_Phase_1 to the meter push to get PVO to display it.

Bulletmark hi can you tell me more about how to add voltage as above as i have no idea were to add the &v6=voltage_AC_phase_1 to the meter push to get PVO to display it, thanks in advance for your help as i am NOT good with any sort of this tec stuff.
well i have no smart meter so thats me stuffed with that idea pitty as it would have been very helpfull to have volts displayed as its so verable here 228 to 258 is common any day

Jim, add an inverter push setting as described at If you have an attached Fronius smart meter, you should also add the meter push as described there but add &v6=voltage_AC_phase_1 at the end of the “Upload File Name” string, i.e. after <your_key>. Note you can not see voltage unless you have a smart meter.

Have been watching recent advice with interest. Took a deep breath and attempted to improve my push settings.

with the &v6=voltage_AC_phase_1 on end of meter push I can now see voltage. So that’s all good.

I had &nodayenergy=1 on the inverter push. Checked the software version - it’s 3.10.2-1 - so changed it to &dayenergy=1. immediately started getting zero readings with occasional peaks. Left it running for a couple of hours but problem persisted. So I’ve changed it back.

Am I misunderstanding the inverter setting somehow?

After changing to an energy counter, you really need to wait for a new day to see it working correctly.

Great. Will change it back and be more patient.

Much appreciated.

Just saying thanks… all fixed now.

It makes perfect sense… waiting for a new day… I clearly wasn’t thinking carefully enough about it.

i have an S0 meter connected not a fronius one though and it doesn’t work for the meter push settings. it does show me the solar, import and export on the fronius page but that’s it. so if your after the meter push its best to get the fronius meter rather than a pulse output meter

I have two arrays (or is it two strings?). An older set of panels and some more recently installed ones or higher capacity - both sets hooked up to the Fronius Primo 5.

With help (on this thread), I now have reliable and accurate (as compared with output from Smappee) readings on PVOutput. But I know I have some morning shading. I did try flying a small drone up to see how bad it is and which panels… so I can work out which trees to trim. But wasn’t very effective strategy.

just had a look at adding extended values (can’t see any relevant settings) or an extra push - eg Current Data - String Control (but Fronius says connection not possible).

Is this something that can be done?

As far as i can tell you cant get string control from the push or fronius php (that uses api)
Its obviously possible as the fronius solar web can display it but we don’t have access to the data they retrieve it from. I did hear you can get it from the modbus but haven’t looked into it.

If you want extended data and don’t have a smart meter you can use fronius.php on a pi or whatever is available. i have modified one called fronius ultimate php Fronius PHP Ultimate
That lists out all options you can get from the api and send whatever you want to extended data