Fronius Push - Inverter DAY_ENERGY not increasing

The nodayenergy parameter has added the PVOutput Push Service to handle a bug in the Fronius firmware where the DAY_ENERGY data does not increase, while power (PAC) is reporting above 0W.

On the inverter push config add the following to the end -


This will allow PVOutput to ignore DAY_ENERGY from Fronius and calculate energy from power reported.

There has been reports where the consumption calculation was reported at 0W during the afternoon when using the auto=1 option on the meter push.

This was due to inverter not increasing generation data, resulting in the export reported by the meter push to exceed the generation.


Thanks, testing now, will see how tomorrows data goes.

I’m currently not seeing any consumption data on my test system. Should the urls be:

Current Data - inverter

Current Data - Meter

There is no generation values yet, would that be the problem?

The inverter config should not have auto=1

    Meter: auto=1
    Inverter: nodayenergy=1

Production seems to be correct so far, very close to Solarweb and my own script, but it is 0.16 kwh to high.

However it didn’t start registering consumption until 7:45am, starting at 0 - so its over 1 kwh to low in total.

Ich added the Parameter on Inverter right now. I have 4kwh more than solarweb. 5min Intervall.
Maybe tomorrow it works? But what if peeks between the 5min Intervall? It can’t bei right with the Parameter…

ok, at the end of day, it’s only 85W difference… seems to be good.

Found that as well, when I checked yesterday mid-afternoon after adding the parameter first thing in the morning I was seeing PVOutput showing 4 kwh over Solar Web so far for the day, but looking now at the end of the day I have 32.56kwh on Solar Web and 32.690 on pvoutput ¯\_(ツ)_/¯