Fronius - Logdata Push Failure


Hi. Thanks wattmatters. When I checked this morning it was behaving normally again. Just one of this things I guess.


Mine’s been in “Connection not possible” state for weeks.


According to the information at

The Fronius Log Data Push is indeed only available in Donation mode.


Hey sorry to dredge up this old post but it’s the only reference I can see to “Connection not possible” which is what I’m getting at the moment.
The wifi connection to my inverter is solid but I’m not missing a lot of uploads to pvoutput as a result of this problem.
I’m a donator and am pretty sure I’m still current.
Is there a way I can test the API connection?


Saving the Fronius setting tests the connection.

‘Connection not possible’ means the URL is incorrect check the sid and key values.


Hey Bankstown Bloke,
That’s the thing, it does this intermittently. The URL does not change but sometimes it says Connection not possible, and other times it’s fine.
I’m not able to identify any pattern but it can miss hours of uploads sometimes.
Network diagnostics on the inverter come back positive, I can have a solid ping to the datamanager interface with no dropped ping packets.

If the SID and KEY values were incorrect, would it not fail every time?



If the connection test works then the cause is likely an intermittent internet connection issue. If you enable the hourly Log Push then the gaps should be filled in each hour. Other sites are pushing fine.


Hi AndrewF,

My Fronius inverter connects wirelessly to my router - straight-line distance is around 5m but there are a few bricks walls in between. I find that with the LOG PUSH disabled I wind up with lots of gaps in the data. Oddly I have a Raspberry Pi which manages to wirelessly PULL data from the Fronius without any issue. This suggests [ to me ] that the inverter times-out quicker and gives up more easily on PUSHING data.

I have a friend with an identical Fronius inverter to mine. We ran shielded Cat 6 from it to his router because of the greater distance - it has worked flawlessly i.e. there are no missed data.


Hey Grannos,
Thanks for the info.
I think you might be onto something relating to the inverter timing out. The wifi is solid. Low latency, no drop outs. Yeah, it’s wifi but the signal is strong and reliable.
Running ethernet is not really practical for us right now.
I feel like this is a relatively recent development and wonder if it’s related to a datamanager firmware update. I can’t remember when I did my last one but this is definitely a new problem which never happened previously.
Anyway, it’s a shame but at least it updates at the end of the day.


Hi Andrew,

Yes the Ethernet option is a bit of a pain. You could use a pair of Ethernet Over Power adaptors with one near / adjacent to the Inverter. Or like me wait for the Log Push to clear things up. Most strangely the 09:00 WST [ +08:00 ] PUSH from the inverter fails EVERY single day. The 10:00 LOG PUSH cleans up the missing entry. I am not sure what’s so special about 09:00. If it were 08:00 instead [ 00:00 UTC ] I could understand that some strange roll-over problem was occuring.

The only other Ethernet issue is getting the cat 6 cable out of the inverter itself. The case design would require the cat 6 to go out through the bottom gland, if available, or our the back of the inverter into the wall cavity.

My Raspberry Pi however manages to run an API call against the inverter every minute without interruption! [ This data is for my own purposes only ].

20191114, 08:58, 3325
20191114, 08:59, 3356
20191114, 09:00, 3370
20191114, 09:01, 3377
20191114, 09:02, 3410
20191114, 09:03, 3436
20191114, 09:04, 3445
20191114, 09:05, 3459


FWIW, my Fronius Primo 6 is connected via WiFi, and I rarely see any dropped samples - would be unlucky to have more than one a month.
Do be aware that it can only connect using 2.4GHz frequencies as wireless-n or wireless-g - and this band is often impacted by interference from nearby WiFi, and microwave ovens. Because the inverters are often mounted on an outside wall, they don’t have the shielding from neighbours wifi on the same channel that devices inside the house enjoy. If you have a microwave oven nearby, or worse within the line between inverter and base-station, you may lose the signal whenever the microwave is in use.

Perhaps use one of the mobile-phone wifi monitoring apps like ‘Wifi Analyzer’ and stand next to the inverter, and see if there is a different channel you can switch to with less interference from nearby other basestations.

The inverter shows the signal with only a 3-bar strength meter - this shows the neighbours ASUS signal on channel 10 is stronger than my own on channel 13, but it still cuts through OK because they are enough-separated channels:

What signal strength (out of 3!) do your inverters show the signal at? and does the inverter see any others on the same or within +/-2 channel numbers?


Another possible solution to improve your WIFI connection is to get and extension cable for the WIFI antenna on the inverter and a high gain antenna then route the cable and antenna closer to you WIFI (router.) Alternatively you can get an Access Point hard wired to your router and position it closer to your inverter. Either way you would have to rout some cable somewhere in you home. I installed an Ubiquity Unifi AP and I now have 2.4G and 5G all over my 4700ft^2 house improving all my WIFI connections.
Ubiquity is an enterprise level company and may require professional installation. I opted for their EdgeRouter4 as well but I had to use an expert to set it up properly. My whole WIFI has improved by orders of magnitude.
However, you should realize that the Unifi AP has both 2.4G and 5G radios and you should consider making the Unifi AP your only source of WIFI requiring you to disable WIFI on your router for better connections all over your home. Before doing so you should move all your WIFI connections to the Unifi AP.


I only get one bar but have no issues.


LOL - I recently put three Ubiquiti basestations through the house as well, as the kids (both at Uni mind!) kept complaining we had ‘the worst wifi in the suburb’, and I’m in the comms industry. What is very odd, is the Tesla battery gateway refuses to maintain a stable connection to any of the Ubiquitis, so I had to re-enable the router’s WiFi specifically so the Tesla battery would stay connected to the old wifi, while everything else is connected through the new system. Go figure!


Since the Ubiquity equipment is meant mainly for office or enterprise networks. I did hardwire the Unifi AP to my router. The set up is not dumbed down to be used by ordinary folk so I had to have my grandson install mine. It took him quite a while to set it up properly. The original installation included my old d-link dgl-4500. There were no problems except with the two wifi’s operating I opted to replace the d-link with the EdgeRouter 4 as well. My grandson did the switch out of routers and all is well. All my wifi goes through the Unifi AP and I get reception in almost every corner of my large two story home. However, I don’t have a Tesla battery. I do connect to two IP cameras, a Blink Base with 5 cameras, A Neurio (now Generac) net consumption and solar Production meters and a couple of smartphones. No problems with any of them losing connection for any extended periods. Here is my network. All these connections are on the 2.4G network but my smartphone can connect to the 5G as well.


Just thought I’d chime in with an update. I was running my 2.4ghz wifi (also ubiquiti NanoHD with an Edgerouter4) on channel 6 so I thought I’d force it on to 1. Even though there is more congestion on channel 1, I am not getting any more dropouts. From a monitoring standpoint, the quality of the connection at the network layer is the same. no dropped pings, same kind of latency.

Signal strength on the Fronius is showing 2 bars but before I had my Ubiquiti stuff it only had 1 bar and was fine.

So I have determined that using the least crowded 2.4ghz channel is not always best. If anyone else is having issues like this, try a different channel for a few days and see if it helps.


I have pretty much the same result. It seems that everyone in my neighbourhood is on Channel 6 and things seem fine. I tried switching my 2.4G to channels which had no traffic and did not seem to overlap any but the performance of the network didn’t seem to improve so I switched back to the Auto setting and back to Channel 6. Go figure.


The lower the channel the lower the ghz (albeit only slightly) can help with penetration through objects.
the other thing is if someone is on channel 2,3,4,5,7,8,9,10 it affects all the others on channel 6 aswell where as channel 1 is only affected if others are on 2,3,4 as there is more noise if someone is crossing the channels.


So this is happening to me again.
I’ve tried Channels 1, 6 and 11 with varying bandwidths. Nothing seems to really help./
There is no packet loss to from the diagnostics screen on the fronius. There is no packet loss from the router to the fronius either, so I’m not sure what the problem is.

The fronius seems to report back to solarweb in real time but the push service has repeated problems uploading to pvoutput.


Hi AndrewF,

Does your Fronius get its IP address from your router using DHCP? If ‘yes’ what’s the lease period for the DHCP scope?

If it is a fixed IP is there a chance that it is ‘colliding’ with another device on your home network? If the Fronius IP address were inside the DHCP scope that could cause problems with duplicate IP addresses.