Eagle 200 stopped reporting


#1

My Eagle 200 stopped reporting and I can not seem to get it back. I had it set-up as my primary device, wit my EKM v1 as my secondary. It last reported on 30/05/20 @ 03:50. _ am a new user, however, the system had been working for the previous three days. The only changes that I remember making were to the tariffs and the units section. I have tried pushing from the Eagle 200 and letting PVOutput collect the data via my cloud ID and log-in credentials. Any suggestions?


#2

Mine is doing the exact same thing. It also stopped at the exact same time as yours. Are you using eagle post via the “https://pvoutput.org/service/r2/eaglepost.jsp” command? when i looking in my eagle settings it is showing an error that the destination is not valid. On the surface this appears to be a PVOutput issue, but i am still looking for the data to find the true culprit.


#3

i think it is the certificate problem mentioned in this thread, and heaven help us - it seems that rainforest has to do something on their end to fix the problem…


#4

Yes, I also have PVOutput set to gather the info from Rainforest. Thank you for responding, when and if I find solution I will post it.


#5

I seem to have found a work around by uploading Eagle 200 to Wattvision and then having PVOuutput gather data from WattVision. PIA but it will work until Rainforest solves their problem.


#6

Doesn’t work for me at Wattvision either.


#7

Is this configured on the Eagle device or on their portal? Is there an option to switch to plain “http”?

The issue with the expired root certificate on May 2020 should still only affect very old devices.


#8

well i have the newer eagle, running 3.11.6.460 (no idea if this is current) and the push service stopped working for me too. as far as i understand it, for this device, all configuration is done in their portal and then it is sent to the device.

you can configure a “custom” destination and set it to http, but since the consumption data is somewhat of a proxy for whether or not the house is empty, i’d rather not send it unencrypted…

edit: i just re-added the built-in PVOutput cloud service to the eagle (https) and it started working. yesterday and the day before i had tried re-adding and it was stuck at “initializing”. so i guess rainforest fixed something on their end?


#9

Added some special sauce this end -


#10

I will give it a try, thanks for your help.


#11

thanks. only thing is i don’t understand what you mean by “very old devices”. are you talking about firmware revs or particular revs of the eagle hardware? because as far as i can tell, eagle-200 is the current product from rainforest, and that is what i have.


#12

My Eagle 200 is about a month old however, went through the set-up again and it is working now.


#13

My Eagle-200 stopped sending data at exactly the same time. I logged a ticket with Rainforest support.

The PVoutput upload over the weekend showed a status of “initializing”. I deleted the upload and re-added it, with the same result. This morning, I see the status is now “OK”, but it’s still not uploading data to PVoutput. Strangely, I now see some bogus consumption data for this afternoon. I have no idea how this happened. I’ll post here when I get a response to the support ticket.

Jason

Capture of my consumption data on PVoutput. Capture was at 10:45 am. I don’t know where the bogus data came from.


#14

i’ve got one sample that’s in the future - 2:55PM - since this started working at around 8AM this morning (pacific daylight time USA). i don’t know where that came from… i wonder if you might have one like that hanging around that’s messing things up? in my case even though the sample is there everything seems to be working right, but i thought i would mention it.


#15

My eagle-200 started to work again this morning at 7:45 am PST. I did not have to re-enter any of the data push URLs on the rainforest webpage. My entry on the rainforest cloud web page was saying “Initializing” just like everyone else. This morning it changed to “OK” and started working all on its own.

Thank you PV community for spotting this issue.


#16

I received this from Rainforest this morning:
Hello Todd,

Thank you for contacting Rainforest Automation Support.

Our support team noticed that your device’s firmware was not up to date. PVOutput’s SSL certificate also got expired which is why you were having issues with uploading your data. We have updated your device and it is working properly now. Please let us know if the problem persists; we will be more than happy to help you.

Kind regards,

Rainforest Automation Support


#17

I received a similar message from Rainforest. But the data that is showing up at PVOutput doesn’t look correct. My net usage is showing up as roughly zero, when I’ve been running about -3kW net consumption for the last hour.

I’ll continue the dialog with Rainforest Support.

Jason


#18

My response from Rainforest Support was just “we looked at your device and everything looks OK” But I had removed any cloud connections yesterday since neither PVOutput nor Wattvision were working.

So I don’t know if they updated my device or not. I know they logged into it around 10AM since I see the 15 minute gap in the Rainforest cloud data.

Once I read that BB had fixed the certificates at his end to accommodate the Eagle-200, I added PVOutput.org back into the cloud servers and I finally got an OK on the Settings>>Cloud page instead of “initializing”. Looks like I have consumption data again.


#19

I removed the PVOutput upload and re-added it. Everything now seems to be working properly. I don’t know if it was re-adding the cloud connection or PVoutput updating their certificate, but everything magically started working a short time later. I suspect both were necessary.

Thanks everyone for your help!

Jason


#20

I think it was both. The system had to purge the old configuration and get a new one with the new certificate in place. I had purged the system multiple times before trying to fix the issue and that was always ineffective. Once the certificate was in place, things just started working again for the most part.

I had to add the summer tariff rate in multiple times though as it got confused and had all data in the peak period starting at midnight. So I lost a couple of days of accurate data.