Cumulative extended v7 and associated credit tariff

Hi,

this is my first post, so please forgive me for my lack of knowledge about PVO, I only started some days ago and still reading the docs. :slight_smile:

I’m uploading all v1-v6 (through HA/Node-Red, pulling data from my Elios4You meter) parameters since 5 days and added my export tariff and consumption tariff (both flat, so no need to set dates/times luckily).

I have a state incentive plan that credits me 30 cents per kW/h exported plus 20 cents per kW/h autoconsumed. I pay energy 16 cents per kW/h, flat.

I wanted to configure all this in PVO to double-check what I should expect for energy credits and debts and double-check what supplier bills me and state agency credits me.

In order to do this, I’ve added to the above v1-v6, the upload of cumulative lifetime autoconsumption energy (v7) together with actual/interval autoconsumption power data (v8).

While configuring v7, I was looking for the c1-like flag, and I thought I found it: “Calculated as: Uncumulate”. I also added the Credit option, so later I could add a specific tariff (0.20/kWh) like docs mention. This is the config for v7/v8:

Since I wasn’t sure about the Uncumulate setting, I looked at the docs, and found this:

image

Nice, it confirmed that the option would consider v7 as a cumulated parameter. But…I read the note at the bottom, that recommends not to upload live data to calculated fields. So my doubts remain, did I configure the two parameters correctly?

The second question is related to the tariff: under the Edit Tariff section, I can’t see the v7 parameter to which I’d like to link a credit tariff, so that the total credit/debt balance calculated by PVO would reflect the reality of the financial energy balance. Did I miss some config steps?

image

For the first post this is about it, I have a lot of questions but I will gradually answer to those myself while studying the docs and reading the forum.

Thanks a lot for any help, and sorry for the length of the post.

Alessandro

When sending a cumulative / lifetime value, this option will reset each starting value to 0 for the first value of the day.

  • day 1, v7=10000 8:00AM, result v7=0
  • day 1, v7=15000 6:00PM, result v7=5000
  • day 2, v7=20000 8:00AM, result v7=0
  • day 2, v7=25000 6:00PM, result v7=5000
  • etc…

This setting is doesn’t affect the credit/debit setting which is used to if you wish to calculate debit/credit tariff on an extended parameter and add it to the total daily balance.

After enabling either credit or debit on v7-v12 and saving the system details, the tariff rate corresponding to the parameter will appear on the tariff page -

image

Yes that’s what I imagined, so I can upload to v7 even if it’s a “calculated” field? Because in the notes of the docs it says not to upload to calculated fields, just want to be sure I’m doing the proper thing. :slight_smile:

Now I see the field on the tariff page, when I configured the v7 field and I checked in the tariffs section, it wasn’t there. Maybe it takes some time/some uploads before the field is visible.

So, since I have a flat tariff of 0,16 for energy import (debit), 0,308 for energy exported (credit) plus 0,206 for energy autoconsumed (v7), I configured the tariffs like this:

can you tell me if it’s correct?

thanks a lot for your help,

Alessandro

That looks fine, the extended data rates only support flat rates however.

I have the following rates:

  • flat rate credit for export: 0,308/kWh
  • flat rate credit for autoconsumption: 0,206/kWh
  • flat rate debit for import: 0,16/kWh

If what I configured is correct, the subtotals I see in the summary for each day are not correct, they don’t take into account the v7 credit.

Thanks for the help.

Currently the credit/debits of extended parameters are shown separately and not added to the main balance.

The credits are appearing for the extended parameter on the Extended data ‘Daily’ view.

In future, there will be option to show the extended and main balance together.

Can’t find this view. Do I have to customise the Daily View?

It would be great to see all credit columns, all debit columns, and the sum of that. Also in the Compare plan view.

Thanks.

  • Click Your Outputs
  • Click on Extended Data view, 5th square below graph.
    image

See Daily Page — PVOutput documentation

Ok, thanks.

Something’s wrong though, I’m uploading this:

image

My meter gives me everything in kW and kWh, so I convert to W and Wh, then I export to v7 and v8.

This is how I configured v7/v8, tell me if it looks ok:

For June 9-10 I read:

Is the dot a decimal or digit separator? I configured the comma as decimal separator in the options.

The credit tariff is 0.20 per kWh, so it should be €4 not €40. I configured the v7 credi tariff like this:

image

Maybe it’s not cents like the note under the field says?

Thanks.

I changed the credit tariff for v7 like this:

image

Then I recalculated for all days in June, but the credit totals didn’t change.

The v7 unit should be “Wh” instead of “kWh” and no modifier required.

Using “kWh” will automatically multiply the tariff by 1000.

I am uploading Wh. I just used the Unit to display in kWh. It says “Graph data display formatting, does not change upload data”.

Anyway, I changed to Wh the unit now, and recalculated, I don’t see any change:

Change the v7 summary from Change to Last, this setting affects how the credit/debit is calculated but results in the same daily summary result.

‘Last’ will multiply the tariff by the last reading of the day, while other summaries except for ‘Sum’ will add the tariff for all data points this should not be used for cumulative data sets such as energy.

1 Like

The total balance (extended balance + main balance) is now available on the extended daily page -

image

1 Like

So I did as you said, modified to Last. But the daily totals I see are still wrong.

These are the configured tariffs:

image

This is the v7 configuration as per your instructions:

image

These are the figures I see:

image

Let’s take June 12:

  • Autoconsumption (v7): 20090Wh (the comma/period in the setting is not respected here, should be period like I configured it)
  • Tariff for v7 credit: 20,6 cents per kWh
  • Expected Credit: 20,09kWh * 20,6c = €4,14
  • Shown Credit: € 42,50

Let me know if I need to change something or is there a bug in the calculations.

Thanks a lot for the help.

The changes would only affect new / updated data, the last two days looks correct.

Yes I noticed, finally we made it. :slight_smile:

Obviously it would be great to have an autoconsumption column in this view to have a proper view of the balance:

Questions:

  1. Instead of uploading autoconsumption, since I’m already uploaded all v1-v6 values, can I make v7 a calculated value (consumption - import) so it would also fill all historical daily records? What would be a proper formula that takes into account all cases?

  2. Is there a way to recalculate ALL records uploaded? I managed to upload all history I had in my meter. It would be great to have calculations for everything.

Thanks a lot for the support, it is great having all data finally in and calculations working correctly.

The 17th hasn’t been calculated, but data is there…