Can't see output for new system addition

I configured my 1st solar system on PVOutput many years ago. Subsequently, I have added a solar system to my 2nd home and tried to configure this system on PVOutput. However, I am not able to see my output data. My 2nd system has 2 Solar Edge inverters and I have generated an API from the SolarEdge site and entered into the API field on PVOutput. I also entered both serial #s for the inverters. I completed the # panels, panel size in watts and added the azimuths. When I click on the test link after the API field, I get the following message:

This site can’t be reached

The webpage at*********************** might be temporarily down or it may have moved permanently to a new web address.
It has been more than 15 minutes since I entered the settings.
When I click on “Your outputs”, no data gets uploaded.
Any idea what I might be doing wrong?

The actual error is -

Too many requests for the API key / SolarEdge System - is there anything else using the same API key that is using up the request quota?

I set up a solaredge kiosk, could that be the cause? It was so that my architect and electrician could view the output but probably never do so.

I just removed the SolarEdge Kiosk.

Still no data outputed after kiosk removed??
Other ideas?

Looks like the existing API key access has been revoked, error is “Invalid token”

I generated new API key. So far still unable to see any data??

Also update the PVOutput system config, it still has old SolarEdge key.

Maybe I am not doing it right.
I tried entering the new API again.

Maybe start fresh on everything.
create a new api.
create a new pvoutput system and set it up again. its either a wrong setting somewhere or an api issue.
have a read here
and probably more specifically here Auto Uploader — PVOutput documentation

Best to contact SolarEdge support ( about the problem, tell them the following request to the SolarEdge server doesn’t work -