Automatic upload from SMA inverter


#1

Is it possible to create an automatic upload for the SMA inverter?
I know it is possible to create an automatic upload van Sunny Explorer to Sonnenertrag.eu.


#2

Uploads from SMA are usually sent from the inverter via bluetooth.

There are a few scripts to upload from SMA listed below -

https://pvoutput.org/help.html#integration-contributed-software


#3

SBFspot running on a Raspberry Pi is working well for me.


#4

Mine works very well too
I would like to add consumption to that too, that’s why I ended up here


#5

I’m running this script on a Raspberry Pi Zero W, to automatically fetch data from my SMA Inverter…
SBFspot
https://sbfspot.codeplex.com

Works like a charm - Polls the Inverter every 5 min via Bluetooth, and uploads the data. It doubles as a HD webcam also :smile:


#6

oskitch. Pleased to see that your Raspi is working well. I have been using the Pi version 2 for a number of years to upload data to PVoutput. I now have BT FTTH installed and although the Pi is well connected by ethernet and clearly visible to the BT Hub 6 it has not been able to upload any data since the switch from Plusnet copper to the exchange to BT. Has anyone got any ideas please? I have changed the gateway in the pi ethernet settings.


#7

Can you see the Internet from the Pi (e.g. can you ping google.co.uk)? I sometimes find that if I reboot my rooter my Pi looses connection to the Internet and I also have to reboot my Pi to fix this.

Bob.


#8

Thanks bobboulby for your comment on my pi problem. Using putty I can communicate with the pi 100%. I can ping it from my pc. However I cannot ping anything from the pi on my local network let alone anything outside it.
Here is the network setup file on the pi:
GNU nano 2.2.6 File: /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet static
address 192.168.0.41
netmask 255.255.255.0
gateway 192.168.0.253

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

As I probably mentioned before the only change here is the ip address of the new bt hub 6 / router. Unfortunately I had never tried the ping command on the pi when it was connected to another bb provider…


#9

Ah! Think I was not understanding how putty works. It would appear that the pi can ping pvoutputs address:
pi@raspberrypi ~ $ ping 45.56.66.169
PING 45.56.66.169 (45.56.66.169) 56(84) bytes of data.
64 bytes from 45.56.66.169: icmp_req=1 ttl=51 time=125 ms
64 bytes from 45.56.66.169: icmp_req=2 ttl=51 time=124 ms
64 bytes from 45.56.66.169: icmp_req=3 ttl=51 time=124 ms
64 bytes from 45.56.66.169: icmp_req=4 ttl=51 time=124 ms
64 bytes from 45.56.66.169: icmp_req=5 ttl=51 time=124 ms
^C
— 45.56.66.169 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 124.621/124.808/125.024/0.342 ms

pi@raspberrypi ~ $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=1 ttl=57 time=9.79 ms
64 bytes from 8.8.8.8: icmp_req=2 ttl=57 time=9.53 ms
64 bytes from 8.8.8.8: icmp_req=3 ttl=57 time=9.48 ms
64 bytes from 8.8.8.8: icmp_req=4 ttl=57 time=9.56 ms
64 bytes from 8.8.8.8: icmp_req=5 ttl=57 time=9.83 ms
^C
— 8.8.8.8 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4007ms
rtt min/avg/max/mdev = 9.483/9.642/9.834/0.154 ms


#10

I’m assuming that you are using SBFSpot on the pi? If so have you checked the log file in smadata/logs? There should be a log file for each day. Also can you ping say bbc.co.uk from the pi (as opposed to just an ip address)? If not it may be a DNS error.

Finally (and please treat this with caution as I’m no pi networking expert), the gateway of 192.168.0.253 doesn’t look right to me. I’d expect it to be 192.168.1.something.

Bob


#11

Thanks Bob for another suggestion. Yes I am definitely using SBFspot in the pi. The router / bt hub 6’s ip address is set to 192.168.0.253 as it saved setting all the devices on my network to new ip addresses.
As you can see below I cannot ping bbc.co.uk from the pi but can ping ip addresses. Maybe there is a clue here?
pi@raspberrypi ~ $ ping 45.56.66.169
PING 45.56.66.169 (45.56.66.169) 56(84) bytes of data.
64 bytes from 45.56.66.169: icmp_req=1 ttl=51 time=131 ms
64 bytes from 45.56.66.169: icmp_req=2 ttl=51 time=130 ms
64 bytes from 45.56.66.169: icmp_req=3 ttl=51 time=124 ms
64 bytes from 45.56.66.169: icmp_req=4 ttl=51 time=125 ms
64 bytes from 45.56.66.169: icmp_req=5 ttl=51 time=127 ms
64 bytes from 45.56.66.169: icmp_req=6 ttl=51 time=132 ms
64 bytes from 45.56.66.169: icmp_req=7 ttl=51 time=124 ms
64 bytes from 45.56.66.169: icmp_req=8 ttl=51 time=125 ms
^C
— 45.56.66.169 ping statistics —
8 packets transmitted, 8 received, 0% packet loss, time 7010ms
rtt min/avg/max/mdev = 124.710/127.636/132.000/2.936 ms
pi@raspberrypi ~ $ ping pvoutput.org
ping: unknown host pvoutput.org
pi@raspberrypi ~ $
pi@raspberrypi ~ $ ping www.bbc.co.uk
ping: unknown host www.bbc.co.uk
pi@raspberrypi ~ $ ^C
pi@raspberrypi ~ $ ping bbc.co.uk
ping: unknown host bbc.co.uk

Martin


#12

Looks like a DNS problem then. I’m afraid my expertise is running out now - maybe somebody else here can help or ask over in the Raspberry Pi support forums https://www.raspberrypi.org/forums/?

Bob.


#13

Yes I was about to hit the raspi forum as well. Again many thanks Bob for the dialogue.


#14

Hope you get it sorted - I’d be interested to know what the outcome is.

Bob.


#15

Hi Bob

Still not got this problem licked! However today I used my S7e 'phone to ping “pvoutput.org” using the 4G connection and it works. When I turned on the wifi (ie using the BT Fibre route the ping test failed.
This does rather point to BT not resolving the web address. Previously they denied that could happen so I will get onto them again. I wonder if anyone else has had this problem with smaspot on the Pi when using BT for broadband.
BTW I have not had any useful response yet from the Pi forum.
If you know how to make my problem more visible on the pvoutput forum then I would be grateful.

Regards, Martin


#16

Sorry I’ve been away so have only just got around to reading this. It does seem like hard work, BT are a popular ISP so you’d think there would be help available. The fact that you’re having problems with multiple devices on your network does suggest that it’s a BT problem - is it the same from your computer (assuming that you have one)?

The only other thing I could suggest is to to factory reset your router to see if that solves it. You could also try deleting and recreating the wi-fi connection on the Pi although as it’s also happening on your phone I’m not confident that this would work.

Good luck :slight_smile:

Bob.


#17

Nice to hear from you Bob. I solved the problem only yesterday with some on line help from the Raspi Forum. Dead simple of course. There is file in the Pi “/etc/resolve.conf” . In Putty all you have to do is type this command once logged in to Pi: sudo nano /etc/resolve.conf. One line of text in there “nameserver 8.8.8.8 8.8.4.4” No inverted commas so typically it would look like this:
nameserver 192.168.1.254 8.8.8 8 8.8.4.4 (note the spaces between the ip addresses) The 8.8.8.8 & 8.8.4.4 are alternative dns servers (google). I now you don’t need this but It is for the benefit of the others who may be stuck. I must have put my original router’s ip address in this file because it was there but it was a while back when I confugured the Pi!! So it was a dns problem, nothing to do with the bb service provider, in my case BT. BTW my Pi is connected with good old ethernet cable! Again many thanks for your interest in my problem.


#18

That’s great news. Assuming that you are fc_solar2011 I can see that you are back on-line although there seem to be a few gaps in your data. I’ve always found SBFspot to be good at catching up when I’ve been off line but never for as long as you.

Bob.


#19

Yes I am fc_solar2011! Back on line properly today now. I have filled in the missing days manually but the data does not update the daily live production graph.
At least the sun is shining today!


#20

I know I’m pretty late here, but I just got a RPi for some test projects, I have a solar array, so I said “what the heck”, let’s try connecting those two and getting some sweet stats. The things is, everything (or so I see it) goes through pvoutput.org. Well, what if the site shuts down or something? I personally don’t mind sending my data here, sharring and comparing it with the rest of the world (though I can see how others would), but what I expect is reliability. The idea that, whatever happens to this site, or the internet for that matter, my RPi as long as it receives electricity and is connected to the inverter, it will record, and store everything.
So my question is, is there a script for offline storage and monitoring, or do those other scripts I see here already provide that?
Thanks.