Weather Calculation Not Using Estimates


#1

I have three systems on PVOutput, one parent and two children. All three systems have estimates but the weather calculation (Fine, Partly Cloudy etc.) seems to be ignoring my estimates for two of the three systems.

The systems are Sunny Idle 2.25 (weather calculation working) and Sunny Idle 1.66 and Sunny Idle 3.90 (not working). Note that I have been correcting the weather calculation each day except for 11 May onwards where I have left the system calculated values.

Any ideas what could be wrong?

Thanks - Bob.

Edit, I’ve started correcting these again but for the period 11 May to 13 May the readings were as follows:

Sunny Idle 1.66

Date Estimate Actual % Condition
11 May 9.677 6.637 69 Fine
12 May 9.677 6.588 68 Fine
13 May 9.677 7.470 77 Fine

Sunny Idle 3.90

Date Estimate Actual % Condition
11 May 24.194 14.664 61 Fine
12 May 24.194 15.817 65 Fine
13 May 24.194 18.805 78 Fine


#2

The calculation for Sunny Idle 1.66 from 14 May to 17 May look correct.

System estimate for May is 300Wh.

The baseline is 300 / 31 days / 1660 system size * 1000 = 5.83

May 17th = 5404 / 1660 = 3.255, ratio = 3.255 / 5.83 = 55.84%

This is between 40 to 60% or Mostly Cloudy using the conditions calculations listed below -


#3

I have been manually correcting these each day. The original figures for the 11 to 13 May are in my original post - each day the weather calculation was “Fine” but the percentages were below 90%.

Bob.


#4

I’ve not corrected the calculations for the18 May.

Sunny Idle 1.66

Estimate 300/31=9.677 kWh/day
Actual 3.535 kWh
%age 36.5%
Calculated weather Mostly Cloudy
Should be Cloudy (20% - 40%)

Sunny Idle 3.90

Estimate 750/31=24.194 kWh/day
Actual 8.804 kWh
%age 36.4%
Calculated weather Partly Cloudy
Should be Cloudy (20% - 40%)

Bob.


#5

Both the estimate and default without estimate calculation should be both Cloudy, has the estimates been updated recently for the system?


#6

Yes I updated the estimates for both systems and also for Sunny Idle 2.25 (which is working ok) a few weeks ago.

Bob.


#7

Try editing the Sunny Idle 1.66 system and Saving, this will reload the new estimates.

There is a limitation at the moment which estimates will not refresh without saving the system.


#8

Ok, I’ve re-saved all three systems (2.25, 1.66 & 3.39) and will monitor over the next few days.

Bob.


#9

Seems to working ok now - thanks.

Bob.