Using current cost data cable with W10

Help - am trying to migrate my service uploads to a Windows 10 netbook (currently on Windows XP). I have a current cost ENVI with data cable (white one) which I plug in to usb port and I have installed the drivers from Current Cost which are for the “windows vista and windows 7” as these seem to be the latest ones. When I plug in the cable and view it in device manager it says “this is not prolific PL2303 please contact your supplier” but when I click on it it says device is working fine.
Is there any way of using this cable with a W10 computer or am I limited to Windows 7?

Hi @gandkslater,

I had a similar problem with a ‘Prolific’ device. It is actually included in a USB GPS that I use. My understanding is that the actual chipset used in the device is not a genuine Prolific chipset and that the later drivers are capable of detecting this fact and preventing the device from working.

The solution I found was to use an older version of the driver. I started with the latest version of the driver and worked backwards until I found a Prolific driver that worked.

*** You may find that unplugging the device or switching the device to a new USB port may cause the original / newer driver to reload. Just use Device Manager to (re) select the earlier working driver.

I’ve gone to the extra step of attaching an adhesive label to my GPS device with the device driver version number on it so that I don’t have to going driver ‘fishing’ every time. You will need to use the correct x64 or x86 driver depending on which OS you are using. Watch out too for Windows Updates which may attempt to ‘upgrade’ your working device driver.

Good luck

many thanks for this - most helpful. I will give it a try. Incidentally, I have now found a replacement cable on ebay here USB data cable for Current Cost EnviR power monitor/meter (supports Windows 10) | eBay which purports to do the job for W10 and 11 and not too expensive. I have ordered one and will let the community know how I get on.
regards g

I downloaded version from here The Famous Old Driver of PL2303 USB – Embedded Area and it worked a treat. Thanks for the info.G

Glad to be of assistance. :grinning: