'Unauthorized 401: Invalid API Key' when adding system in IOS App


#1

Hello All,

Although we’ve had our system for over 3 years, I’ve only just discovered and connected to PVOutput so I’m new to this.

Our system provider gave me the SolarEdge API Key (I’m ‘not allowed’ admin access to the Solaredge site. . .) and Site ID and on entering these into the PVOutput Settings page (using a desktop) the auto-upload instantly started working.

Today I downloaded the App (IOS version) to my iPhone 6 and using the same API key and site ID produce this error: Unauthorized 401: Missing, invalid or inactive api key information (X-Pvoutput-Apikey). I ‘Enabled’ requests in the settings page which seemed to make no difference.

I note that the API key I pasted in the Settings field is now blank (to keep it secure?) but more intriguingly that the Site ID is different. If I tried that Site ID I got a slight variant in the message: Unauthorized 401: Invalid API Key.

Trying the ‘Read Only key’ doesn’t seem to help - I still get the Unauthorized 401 errors.

from this description can anyone see what I’m doing wrong?

tim


#2

Note these are two different API keys and ids.

  • The SolarEdge key is used to access SolarEdge data. The site-id is an id that identifies your SolarEdge installation on the SolarEdge portal.
  • The PVOutput (X-Pvoutput-Apikey) for PVOutput data access. The system-id is an id that idenfies your PVOutput system. This is not the same as the SolarEdge site-id.

The ios app is asking for the PVOutput details, api key and system id, these can be found via Settings


#3

Many thanks - I’ve now managed to connect!

tim