Unable to Authorize Enphase API

On 9/19, the Enphase API suddenly stopped uploading my production data to pvoutput. I am on the API v4 and when I try to authorize it, I get an error message on enphase API website that I don’t own any system. I can see my production data on the Enphase Enlighten app/website. Any one else have this issue and suggestions on how to fix?

Could be a misconfiguration on Enphase side, should be able to get support at api@enphaseenergy.com

Sharing it as another data point, I’m getting the same error as well.

I spoke with enphase. Apparently my installer never transferred over ownership of my system to me so Enphase did not have me listed as the owner. I spoke with my installer and they transferred ownership and now I can authorize the Enphase API.


Thanks for this, but how did you manage to authorise in the first place before it stopped working on the 19th?

This happened to me as well. I was definitely able to authorize before when the warning about needing to authorize with Enphase again was popping up a few weeks/months ago.

But about 5-6 days ago, my generation data wasnt appearing on PVOutput anymore so thats when I was trying to re-authorize and ran in the same issue as the posters above. I reached out to my installer about turning over ownership. I was then able to authorize my system via PVOutput, but my generation data still isnt showing. I’ve tried removing the authorization and re-authorizing, each time it appears to work, but still no generation data. Any ideas?

Just replying to my own post here… but I found the other Enphase API v4 related threads and removed Enphase v4 as my Primary, changed it to None, removed PVOutput as an authorized system from Enphase Enlighten, then added it all back to PVOutput and re-authorized and my solar data is working now.

I noticed the same too (mine stopped working since 2022-09-27).

I have tried to remove the authorization from both side, reauthorize, and now get:

Failed to authorize PVOutput to read your Enphase site data

Enphase server not responding, please try again later.

Note that pvoutput.org do show up under “My Access Control” → “API settings” after this. I’ve tried to revoke and reauthorize multiple times, but it didn’t help.

Looks like you’re back online now?

Yeah, I have tried it again the other day and it worked. Thanks!