Too complex password?


#1

Hiya,

I’m trying to install SBFspot on a RaspberryPi Zero W and all of it is going well, instructions are clear and then it aborts last minute because the password isn’t right. Now I went into the configuration file and adjusted the password to my own, saved, double-checked the savefile and ran the install again. It again complained about the password.
When I first entered my SMA inverter I had to set a strong user password so I picked letters, numbers and special characters. One topic I could find hinted that it worked just fine logging in as long as there were no special characters involved in the password. Unfortunately, it’s not possible to reset the user password on a SunnyBoy without requesting a PUK code (25 euro!) and filling in a lengthy form. So I hope someone here knows how to help.

    curl -s https://raw.githubusercontent.com/sbfspot/sbfspot-config/master/sbfspot-config | sudo bash
SBFspot Configuration Tool V1.0.13
Running on Raspberry Pi Zero W Rev 1.1
Checking whiptail... Installed.
architecture=armhf
Raspbian GNU/Linux 9.9 (stretch)
username=pi
userhome=/home/pi
Minimum SBFspot version supported by this tool is 3.5.0
Request to install latest version (3.5.2)
Searching for existing configuration(s)...
Reading settings from /usr/local/bin/sbfspot.3/SBFspot.cfg
Saving defaults to /var/tmp/sbfspot.3/sbfspot.defaults... Done
Performing some checks before installation... Done
Downloading https://github.com/sbfspot/sbfspot/releases/download/V3.5.2/sbfspot-sqlite-arm-linux.tar.gz
Copying files...
SBFspot.db exists
Checking database...
Schema Version=1
Configuring SBFspot... Done
Running SBFspot...
SBFspot V3.5.2
Yet another tool to read power production of SMA solar inverters
(c) 2012-2018, SBF (https://github.com/SBFspot/SBFspot)
Compiled for Linux (LE) 32 bit with SQLite support
Commandline Args: -v -ad0 -am0 -ae0 -sp0 -nocsv -nosql -finq
Reading config '/usr/local/bin/sbfspot.3/SBFspot.cfg'
Thu Aug  1 14:51:45 2019: INFO: Starting...
sunrise: 06:01
sunset : 21:31
Connecting to Local Network...
Initializing...
SUSyID: 125 - SessionID: 863020555 (0x3370A60B)
Inverter IP address: 192.168.2.127 from SBFspot.cfg
Thu Aug  1 14:51:45 2019: CRITICAL: Logon failed. Check 'USER' Password
Installation aborted

#2

Password length should not exceed 12 characters.
You can try to login as installer with default password 1111
Did you try with sunnyexplorer?


#3

Thanks for the reply, the password is 10 characters only, so within the safe limit.
I did try with the installer password but it gives the same error “Check ‘USER’ Password”, I assume because it still tries to log in as the user on SMA? I can’t find where to change it from USER to INSTALLER.
I haven’t used sunny explorer yet, but I’ve used webconnect (via the IP address of the inverter) and logging in there works fine. Also tried pulling data from the inverter with Hassio and that works fine too.


#4

Just an addition here/ I’ve checked the saved cfg file in the texeditor and it indeed seems to drop the exclamation mark I have in my password. I’ve edited the file via the command line (is it called that too in Linux? I’m not sure) and definitely added the exclamation mark.


#5

To use installer account, try this:

./SBFspot -v -nocsv -nosql -finq -installer -password:1111

#6

Thank you! That worked. :+1: Somehow I managed to get another error but it’s most likely inverter side so I will start to work on that now :joy: