Tariff Plans - Multiple TOU

The Tariff Plan functionality has been introduced to support multiple TOU rates.

  • Up to 10 plans can be saved for a system each with a different tariff rates and TOU configuration
  • Each plan can have a start and end date e.g. A summer or winter plan
  • A plan without a date range is valid all year round. If no plan date ranges can be matched this plan will be used.
  • Templates are pre-configured plans you can load and save as your own plan.



Switch to multiple plans -

  1. Open the Edit Tariff page, the existing single tariff details will be shown.
  2. Enter in the plan name, select a date range and enable it.
  3. Click Save next to the plan name to save it.
  4. The plan now appears on the Saved Plans list. Active plans will have a + prefix.
  5. Repeat for additional plans using a different name and date range.
  6. Ensure Use Tariff Plans is enabled on the Edit System page.
  7. Save the system settings.


Tariff / TOU calculations will work as before, except each upload will decide which plan is applicable and activate the plan’s tariff and TOU settings.

Plans with date ranges are checked first, if none can be matched the plan without any date range is used. It is important to have at one active plan without a date range, otherwise no tariff and TOU calculations will be run for that date.


Awesome! That’s a useful addition, thanks!

A few questions:

  1. How does the “Switch Plan” view on the Daily viewing page work now? It seems to switch to a Plan I no longer have defined. Is there a way to choose given the new system?
  2. Are we able to create our own Templates for import, or are they essentially just examples? (if the latter, seems kind of an unnecessary UI addition for what won’t apply to many people)
  3. Can the limit on the number of Saved Plans be raised by a few? Perhaps 10? Why? see below…

In PG&E land on the E-6 plan, we actually have 6 rate periods per year, because the rate plans were originally created to take DST into account, but the dates DST begin/end have since changed and the adjusted dates are based on “X’th Sunday in the month of Y”.

So this is what we actually have the period of summer 2018 - 2019:
Summer: May 1 - Oct 28 (“last Sunday in October”)
Summer Adj: Oct 29 - Oct 31 (Adj is “period between last Sunday in October and first Sunday in November”)
Winter Adj: Nov 1 - Nov 3 (Adj is “period between last Sunday in October and first Sunday in November”)
Winter: Nov 4 - Mar 10 (“second Sunday in March”)
Winter Adj: Mar 11 - Apr 6 (“period between second Sunday in March and the first Sunday in April”)
Winter Again: Apr 7 - Apr 31

So this alone consumes 6 plan slots if you’re entering dates for all the periods. I was able to get around it by having “Winter” as no date set, which lets me use an “E-6 Winter” plan for both the two winter periods, just maxing out the 5 plan limit.

I imagine others might have similarly complex periods, and it’d be nice to have a couple plan slots left for doing actual comparisons, and/or using the “Switch Plan” feature if it’s updated to select from this of plans.


P.S. Previously I had to have calendar reminders 6 times a year to adjust the rates/TOU periods, so this feature is a nice improvement, in that I should only need to go in once a year to set the dates (given the variability each year due to when the first/second/last Sundays land).

  1. The switch plan is being reworked at the moment. Currently its being disabled until the ability to choose any one of those plans is added.

  2. The templates are just examples to get people started. But there will be more templates added in the future e.g. PG&E Plans so new users on the same provider don’t have to manually set them up.

    Let me know if you want your 6 PG&E plans to be a template.

  3. Number of plans increased to 10 - although 6 plans is quite excessive already! :smiley:

1 Like

Is it broken now? My system is now showing $0.00 for all current and historical days.


Reproduced the bug.

So if I have overlapping time-periods, such as Shoulder 2 M-F from 20:00 to 22:00, and then I have High-Shoulder 1 20:00 to 22:00 only on Tuesday, P/H, or both, then all peak calculations will not work, and end up with $0.00.

If you wait 5 minutes for the next refresh-update, only the low-peak calculation values will work.

I have yet to figure out how to get “Shoulder Import” to actually calculate using values that’s not $0.00/kWh. No amount of setting one, two, three shoulder-periods M-F, overlapping or not, will let it calculate non-zero.

When there are overlapping periods, the first matched tariff will be used.

There doesn’t appear to be any overlapping periods currently configured however.

The tariff plan switch/simulation tool has been added back.

Click on the Plan link below the graph. This is only available to system owners.

On the popup select the plan and click Change. The plan cost breakdown will be shown in the popup.

Click Reset to show the current active plan.

1 Like

I removed my overlapping periods because I don’t care to have $0 calculations.

I’d assume you guys tried it on another system? Should I leave it overlapping on mine so it can be debugged?

Now that Shoulder Import calculations are working, I’m assuming the rest had been fixed also.

You can save the overlapped settings to inactive plan so the settings can be replicated for further investigation.

Not sure if it is to do with the tarriff changes, but for the last few days the daily detailed view doesn’t display properly. The Generated and Export figures are the same, and the import and consumption figures are the same. Recalculating fixes the problem but the current day is reverting to the incorrect display. The figures are correct in the live view.



The tariff plan was manually refreshed for the system and now it looks correct. The issue was it could not find any active plan and reset to empty plan i.e. (gross import/export)

After saving the plan did you click on “Save” at the bottom of the Edit Tariff page?

Yes, i think so because I have 2 plans there and have been using them to compare on the live page. It’s weird because when I did a recalc it was fine, but would update to gross a few minutes later.

Seems fine now. Thanks for your help.

Cheers, Ros

actually maybe i hadn’t. I see what you mean, it was probably set to gross in the top section.

The plan settings is correct, its on Net.

Possible cause may have been that the “Use Tariff Plans” was enabled on Edit System, then the ‘powershop’ plan was saved but the Edit Tariff page was not saved - so no plans were loaded.

The calculations that take place every 5-minutes could not find any matching plan so it resets to an ‘empty plan’ which is on gross.

We may just need to refresh each time a plan is saved instead.

EDIT - Tariff plan settings are now refreshed on each plan save. Clicking on Save at the bottom of Edit Tariff page is no longer required for plans.


The templates are just examples to get people started. But there will be more templates added in the future e.g. PG&E Plans so new users on the same provider don’t have to manually set them up.

Let me know if you want your 6 PG&E plans to be a template.

While that could be helpful for other PG&E users today, there’s two aspects that make me think it wouldn’t be that useful long term:

a) PG&E tweaks their pricing quite frequently
b) The start and stop dates vary every year since they’re based on “first Sunday in…” and “second to last Sunday in the month of…”, which doesn’t seem worth explicitly building support into PVOutput for.

Number of plans increased to 10 - although 6 plans is quite excessive already! :smiley:

Thanks! Yes, please tell PG&E that!

I’m not even attempting to factor in the complexities involved when my usage or generation exceeds their “baseline” kwh/month threshold, at which point the rates increase (3 tiers total, used to be 5). Usually they balance out so we’re in the baseline, but I’ve had months where I “exceeded” the baseline (in generation!) and thus got paid the higher tier rate…

Realistically that’ll leave me some room to put in and do simulations on actual different plans - like the EV-A plan (an option for houses with electric vehicles), the future time-shifts on the E-6 plan (which moves peak TOU later into the evening to weaken it, coming in 2021 and 2022), the non-TOU E-1 plan, or the E-TOU-A and E-TOU-B plans all PG&E solar customers will eventually be moved to by 2023 (and all new solar installations are forced under).

What is the order of tariff matching? Is it alphabetical?

It might make most sense to use the most specific tariff, i.e. the one with the smallest days spanned. That said as long as the matching order is known we can emulate that through naming.

Its ordered by the start date but its in alphabetical not calendar order.

Sorry, I’m a little unclear on what that means. With tariffs with overlapping dates, the one with the ?earlier? start date will take precedence? Or are we talking December before June?

Put another way, if my utility company has a Oct-Mar Winter Tariff, but has a few weeks in the December that follow a different tariff, can I override it (2 tariffs), or do I need to break it up into 3 Tariffs? If 2, how?

PG&E is lovely… takes 5-6 tariffs to encode a Summer tariff + Winter tariff (non-DST), then adjustments for DST starting earlier than it used to when the plans were drawn up, then the normal DST period.

The dates are treated as text and 10-Dec will come before 01-Jun since “0” is before “1”.

There should not be any overlapping dates since it would not know which plan to pick even with a predictable order. In future, there will probably be a warning if dates do overlap.

  1. Plan 1 (Oct-Mar)
  2. Plan 2 (Dec-01 to Dec-14)
  3. Plan 3 (No Start/End Date)

Plan 3 will be used if none of the dates match Plan 1 or 2.