SolarEdge Direction of "Both" not showing generation


#1

I’ve recently setup and configured my new system here and I’ve found that setting the direction of auto uploader to “both” isn’t showing my solar generation. I can get it working if change it to solar and set consumption on the secondary monitor - but should this be working as intended?


#2

Both direction isn’t supported for SolarEdge.

The setup should be -


#3

Thanks for clarifying on that. I somehow didn’t find that post which would have saved me!

I found that If I have both primary and secondary devices connected and set to update every 5 minutes logging ceases after a period of time. Does configuring it in this way mean it is updating twice every 5 minutes thus exceeding my 300~ per day limit? If not the case, any suggestions what might be causing that?

I currently have the SolarEdge 15 Minute Energy setting enabled for both devices but as you would know it doesn’t look nearly as good as having 5 minute intervals. Ideally I’d like to have it updating as often as possible within reasonable limits, but my trial and error of continuously adjusting the settings doesn’t seem to be working for me.


#4

The data interval is 5-minutes but polling takes place every 10-minutes for SolarEdge.

If there are multiple inverters, each one has to be queried individually at each poll.

Try increasing the PVOutput Poll Interval setting to 30 minutes.


#5

Thank you, that explains why setting it to 5 minutes stops logging prematurely each day (I have 3x inverters). I will reduce the time to 30 minutes as you suggest until I level-up my skills to poll locally over modbus.