SolarEdge API stopped at 9:40am?


#1

Hi!

Just trying to get a new SolarEdge system online… see https://pvoutput.org/intraday.jsp?id=57479&sid=63726&dt=20181219

The site has production and consumption metering, all working on the SolarEdge portal.

I’ve been playing with the pvoutput Direction settings “Solar, Consumption, Net, Both” and currently have it at “Solar”.

It had data working up till 9:40am… now nothing since then…

Any ideas?


#2

You have not set up your PVOutput page correctly. From the information on your site you are using more power than you are producing! You have a very large system and it must be installed on an industrial plant to make sence. @bankstownbloke should be able to analyze your problem and offer a solution to how your system should be configured on PVOutput. Good luck.


#3

You have not set up your PVOutput page correctly

Thanks…

I can query the SolarEdge API and it appears to be returning the correct data for the site.

https://monitoringapi.solaredge.com/site/877860/powerDetails?meters=PRODUCTION,CONSUMPTION&timeUnit=QUARTER_OF_AN_HOUR&startTime=2018-12-20%2000:01:00&endTime=2018-12-20%2013:00:00&api_key=xxxx

The solaredge API supports sending both the Production and Consumption, and the data is there, and pvoutput seems to support this, so I’ve set the pvoutput Direction to “Both”. But that seems to break the pvoutput updating.


#4

You will need to configure with the same solaredge site/key -

  • Primary Device - Direction = Solar
  • Secondary Device - Direction = Consumption

The Both direction is not supported with SolarEdge


#5

The Both direction is not supported with SolarEdge

Thanks, got it … cheers @bankstownbloke


#6

@bankstownbloke

The consumption data is showing up on pvoutput with the right values, and checks out with the SolarEdge system.

But the Solar data is showing up on pvoutput at values lower than from the SolarEdge system. It seems to be about 50% of the values.

Both data feeds from the solaredge API seem to be correct.

Thoughts?


#7

The system has 8 inverters which requires 8 calls to SolarEdge from each inverter every 5-minutes which is exceeding the SolarEdge API limit.

The only option here is to use the Energy option which will reduce the number of requests from 8 to 1.

image