Showing Tariff on Live Chart


I have 3-tier tariff:

Peak: 11a - 7p
Shoulder: 7a - 11a and 7p - 11p
Off-peak: 11p - 7a

When I click on the live chart, I will show the Peak and Shoulder range. However, it is off by one-hour. In my case, it will show Peak as 12p - 8p and Shoulder as 8a - 12p and 8p - 12a. Maybe it is caused by daylight saving time?

Does anyone notice this?



I’ve noticed this also. Not sure if it is just the graph that is off visually, or if the tariff calculations are off by an hour also.Tried to play around with the DST settings, but doesn’t seem to affect it. Daylight Savings ends for us Sunday morning, so I’ll see if it fixes itself then.


The DST Adjust setting should only be enabled if the uploading script is unable to adjust for DST, otherwise the data will be offset by one hour.

This should be Disabled if the uploader handles DST.

This system is using the SolarEdge PVOutput Auto Uploader.

All Auto Uploaders handle DST by default and the DST setting should always be disabled.