SBFspot - Power value too high for system size


#1

I set up SBFspot yesterday and everything was working fine.
Here’s a portion of yesterday’s log file.
[18:45:30] INFO: Uploading datapoint: 20180516,18:45,58372,36,0,117.5 => OK (200)
[18:50:31] INFO: Uploading datapoint: 20180516,18:50,58374,24,0,118.74 => OK (200)
[18:55:31] INFO: Uploading datapoint: 20180516,18:55,58377,36,0,118.84 => OK (200)
[19:00:31] INFO: Uploading datapoint: 20180516,19:00,58379,24,0,118.85 => OK (200)
[19:05:31] INFO: Uploading datapoint: 20180516,19:05,58381,24,0,118.84 => OK (200)
[19:10:30] INFO: Uploading datapoint: 20180516,19:10,58382,12,0,118.61 => OK (200)
Unfortunately, today’s log file shows this error:
[07:37:31] ERROR: Uploading 14 datapoints, starting with 20180517,01:45,58382,0 Bad request 400: Power value [700596] too high for system size [3000]
[07:38:30] ERROR: Uploading 14 datapoints, starting with 20180517,01:45,58382,0 Bad request 400: Power value [700596] too high for system size [3000]
[07:39:31] ERROR: Uploading 14 datapoints, starting with 20180517,01:45,58382,0 Bad request 400: Power value [700596] too high for system size [3000]
[07:40:31] ERROR: Uploading 15 datapoints, starting with 20180517,01:45,58382,0 Bad request 400: Power value [700596] too high for system size [3000]
[07:41:30] ERROR: Uploading 15 datapoints, starting with 20180517,01:45,58382,0 Bad request 400: Power value [700596] too high for system size [3000]
[07:42:31] ERROR: Uploading 15 datapoints, starting with 20180517,01:45,58382,0 Bad request 400: Power value [700596] too high for system size [3000]

Any suggestions?


#2

Here is a sheet with a sample of data from vwspotdata from yesterday and today:

I don’t see any problem with the data but it does give the “Power value too high” error.


#3

I tried to change the “System Size” which I had set to 6 * 500 =3000 watts by changing the number of panels or the panel size but it did not change the “System Size” which now seems fixed at 3000. I don’t know why this can’t be changed or even why it is a limit that should prevent data upload.
Anyway, power today is far below the 3000 limit so I don’t understand the problem.


#4

In the SBFspot database there is a powervalue=700596W
PVoutput allows 150% of your systemsize (=4500W)

select * from daydata where power>4500;

So, to fix this, remove or edit this entry in SBFspot.db

delete from daydata  where power>4500;

or set power=0

update daydata set power=0 where power>4500;

When this is done, upload will start again.


#5

The size will automatically update once you move to another input field. It is always saved as number of panels * panel size when saving the system settings.


#6

Why should OP change system size? It is clear that a generation of 700kW with a 3kW system is impossible.


#7

Thanks for your help.
Yes, you’re right. I was desperate and tried this to get it to load since I couldn’t find the bad data in the view. Thanks for pointing out the daydata table.
The real question is where did the bad data point come from?
Looks like a regular occurrence:
sqlite> select * from daydata where power>4500;
1526564100|1990030396|58382|700596|
1526647800|1990030396|64541|774504|
1526649000|1990030396|64541|774504|

Looks like it’s happening during startup in the morning.
Looks like I’ll need to scrub this daily.


#8

There is a small chance it’s a problem with your inverter (you should try Sunny Explorer to be sure)
Feel free to create a debuglog and send it to me. Start SBFspot with -d5 -v5 and redirect output to a file.

SBFspot -d5 -v5 >>mspohr.log

There is a workaround for this: change the vwPVOdata view (drop it first)

SELECT dd.Timestamp,
          dd.Name,
          dd.Type,
          dd.Serial,
          dd.TotalYield AS V1,
          CASE WHEN dd.Power > 4500 THEN
              0
          ELSE
              dd.Power
          END AS V2,
          cons.EnergyUsed AS V3,
          cons.PowerUsed AS V4,
          spot.Temperature AS V5,
          spot.Uac1 AS V6,
          NULL AS V7,
          NULL AS V8,
          NULL AS V9,
          NULL AS V10,
          NULL AS V11,
          NULL AS V12,
          dd.PVoutput
     FROM vwDayData AS dd
          LEFT JOIN vwAvgSpotData AS spot
                 ON dd.Serial = spot.Serial AND dd.Timestamp = spot.Nearest5min
          LEFT JOIN vwAvgConsumption AS cons
                 ON dd.Timestamp = cons.Nearest5min
    ORDER BY dd.Timestamp DESC

This way, power values above 4500W will be ignored.


#9

Wow! Thanks.
That’s an easy fix to the view.
I’ll set up the debug log. How long should I run it in debug mode?


#10

Until an excess power value is available. If possible have a try with sunny explorer too. Windows only.


#11

The problem seems to occur on startup. I get an unusually large value at the start of the day.
Here’s the section of the log file from this morning (grep kWh). (I restarted the unit at 9:30)
20/05/2018 08:25:00 : 88.109kWh - 0.000W
20/05/2018 08:30:00 : 88.109kWh - 0.000W
20/05/2018 09:30:00 : 88.251kWh - 1059024.000W
20/05/2018 09:35:00 : 88.423kWh - 2064.000W
20/05/2018 09:40:00 : 88.598kWh - 2100.000W
20/05/2018 09:45:00 : 88.774kWh - 2112.000W
20/05/2018 09:50:00 : 88.952kWh - 2136.000W
20/05/2018 09:55:00 : 89.131kWh - 2148.000W
20/05/2018 10:00:00 : 89.312kWh - 2172.000W

I’ve posted the log file to a Google doc…
mspohr.log - startup noise


#12

Sorry for the late answer…
There is a 1h gap from 8:30 to 9:30 instead of 5min but that doesn’t explain the huge power value.
Thanks for the log, but what I need is the data from wake-up till first production.


#13

I had turned the inverter off from 8:30 to 9:30 so the starting value at 9:30 is the “wake up”.
It seems to happen every day.
I’m away for two weeks but when I get back I’ll send additional data.
I really appreciate your help. The patch to the data means I’m posting to PVoutput successfully and that is really what matters.