SBFspot fresh install - `CURL_OPENSSL_3’ not found


#1

Hi all,

I’m pretty new to this and it’s really starting to get frustrating.

I just successfully installed SBFspot on my raspberry pi and finally I got it all set up.

Unfortunately my system in PVoutput.org seems to be empty after waiting for an hour.
Also my DB seems to be not have been filled with data…

This is my log file in

/var/log/sbfspot.3


startTime = 5D13F8F0 -> 27/06/2019 00:00:00
Thu Jun 27 17:35:36 2019: INFO: Done.
SBFspot V3.5.2
Yet another tool to read power production of SMA solar inverters
(c) 2012-2018, SBF (https://github.com/SBFspot/SBFspot)
Compiled for Linux (LE) 32 bit with SQLite support
Commandline Args: -v -ad1 -am0 -ae0 -cfg/usr/local/bin/sbfspot.3/SBFspot.cfg
Reading config '/usr/local/bin/sbfspot.3/SBFspot.cfg'
Thu Jun 27 17:40:01 2019: INFO: Starting...
sunrise: 04:46
sunset : 21:20
Connecting to 00:80:25:15:F5:5C (1/10)
Initializing...
SUSyID: 125 - SessionID: 910024048 (0x363DDD70)
SMA netID=01
SUSyID: 113 - SN: -private removed-
BT Signal=70.6%
Logon OK
Failed to get current plant time (0)
getSoftwareVersion returned an error: -1
SUSyID: 113 - SN: -private removed-
Device Name:      SN: -private removed-
Device Class:     Solar Inverters
Device Type:      SB 3000TL-20
Software Version: 
Serial number:    -private removed-
SUSyID: 113 - SN: -private removed-
Device Status:      Ok
SUSyID: 113 - SN: -private removed-
Device Temperature: 52.5°C
SUSyID: 113 - SN: -private removed-
GridRelay Status:      Closed
SUSyID: 113 - SN: -private removed-
Pac max phase 1: 3000W
Pac max phase 2: 3000W
Pac max phase 3: 3000W
SUSyID: 113 - SN: -private removed-
Energy Production:
	EToday: 12.063kWh
	ETotal: 26025.219kWh
	Operation Time: 38000.14h
	Feed-In Time  : 36423.88h
SUSyID: 113 - SN: -private removed-
DC Spot Data:
	String 1 Pdc:   1.141kW - Udc: 132.84V - Idc:  8.592A
	String 2 Pdc:   0.000kW - Udc:   0.00V - Idc:  0.000A
SUSyID: 113 - SN: -private removed-
AC Spot Data:
	Phase 1 Pac :   1.092kW - Uac: 231.44V - Iac:  4.720A
	Phase 2 Pac :   0.000kW - Uac:   0.00V - Iac:  0.000A
	Phase 3 Pac :   0.000kW - Uac:   0.00V - Iac:  0.000A
	Total Pac   :   1.092kW
SUSyID: 113 - SN: -private removed-
Grid Freq. : 49.98Hz
SUSyID: 113 - SN: -private removed-
Current Inverter Time: 31/12/2009 06:21:32
Inverter Wake-Up Time: 30/12/2009 17:17:11
Inverter Sleep Time  : 31/12/2009 06:21:37
ExportSpotDataToCSV()
********************

Much appreciated!!


#2

Okay short update. Apparently I forgot to add “;” to my sql syntax in the sql db… no wonder nothing was returned :slight_smile:

This is the data contained in vwspotdata table:

2019-06-27 18:00:33|2019-06-27 18:00:00|SN: -private removed-|SB 3000TL-20|-private removed-|1010|0|7.618|0.0|132.78|0.0|968|0|0|4.183|0.0|0.0|231.43|0.0|0.0|1010|968|95.8|12404|26025560|50.01|38000.5|36424.2|70.6|OK|Closed|50.1

2019-06-27 17:55:34|2019-06-27 17:55:00|SN: -private removed-|SB 3000TL-20|-private removed-|1038|0|7.824|0.0|132.82|0.0|993|0|0|4.302|0.0|0.0|230.96|0.0|0.0|1038|993|95.7|12322|26025478|49.97|38000.4|36424.1|70.2|OK|Closed|50.5

2019-06-27 17:50:34|2019-06-27 17:50:00|SN: -private removed-|SB 3000TL-20|-private removed-|1074|0|8.088|0.0|132.84|0.0|1031|0|0|4.471|0.0|0.0|230.76|0.0|0.0|1074|1031|96.0|12240|26025395|49.98|38000.3|36424.0|70.6|OK|Closed|51.1

2019-06-27 17:45:34|2019-06-27 17:45:00|SN: -private removed-|SB 3000TL-20|-private removed-|1095|0|8.252|0.0|132.84|0.0|1050|0|0|4.538|0.0|0.0|231.4|0.0|0.0|1095|1050|95.9|12153|26025308|49.98|38000.2|36424.0|70.6|OK|Closed|51.8

2019-06-27 17:40:33|2019-06-27 17:40:00|SN: -private removed-|SB 3000TL-20|-private removed-|1141|0|8.592|0.0|132.84|0.0|1092|0|0|4.72|0.0|0.0|231.44|0.0|0.0|1141|1092|95.7|12063|26025219|49.98|38000.1|36423.9|70.6|OK|Closed|52.5

2019-06-27 17:35:34|2019-06-27 17:35:00|SN: -private removed-|SB 3000TL-20|-private removed-|1191|0|8.978|0.0|132.82|0.0|1140|0|0|4.915|0.0|0.0|232.21|0.0|0.0|1191|1140|95.7|11971|26025126|49.97|38000.1|36423.8|70.6|OK|Closed|53.0

2019-06-27 17:30:34|2019-06-27 17:30:00|SN: -private removed-|SB 3000TL-20|-private removed-|1196|0|9.303|0.0|128.66|0.0|1145|0|0|4.918|0.0|0.0|232.88|0.0|0.0|1196|1145|95.7|11877|26025032|49.98|38000.0|36423.7|71.4|OK|Closed|53.6

2019-06-27 17:25:33|2019-06-27 17:25:00|SN: -private removed-|SB 3000TL-20|-private removed-|1234|0|9.596|0.0|128.66|0.0|1178|0|0|5.062|0.0|0.0|232.82|0.0|0.0|1234|1178|95.5|11778|26024935|49.99|37999.9|36423.6|71.0|OK|Closed|52.9

2019-06-27 17:20:34|2019-06-27 17:20:00|SN: -private removed-|SB 3000TL-20|-private removed-|1259|0|9.794|0.0|128.66|0.0|1203|0|0|5.168|0.0|0.0|232.96|0.0|0.0|1259|1203|95.6|11681|26024836|50.0|37999.8|36423.5|71.0|OK|Closed|52.3 

But still no upload to PVoutput.org

What can I do?

According to SBFspotUpload.cfg all should be OK (API key, SID, SQL_Database).


#3

Another update.

After opening the Upload Daemon Log file this is what I get:

**●** SBFspotUpload.service - SBFspot Upload Daemon

Loaded: loaded (/usr/local/bin/sbfspot.3/SBFspotUpload.service; enabled; vendor preset: enabled)

Active: **failed** (Result: exit-code) since Thu 2019-06-27 18:11:48 BST; 24s ago

Process: 1757 ExecStart=/usr/local/bin/sbfspot.3/SBFspotUploadDaemon **(code=exited, status=1/FAILURE)**

 Main PID: 1757 (code=exited, status=1/FAILURE)

Jun 27 18:11:48 raspberrypi systemd[1]: Started SBFspot Upload Daemon.

Jun 27 18:11:48 raspberrypi SBFspotUploadDaemon[1757]: /usr/local/bin/sbfspot.3/SBFspotUploadDaemon: /usr/lib/arm-linux-gnueabihf/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /usr/local/bin/sbfspot.3/SBFspotUploadDaemon)

Jun 27 18:11:48 raspberrypi systemd[1]: **SBFspotUpload.service: Main process exited, code=exited, status=1/FAILURE**

Jun 27 18:11:48 raspberrypi systemd[1]: **SBFspotUpload.service: Failed with result 'exit-code'.**

#4

That’s the error of note. Looks like you are missing libcurl with openssl support. The solution (what package to install) will vary depending on what distribution you are running (perhaps something like libcurl3-openssl), but hopefully that’s a pointer in the right direction for you.


#5

Thank you.

I googled now quite a bit and tried to manually install this libcurl package. None of those have resolved the error message. The uploader is still producing those error logs.

Any more ideas?

Any help would be much appreciated.


#6

If you can provide which distro and version you are running on your pi, I’ll try to help more… Resolution will likely depend on the distro, but it looks like an out of date library or such - and as I re-read the error, SSL3 is deprecated so perhaps it’s that you have some old libs or binaries that expect SSL3 which no longer exists - not what I suggested earlier. Where did /usr/lib/arm-linux-gnueabihf/libcurl.so.4 come from? Make sure that’s an up to date lib, maybe.


#7

It’s the current version from raspberrypi.org (Raspbian Buster Lite).

I also did read that its deprecated. But I have the cleanest setup on my Pi and used sbfspot-config command using this guide.


#8

I am having this exact same problem with the service failing to start due to Curl_OpenSSL_3 not found.
does anyone know if this issue can be easily fixed?
i tried searching the apt repo for curl3 but it seems to not be available to downgrade to.
cheers.


#9

I’ll have to test it with the latest Raspbian first…


#10

Same problem here (no upload to PV-output) for 3 systems. I hope there is a solutions in a few days.


#11

I’ll get a solution asap.


#12

Changed the thread title for future common use.

Still looking for a solution. Hope that it get’s fixed soon.
Thanks for looking into this.


#13

I was able to reproduce the issue and as a workaround I recompiled the daemon for Raspbian buster.
You can find it here: https://github.com/SBFspot/SBFspot/releases/edit/V3.5.2
Download SBFspotUploadDaemon_buster and rename it to SBFspotUploadDaemon
Replace the file in /usr/local/bin/sbfspot.3
Reinstall the service:

sudo systemctl disable /usr/local/bin/sbfspot.3/SBFspotUpload.service
sudo systemctl enable /usr/local/bin/sbfspot.3/SBFspotUpload.service
sudo systemctl start SBFspotUpload
sudo systemctl status SBFspotUpload

● SBFspotUpload.service - SBFspot Upload Daemon
   Loaded: loaded (/usr/local/bin/sbfspot.3/SBFspotUpload.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-07-12 22:50:26 CEST; 13min ago
 Main PID: 2887 (SBFspotUploadDa)
    Tasks: 1 (limit: 2200)
   Memory: 1.5M
   CGroup: /system.slice/SBFspotUpload.service
           └─2887 /usr/local/bin/sbfspot.3/SBFspotUploadDaemon

Jul 12 22:50:26 sbfspot systemd[1]: Started SBFspot Upload Daemon.

#14

Excellent, can confirm that your updated version of the Daemon has fixed the problem for me.

One note, it was also necessary to update the execute permission on the new file once copied and renamed.


#15

Not working for me unfortunately:

**●** SBFspotUpload.service - SBFspot Upload Daemon

Loaded: loaded (/usr/local/bin/sbfspot.3/SBFspotUpload.service; enabled; vendor preset: enabled)

Active: **failed** (Result: exit-code) since Thu 2019-07-18 13:10:30 CEST; 8s ago

Process: 2132 ExecStart=/usr/local/bin/sbfspot.3/SBFspotUploadDaemon **(code=exited, status=203/EXEC)**

 Main PID: 2132 (code=exited, status=203/EXEC)

Jul 18 13:10:30 raspberrypi systemd[1]: Started SBFspot Upload Daemon.

Jul 18 13:10:30 raspberrypi systemd[2132]: **SBFspotUpload.service: Failed to execute command: Permission denied**

Jul 18 13:10:30 raspberrypi systemd[2132]: **SBFspotUpload.service: Failed at step EXEC spawning /usr/local/bin/sbfspot.3/SBFspotUploadDaemon: Permission denied**

Jul 18 13:10:30 raspberrypi systemd[1]: **SBFspotUpload.service: Main process exited, code=exited, status=203/EXEC**

Jul 18 13:10:30 raspberrypi systemd[1]: **SBFspotUpload.service: Failed with result 'exit-code'.**

What does that mean? And how do I do that? I can’t find anything in the sbfspot guide where you interact with execute permissions.
Maybe this does solve my problem.


#16

It means that it is not executable.
Try chmod 755 SBFspotUploadDaemon


#17

Okay. sudo systemctl status SBFspotUpload gives me this:

● SBFspotUpload.service - SBFspot Upload Daemon
   Loaded: loaded (/usr/local/bin/sbfspot.3/SBFspotUpload.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2019-07-18 19:19:47 CEST; 14s ago
 Main PID: 1085 (SBFspotUploadDa)
    Tasks: 1 (limit: 2200)
   Memory: 1.2M
   CGroup: /system.slice/SBFspotUpload.service
           └─1085 /usr/local/bin/sbfspot.3/SBFspotUploadDaemon

Jul 18 19:19:47 raspberrypi systemd[1]: Started SBFspot Upload Daemon.

Looks good to me.
Yet, when looking at the SBFspotUpload20190718.log file I only see this:

[19:19:47] INFO: SBFspotUploadDaemon Version 2.0.0
[19:19:47] INFO: Starting Daemon…

Nothing is uploaded to pvoutput whatsoever…


#18

SBFspot running every 5mins?
What’s in SBFspot.db?

select * from vwPvoData limit 20;

#19

It’s now 08:28 AM here for me.

Output:

SELECT * FROM vwspotdata limit 20;

2019-07-19 08:25:34|2019-07-19 08:25:00|SN: 2100250486|SB 3000TL-20|2100250486|150|0|0.885|0.0|171.38|0.0|145|0|0|0.632|0.0|0.0|229.69|0.0|0.0|150|145|96.7|200|26291428|49.99|38325.7|36736.0|70.6|OK|Closed|41.9

2019-07-19 08:20:33|2019-07-19 08:20:00|SN: 2100250486|SB 3000TL-20|2100250486|171|0|1.007|0.0|171.38|0.0|163|0|0|0.714|0.0|0.0|229.53|0.0|0.0|171|163|95.3|188|26291416|49.96|38325.6|36735.9|71.0|OK|Closed|41.7

2019-07-19 08:15:34|2019-07-19 08:15:00|SN: 2100250486|SB 3000TL-20|2100250486|184|0|1.082|0.0|171.33|0.0|180|0|0|0.787|0.0|0.0|229.34|0.0|0.0|184|180|97.8|173|26291401|49.98|38325.5|36735.8|70.6|OK|Closed|41.6

2019-07-19 08:10:33|2019-07-19 08:10:00|SN: 2100250486|SB 3000TL-20|2100250486|215|0|1.261|0.0|171.53|0.0|209|0|0|0.908|0.0|0.0|230.75|0.0|0.0|215|209|97.2|157|26291385|49.98|38325.4|36735.8|70.6|OK|Closed|41.6

2019-07-19 08:05:33|2019-07-19 08:05:00|SN: 2100250486|SB 3000TL-20|2100250486|217|0|1.27|0.0|171.38|0.0|211|0|0|0.916|0.0|0.0|230.59|0.0|0.0|217|211|97.2|140|26291368|50.01|38325.3|36735.7|70.6|OK|Closed|41.5

2019-07-19 08:00:34|2019-07-19 08:00:00|SN: 2100250486|SB 3000TL-20|2100250486|241|0|1.444|0.0|167.16|0.0|235|0|0|1.022|0.0|0.0|230.69|0.0|0.0|241|235|97.5|121|26291349|50.01|38325.2|36735.6|70.6|OK|Closed|41.5

2019-07-19 07:55:33|2019-07-19 07:55:00|SN: 2100250486|SB 3000TL-20|2100250486|202|0|1.216|0.0|167.03|0.0|194|0|0|0.842|0.0|0.0|230.63|0.0|0.0|202|194|96.0|103|26291331|49.96|38325.2|36735.5|70.6|OK|Closed|41.4

2019-07-19 07:50:34|2019-07-19 07:50:00|SN: 2100250486|SB 3000TL-20|2100250486|163|0|0.958|0.0|171.38|0.0|156|0|0|0.682|0.0|0.0|230.21|0.0|0.0|163|156|95.7|88|26291316|49.97|38325.1|36735.4|70.6|OK|Closed|41.3

2019-07-19 07:45:34|2019-07-19 07:45:00|SN: 2100250486|SB 3000TL-20|2100250486|107|0|0.664|0.0|166.99|0.0|102|0|0|0.447|0.0|0.0|229.43|0.0|0.0|107|102|95.3|77|26291305|49.98|38325.0|36735.3|70.6|OK|Closed|41.3

2019-07-19 07:40:33|2019-07-19 07:40:00|SN: 2100250486|SB 3000TL-20|2100250486|80|0|0.509|0.0|158.81|0.0|69|0|0|0.298|0.0|0.0|231.59|0.0|0.0|80|69|86.2|70|26291298|49.97|38324.9|36735.3|70.6|OK|Closed|41.1

2019-07-19 07:35:34|2019-07-19 07:35:00|SN: 2100250486|SB 3000TL-20|2100250486|71|0|0.447|0.0|163.06|0.0|61|0|0|0.266|0.0|0.0|231.89|0.0|0.0|71|61|85.9|65|26291293|49.96|38324.8|36735.2|70.6|OK|Closed|41.0

2019-07-19 07:30:33|2019-07-19 07:30:00|SN: 2100250486|SB 3000TL-20|2100250486|74|0|0.459|0.0|163.0|0.0|62|0|0|0.273|0.0|0.0|231.44|0.0|0.0|74|62|83.8|60|26291288|49.97|38324.7|36735.1|70.6|OK|Closed|40.9

2019-07-19 07:25:33|2019-07-19 07:25:00|SN: 2100250486|SB 3000TL-20|2100250486|71|0|0.451|0.0|158.81|0.0|59|0|0|0.263|0.0|0.0|227.31|0.0|0.0|71|59|83.1|55|26291283|49.97|38324.7|36735.0|70.6|OK|Closed|40.7

2019-07-19 07:20:34|2019-07-19 07:20:00|SN: 2100250486|SB 3000TL-20|2100250486|89|0|0.551|0.0|163.13|0.0|78|0|0|0.343|0.0|0.0|229.15|0.0|0.0|89|78|87.6|49|26291277|49.99|38324.6|36734.9|71.0|OK|Closed|40.6

2019-07-19 07:15:33|2019-07-19 07:15:00|SN: 2100250486|SB 3000TL-20|2100250486|101|0|0.64|0.0|158.81|0.0|91|0|0|0.401|0.0|0.0|228.54|0.0|0.0|101|91|90.1|42|26291270|49.98|38324.5|36734.8|70.6|OK|Closed|40.4

2019-07-19 07:10:34|2019-07-19 07:10:00|SN: 2100250486|SB 3000TL-20|2100250486|99|0|0.614|0.0|163.15|0.0|90|0|0|0.395|0.0|0.0|228.52|0.0|0.0|99|90|90.9|34|26291262|50.0|38324.4|36734.8|70.6|OK|Closed|40.3

2019-07-19 07:05:34|2019-07-19 07:05:00|SN: 2100250486|SB 3000TL-20|2100250486|82|0|0.507|0.0|163.06|0.0|71|0|0|0.315|0.0|0.0|228.36|0.0|0.0|82|71|86.6|27|26291256|50.02|38324.3|36734.7|70.6|OK|Closed|40.2

2019-07-19 07:00:33|2019-07-19 07:00:00|SN: 2100250486|SB 3000TL-20|2100250486|75|0|0.465|0.0|163.0|0.0|63|0|0|0.278|0.0|0.0|229.28|0.0|0.0|75|63|84.0|22|26291250|50.03|38324.2|36734.6|70.6|OK|Closed|39.9

2019-07-19 06:55:34|2019-07-19 06:55:00|SN: 2100250486|SB 3000TL-20|2100250486|76|0|0.475|0.0|163.04|0.0|66|0|0|0.29|0.0|0.0|229.33|0.0|0.0|76|66|86.8|17|26291245|49.97|38324.2|36734.5|70.6|OK|Closed|39.7

2019-07-19 06:50:33|2019-07-19 06:50:00|SN: 2100250486|SB 3000TL-20|2100250486|71|0|0.441|0.0|163.0|0.0|60|0|0|0.262|0.0|0.0|229.76|0.0|0.0|71|60|84.5|11|26291239|49.97|38324.1|36734.4|70.6|OK|Closed|39.5

My SBFspotUpload20190718.log file from yesterday only contains this:

[19:19:47] INFO: SBFspotUploadDaemon Version 2.0.0

[19:19:47] INFO: Starting Daemon...

[19:21:30] WARNING: SoolwegPV is not yet member of SBFspot Team. Consider joining at http://pvoutput.org/listteam.jsp?tid=613

[21:22:30] WARNING: SoolwegPV is not yet member of SBFspot Team. Consider joining at http://pvoutput.org/listteam.jsp?tid=613

[23:23:31] WARNING: SoolwegPV is not yet member of SBFspot Team. Consider joining at http://pvoutput.org/listteam.jsp?tid=613

Today’s log file only contains those warning messages that I should join that SBFspot group.


#20

thanks, but this is not the query I need (vwPVOdata, not vwSPOTdata)

select * from vwPvoData limit 20;
select * from inverters;
select * from vwDayData limit 20;