Problems displaying highchart

Good morning,

strange behaviour - when i first log in i see the chart / graph as normal but if i tab over to the extended data view of the graph nothing shows, subsequently none of the other graphs (that worked upon log in) show now either. I can replicate this by doing a hard refresh of the page / going incognito (ie everything ok on all graphs but then tab to extended data graph and the highchart fails to load, subsequently all the previously working graphs now also fail to load.).

EDIT: I just realised that the data set on Live data page also remains stuck on the extended data set even when tabbing over to ‘all’ or and of the other options. I can no longer view any other live data.

Error in dev tools for your awareness:

Please provide a link to the page with the error.

1 Like

works fine for me…
Do a force refresh of the page
To make the browser refresh without relying on the cache, use Shift + Ctrl + F5. This triggers a “hard refresh”, so the browser pulls up the newest version of a web page


try a different browser

Have you tried clearing the cache and disabling all extensions?

Yea i already tried all of that and tried incognito per my original post.

Did you go to live data, then tab over to extended? The graph works fine until live data > extended and then all the graphs break.

Ive tried Chrome, Chrome incognito, (chrome is my default so i killed my cookies and cache on this one) a fresh install of Brave, Firefox.

If it’s happening across browsers, what about on different devices? Another computer, phone or tablet? If it’s happening across devices, it’s got to be something network based. Do you run a pi-hole or use a custom DNS?

Hmm good thinking. I do run AdGuard on my ‘server’ (my old laptop running HA in VirtualBox). but the only client is my kids tablet. The home router is set up to googles DNS at present i believe. Ill try changing that to cloudflare or something for testing.

That being said ive hit this issue on my cell phone, and my work macbook pro, at both my home network and my work network (both on and off NordLayer VPN).

I switched off AdGuard completely for now but its worth noting that it has not had any traffic flowing through it (my kid didnt have any tablet time recently so i expected that).

Also if i click the print graph button i do get the correct data in the downloaded image.

Whilst performing some troubleshooting I found that if I changed my Axis alignment drop downs for the ‘Standard data’ within the extended parameter section and hit save (just putting any other axis number in there for the time being) this brought the graphs back. I then changed the Axis alignment numbers back to what they were previously and the graphs have stayed. This is both in my regular browser and incognito.

I had previously tried changing some settings to see what would happen but this is the first time i changed the Axis drop down on the standard data section of extended parameters.

Very odd. Marking the post as fixed for now.

Weird, but glad it’s fixed for now! :blush:

Agreed. I looked at your graphs prior to your update and they were blank for me also. Since your update, they look fine.

Do you have a screenshot of the axis configuration which resulted in the blank graph?