Powerwall - Extended Parameters


The latest version of the PVOutput Integration Service should now work with PW Firmware 1.9.1

The quickest way to upgrade from 1.5.1 to is -

  • Download the above zip
  • Stop the PVOutput Integration Service
  • Copy the file org.pvoutput.integration.jar from the lib directory in the zip and overwrite the existing file in your install directory
  • Start the PVOutput Integration Service
  • The pvoutput.log should indicate that is now running


OK - I’ve got all of my set up done now until the SOE (battery percentage) is available in the next release. I’ve got the solar generation reporting along with all of the params that BJReplay showed in his configuration setup (not using all). Happy I’ve got the big picture for what I want to see, Solar generation, house usage, battery use/recharge, and export to the grid. Thanks to everyone for their contributions.


Hi BB - can you do me a favour and look at my output page? It is reporting funny numbers although the graph looks OK for the extended parameters. The table shows the Power and Power Used as being the close to the same. Sometimes it reflects the solar generated and sometimes the load - it is very random. I can’t figure it out so any help would be appreciated. Thanks in advance.


What does the powerwall.ini configuration look like - either load or solar can be used per service.


I am running two services on the same PC - one for Load and the other for Solar. They are called something different (.name).


Check that the dir=c:/logs directory in pvoutput.ini is unique for both services

If the log directories are the same, the PW0-yyyy-mm-dd.log log file used to upload data will be overwritten each time by either service.


That will be it - and it makes total sense - thank you.


Just to confirm - all looking very good today BB - thanks again…


No problems, thanks for the update.


Anyone here have any idea how to display the Battery SoC extended parameter? I can’t seem to make it appear.

I’m using the Powershell script above to successfully upload battery SoC% as v9 data - I can see the raw data is available on PVOutput (it’s included in the live data CSV download), but the displayed graph always says 0.

https://pvoutput.org/intraday.jsp?id=6483&sid=54376 is my system.

I have v9 listed as Battery, Unit %, Summary Last, Axis 0


It doesn’t look like zero, the last value I see is .675% - which I’m assuming is a decimal placement issue - probably should be showing 67.5%


Yes, I eventually found it had “Divide by 1000” set under the cog.

Divide by 10 works better, but the scale doesn’t really suit, as it is calibrated in KW, with no way I can see to change to %, so it will approach 10KW for 100%. In a perfect world, you could set the parameter for the capacity - 13.5KWHr - and that would be the 100% value it would approach, instead of 10KW.


BB said that the next version 1.5.2(?) was going to have the SOE as a parameter - he didn’t mention how he was going to represent it on the graph though.


It would just be another extended parameter - the usual formatting options would be available.


State of charge data is now supported as an extended parameter.


Upgrade instructions -

Add to powerwall.ini



Looks like axis 1 with % as the unit seems to be the best result so far - still waiting for a full day to see the change to the graphs.


spludge - when I set it up I used “%” as the unit and it show as percentage with the new parameter - you should try again. Search (or Find/Compare) for Bywong - Testing to see the results


BB - question for you. When I choose the extended parameters graph, the scaling is great but when I let it refresh automatically the scale changes (e.g. wait for the next 5 minute interval to show on the graph). Is there a way to force it not to change? Thanks in advance.


Looking good. I’ve written up a for-dummies guide on configuring it here:

Now, if only the Android app could display the Extended Data…


Someone correct me if I’m wrong, but I thought you had to donate to be able to use extended parameters. Your text explanation states that it is optional - a nice to do (although it is nice :slight_smile: I don’t think it is optional).