Omniksol Inverter & Aeonlabs HEM - How to upload via add status


#1

Hello all

I’m gathering all my data in Domoticz to upload it to PVOutput via add status API, but I’m not getting my settings right.

The inverter data is only solar data in Watt e.g.:
17/01/2019 11:00 353,00
17/01/2019 11:05 515,00
17/01/2019 11:10 840,00
17/01/2019 11:15 67,00

The power usage data is also in Watt but can go negative as I can only measure it together with the generated energy e.g.:
17/01/2019 11:00 543,10
17/01/2019 11:05 294,40
17/01/2019 11:10 -166,60
17/01/2019 11:15 490,90

This means that when the power usage is negative I’m exporting to the grid. But if I put the generation in v2 and usage in v4 with n=1 I’m getting incorrect data in PVOutput. Net calculation is enabled and net method is set to instantaneous.
Can someone guide me on how to properly upload and configure my system?

Thanks


#2

When in net mode (n=1)

v2 = Export
v4 = Import

The requests should be -

  • t=11:00&v2=0&v4=543&n=1
  • t=11:05&v2=0&v4=294&n=1
  • t=11:10&v2=166&v4=0&n=1

See the Net Data section in https://pvoutput.org/help.html#api-addstatus


#3

Thanks for the reply!

I get that export/import is divided with these requests, what I don’t get is where the generated data is going. Is it now going to show generation only when my generation > consumption? e.g. at 11:00 I have 353 Watt generated, this is lower then my consumption, so PV Output will not see this as generated power?

I changed my upload script to reflect your suggestion. My data is still completely off, but is it possible I have to wait a day to get correct data?

Last question, is there a reason why you set the time back with one hour?


#4

The previous example assumes gross generation from the inverter is already present and the net meter data is being sent.

The gross generation and net data need to be both sent separately. These are both combined to work out the gross consumption.

Request 1 (Inverter) - t=11:00&v2=353
Request 2 (Meter) -    t=11:00&v2=0&v4=543&n=1

Consumption calculation -

Consumption = Generation + Import - Export 

T = 11:00, G = 353W, C = 353 + 543 = 894W
T = 11:10, G = 840W, C = 840 - 166 = 674W

The two requests at 11:00 produce the same results as -

t=11:00&v2=353&v4=894

#5

Allright that’s more clear now! Did not get that for net values I needed to do 2 separate requests.

I have all my data in one script so I opted to take the second route by not sending the net values. It is uploading this data now. Do I need to turn off Net Calculations in the settings for this?

I calculated the same consumption In excel, uploaded it via live loader, but this is not showing at all. The validate screen gives me correct numbers to import. For instance in the beginning of the day all the values are 0. Is there something I’m missing?

Thanks for the help!


#6

Remove n=1 in the request if you are not sending net data.

Net Calculation option is used for tariffs, it should remain enabled if you wish to calculate Net tariffs.

Please provide the data you are uploading.

The configuration and sample data should look like the below -

11:00,353,894

image


#7

Uploaded my data again and now it seems to stick! :grinning:

Finally a meaningful graph!
Thanks for the help!

ps: can I mark this as solved and give you the credit somewhere?