No upload to pvoutput with SBFspot 3.5.0 running on Raspberry Pi


#1

Hi there

Since a long time that I’m using Pvoutput to upload my data from my SMA inverter.
I bought a raspberry pi to install SBFspot on it. :wink:

I’ve used the curl… command that makes the installation very easy for a newbie like me.

I have several questions and maybe problem:

  • I used SBFspot on a USB key connected to my raspberry. Therefore i’ve added /mnt/usb at the beginning of all directories. The sbfspot.db file is created but nothing inside?
  • My account on PV output is not refreshed with the data of today: what can I do to get the data of November 9th only to check if my install is OK?
  • Does the daemon starts every 5 minutes to upload PVoutput?
  • I’ve tried to use the /mnt/usb/usr/local/bin/sbfspot.3/SBFspotUploadDaemon command but I’ve make my raspberry entering emergency mode: I had to reinstall everything on the rasp. Hopefully everything is fine on the USB key.
  • last question on running SBFspot on raspberry: if the rasp restart, does sbfspot start automatically? Do I have to enter any command?

Thank you for your help, I’m a bit lost.


#2

OK some news.
I install again everything from 0.
Installation is OK on usb key mounted to /mnt/usb, link to the inverter is OK
I ran the command "/mnt/usb/usr/local/bin/sbfspot.3/SBFspot -v -finq -nocsv.

This is the results:
SBFspot V3.5.0
Yet another tool to read power production of SMA solar inverters
© 2012-2018, SBF (https://github.com/SBFspot/SBFspot)
Compiled for Linux (LE) 32 bit with SQLite support
Commandline Args: -v -finq -nocsv
Reading config ‘/mnt/usb/usr/local/bin/sbfspot.3/SBFspot.cfg’
Sat Nov 10 00:18:17 2018: INFO: Starting…
sunrise: 07:43
sunset : 17:33
Connecting to 00:80:25:15:FB:C2 (1/10)
Initializing…
SUSyID: 125 - SessionID: 957834232 (0x391763F8)
SMA netID=01
Serial Nr: 7D2F6B0E (2100259598)
BT Signal=67.8%
Logon OK
Failed to get current plant time (0)
getInverterData(sbftest) returned an error: -1
SUSyID: 113 - SN: 2100259598
Device Name: SN: 2100259598
Device Class: Solar Inverters
Device Type: SB 3000TL-20
Software Version: 02.08.01.R
Serial number: 2100259598
SUSyID: 113 - SN: 2100259598
Device Status: Ok
SUSyID: 113 - SN: 2100259598
Device Temperature: 0.0°C
SUSyID: 113 - SN: 2100259598
GridRelay Status: Information not available
SUSyID: 113 - SN: 2100259598
Pac max phase 1: 3000W
Pac max phase 2: 3000W
Pac max phase 3: 3000W
SUSyID: 113 - SN: 2100259598
Energy Production:
EToday: 0.000kWh
ETotal: 14376.518kWh
Operation Time: 18899.99h
Feed-In Time : 18572.37h
SUSyID: 113 - SN: 2100259598
DC Spot Data:
String 1 Pdc: 0.000kW - Udc: 0.00V - Idc: 0.000A
String 2 Pdc: 0.000kW - Udc: 0.00V - Idc: 0.000A
SUSyID: 113 - SN: 2100259598
AC Spot Data:
Phase 1 Pac : 0.000kW - Uac: 0.00V - Iac: 0.000A
Phase 2 Pac : 0.000kW - Uac: 0.00V - Iac: 0.000A
Phase 3 Pac : 0.000kW - Uac: 0.00V - Iac: 0.000A
Total Pac : 0.000kW
SUSyID: 113 - SN: 2100259598
Grid Freq. : 0.00Hz
SUSyID: 113 - SN: 2100259598
Current Inverter Time: 10/11/2018 00:19:24
Inverter Wake-Up Time: 09/11/2018 08:25:09
Inverter Sleep Time : 09/11/2018 17:40:42
[2018-11-10 00:19:19.703] Error: Can’t open SQLite db [/home/pi/smadata/SBFspot.db]: ‘unable to open database file’


  • ArchiveDayData() *

startTime = 5BE61170 -> 10/11/2018 00:00:00


  • ArchiveMonthData() *

startTime = 5BDADCB0 -> 01/11/2018 12:00:00
Reading events: 2018-Nov-01
Sat Nov 10 00:19:20 2018: INFO: Done.

I have 1 error regarding the sqlite database. SBFspot search in /home/pi directory but I’ve installed everything on /mnt/usb: how can I fix this?

Also how can I run SBFspot manually to retrieve the data for yesterday November 9th and update pvoutput?

Thanks for your help

Louloutte31


#3

I’ve solved this issue by opening the cfg file and manually change the path to the database.
I still get no data for November 9th from my inverter.


#4

I had to enter these last commands to start SBFspot running:
pi@raspberrypi:/mnt/usb/smadata $ sudo systemctl enable /mnt/usb/usr/local/bin/sbfspot.3/SBFspotUpload.service
pi@raspberrypi:/mnt/usb/smadata $ sudo systemctl start SBFspotUpload
pi@raspberrypi:/mnt/usb/smadata $ sudo systemctl status SBFspotUpload

Then my data are now uploaded to PVoutput!


#5

Thanks for reporting this issue…
It’s confirmed being a bug

EDIT: Fixed in V1.0.12