My uploaded data is out by 1 hour


#1

When my local time is 9am and I post my current data it shows on PVout as 10am. The time I am getting from my inverter is correct. I also have the time zone setup correctly on my PVoutput account.

What do I need to do to get the correct time.

One thing I will try in my script is dduct one hour from the time in my inverter before posting, but i’d rather find out what it is happening first.


#2

Check the upload HTTP data, the timezone of your device may be adjusting for DST.

The local time uploaded isn’t changed by PVOutput unless the Adjust Time setting has been set to Daylight Savings.


#3

I have Australia/Brisbane set and DST is greyed out. only pull down menu working is Solar, but there is no other option on that pull down.


#4

I dug deeper, I am using a PHP script and found the time zone setting in the php.ini was set for Canberra not Brisbane. now the time is correct.

Thanks for the tip to check the http string.


#5

My Data, gathered from an Envir system, is transmitted to Pvoutput via the measureit programme. In the Pvoutput live Settings the ADJUST TIME setting is greyed out so i am unable to Select the Daylight Savings option. Is there a solution to this problem. I have tried changing my measureit time zone to one that is different to my own to no avail.


#6

Ive also fixed my problem. In the measureit program there appears to be not allowance for daylight saving changes. I previously changed my global setting to +10.30 which did not appear to work. I then adjusted the setting in each clamp data box to +10.30 which has now displayed the correct time in Pvoutput.