Missing energy generated values

Hello all

My generated solar energy was being sucessfully recorded on pvoutput until the 23/04/22. Now I can see my power value, but average and energy are zero. I’m not sure why this has happened.

I have:

Nothing on my system has changed. The inverter is running fine and producing power.

My system is called “Heaton Chapel Stockport”

Please help

Hi @schneil. Assuming that you’ve made no changes to your PVO setup it looks like you are continuously pushing ‘v1 = 0’ i.e. Energy Generation = 0 and this is why your system is showing no generation / production.

Can you check to see what parameters and their values that your are pushing to PVO?


Hello Grannos

I’ve tried an updated version of the script located here:

The output states:
Status data #1
Operation mode…Normal
Total operation time…99 h
PV1 input power…134 W
PV2 input power…67 W
PV1 voltage…240.6 V
PV2 voltage…211.5 V
PV1 current…0.5 A
PV2 current…0.3 A
Output power…201 W
Energy today…0.00 kWh
Energy total…0.0 kWh
Grid voltage…246.4 V
Grid current…1.1 A
Grid frequency…50.00 Hz
Internal temperature…18.4 °C

If you note the “energy today” and “energy total” values are zero.

Looking at the inverter itself, it seems to be producing power, but the time and date is in red on 00:00:00 2000-00-00 Plus it’s not recording power generated.

Google Photos

So if I’m correct, the script is doing it’s job. It’s just the inverter has gone a bit nuts. Is there an easy way to reboot it?

Hi @schneil. Yes it looks like the script is working but something is amiss with the inverter or at least the software / firmware that’s running behind the LCD display. I imagine your only option is to reboot the inverter unless there is a method for remotely restarting the data gathering part.

I’m not familiar with your inverter so I can’t advise on how to restart it.

Does the inverter get its date / time from the Internet? Do you know if your inverter has a correct IP configuration? Normally the GATEWAY address would be your router’s internal address e.g. or similar. Does the inverter also have a valid DNS address? This would also normally be your router’s internal IP address.

The reason I ask the above is that the inverter would be unable to obtain its time via NTP if it can’t access the Internet with working name resolution.


Hello Grannos

Rebooting the inverter did the trick. It’s displaying time and date correctly. The generated power is being uploaded too.

(It’s not smart enough to get time and date online ad DHCP is a pain. So I set both manually)

Now to get the script running continuously in the background…