Issues with Eagle automatic uploads

I’m new to PVoutput. I have an older Eagle (RFA-Z109) connected to my PG&E SmartMeter. It records net imports from the grid, and exports to the grid. When I tried to set it up through the Auto uploader, the only two options for “Direction” were “Solar” or “Consumption”. Neither are the correct option. There should be a “Net” option as well, but it is not in the “Direction” drop-down box.

See .

I first tried the Consumption option. PVoutput started recording kWh usage, but only in ever-increasing positive numbers.

No data points were recorded between 9:05 and 14:55, presumably because the kWh were going down during the time due to the solar generation.

I briefly tried the Solar option last night also, while the sun wasn’t shining, and my EVs were charging and consuming a fair bit of energy. PVoutput then treated the consumption from the grid as solar generation, which was was clearly wrong.

Why is the “Net” option missing from the “Direction” drop-down ? I believe this would be the proper option to use.

Note1. I have not tried the “Eagle push” method as this requires a subscription, and I’m just trying out PVoutput at this time.
Note2. Since the free version includes only one upload device, I have now changed my device to Enphase to try out.

The “Net” is a donation option. The Eagle Auto Upload device isn’t recommended due its unreliability.

Thanks. That explains it. There is no indication on the Edit system / Automatic uploads / Direction page that “Net” is a donation option. That should probably be fixed !

What device would you recommend ?

For the Eagle, the push option directly from the Eagle to PVOutput is recommended.

This is a donation only option however.

Thanks. I did donate. I have not tried uploading directly to PVoutput yet. Still downloading from Wattvision at the moment.

Using Eagle Push directly from the device to PVOutput is the most reliable method -