Integration Service not running


#1

I run 3 integration services all 1.5.2. Today I moved their location to a different drive. I did this by stopping each service, uninstalling each service then moving the entire folder, reinstalling each service then restarting each service. One of the services is no longer logging. All 3 services are setup for a powerwall (serv 1 comsumption and extra data, serv 2 solar, serv 3 consumption and further extra data) it is service 3 that is no longer working, this points to a different site ID 56863 than serv1 & 2. If I swap the site ID’s serv 3 runs and serv 1 no longer runs, so its the site stopping me?

The wrapper starts fine and and the powerwall, the PVOutput.txt log file just continues to poll the powerwall with
2018-03-02 13:39:38,655 INFO [Thread-2] (WebClient.java:162) - >>> http://xxx.xxx.x.xx:80/api/meters/aggregates
every 30 seconds, but there is no summary and nothing written to the output log file.

Have tried to setup a service on another PC and again it is the site id 56863 that is the problem.

I made no other changed expect the location of the files, not sure what I have done to stop this service running?

Thanks

Edit : Some time ago I set this system status to “testing” which then next time I looked said “decommissioned”, so I set it back to active, assume this isn’t related? It is still receiving API data from my intverter ok


#2

Check that pvoutput.conf and pvoutput.ini have the correct settings.

Each service needs a unique service name and point to unique logging directories.


#3

Thanks, checked this many times, as I said all I did was move the 3 integration services from drive c: to drive d:, the logs were always going to d: so their location didn’t change, pvoutput.ini or pvoutput.conf shouldnt need changing so from when it was working so far as I understand.


#4

If the service starts successfully and there are no errors in the logs then it means there is no matching data from the PW url to upload.

Open the http://xxx.xxx.x.xx:80/api/meters/aggregates url in a browser and check the data matches the ‘power=’ criteria set in powerwall.ini


#5

url=http://xxx.xxx.x.xxx/api/meters/aggregates
poll=30
direction=in
v7=site.energy_imported
v8=site.energy_exported
v9=site.instant_average_voltage

have also added the default
power=instant_power
just in case which is what appears in the browser at the url

still no go, service runs, no errors just repeats the url request every 30 seconds, have also used the .ini from the working service still no go.

I then created a new System and the ONLY change I made to this serv3 integration service is the SID in the PVoutput.ini file, this works fine, uploading data all good.

Its something only specific to SID 56863


#6

The system Id 56863 is receiving data - https://pvoutput.org/intraday.jsp?id=62806&sid=56863

You can send pvoutput.log to pvoutput@gmail.com


#7

These uploads are from my own script now, as the new site i created is working fine with the integration service this combination is fine for me, it’s really just a matter if you want me to send you logs for bug finding? Otherwise it’s all good thanks


#8

Only if you want to fix the problem and upload with Integration Service.


#9

The integration service runs fine on all other sid’s, the problem sid can stay with my script. Will just leave it at that unless other issues arise, I’m sure you have enough on your plate, thanks for the help