Globalapi.sems.com.cn login problems [Problem found]


#1

Didn’t seen any GoodWe forum, so ill post it here.
Does anyone have any problems logging into https://globalapi.sems.com.cn ? ( https://globalapi.sems.com.cn/api/v1/Common/CrossLogin)
I can login via the website with no problem.

I’ve build my own application to log the data from my Goodwe inverter but since the 26th i cannot login, don’t even get a reply anymore.
username, or different ip does not change a thing.

My application will be available when i get it completely working and an decent UI


#2

I am using gw2pvo to get data from the sems website and post on pvoutput. gw2pvo has failed since 26th June. The error I am getting is that “certificate verify failed”.
Cheers Brad


#3

Thank you for pointing me in the right direction.
Their ssl certificate expired the 25th, lets hope they fix that soon. Otherwise i need to figure out how to login to semsportal.com using curl

Updated the title.


#4

Not ideal but i disabled ssl verification by adding CURLOPT_SSL_VERIFYPEER to the curl headers.
At least i can get my data, and i sensitize it so all should be good.


#5

Check this thread if you are using a Raspberry PI to send you data. Older versions of the Debian OS caused my problem. Updating the RPi solved the problem.
See: Error: certificate has expired


#6

That is not the problem in my case, in my case its the remote certificate that is (still) expired.
https://www.ssllabs.com/ssltest/analyze.html?d=globalapi.sems.com.cn&latest

The topic you are referring to tells me the pvoutput,org certificate was expired at that time, which they probably renewed pretty quit but from a certificate with change in the issuer.

Computers got a file (cacert) of certificate issuers which are known and trusted, on computers with windows, ios they will update automatically.

Raspberry pi wont, the manual update you preformed updated the cacert file with all the issuers and now the issuer and certificate from pvoutput got recognized again.


#7

Gw2pvo has been updated. It seems to have solved the problem.
Cheers Brad