Gaps in live data


#1

Since 2nd November I’ve started getting gaps in all my live data. I’m logging at 10 minute intervals because OpenWeatherMap data was already useless due to gaps at 5 minute intervals. is this a temporary problem with PVOutput? It was working fine up to 1st November.


#2

No gaps in mine…uploading from Fronius and Tesla PW, if that helps. What device is doing the logging, and have you changed or had any problems in internal network connection (wifi? hard cable?) with your device?


#3

The system has a 10-minute status interval, while the Solar Edge Energy setting is enabled which means generation data is only available at 15-minute intervals. These intervals are rounded to the nearest 10-minutes which will result in gaps.

Either disable solar edge energy or use a 5-minute or 15-minute interval.


#4

Thanks, BB. I’m not that well up on the API stuff. Originally the PVOutput Primary Device was set to log my solar edge output direct. When I got the Powerwall 2 I followed through the Mikes Gear procedure to set up an always on PC to upload the live data to PVOutput. Then I added OpenWeatherMap in the Weather Device in Automatic Uploads. This gave problems with 5 minute interval logging, broken weather data and no line on the graph. So I ended up setting the Live Settings Status Interval to 10 minutes, which produced solid lines most of the time.

As I mentioned first, on 2nd November all the data lines became much more broken, i.e. frequent data gaps at the 10 minute interval rate. Following your suggestions, I first changed to logging interval to 5 minutes, and then 15 minutes. This did not achieve anything, particularly the 5 minute interval.

Then I turned off OpenWeatherMap data by setting Weather Device to ‘None’. I was beginning to suspect that this was the root cause of the problem. I also reset Status Interval to 5 minutes. This did produce a much improved result but still quite a few gaps.

Finally I set the Primary Device to ‘None’, turning off Solar Edge logging. Now I have no 10 minute data gaps and solid graph lines, except that very occasionally, the V7 parameter, battery flow, has a missing data point. It is only logging at 10 minute intervals despite having 5 minutes set. Is that what you mean by the system having a 10 minute status interval? I’m puzzled by this because I have a nearby friend, site name LC, who is able to log both is Powerwall Gateway output and OpenWeatherData at 5 minute intervals with no data gaps. Maybe I’ve got something wrong elsewhere in my settings. My friend knows a lot more about API stuff, so maybe Should get him to check my settings.

I have forgotten the details of the setting in the files on the always on PC and I’m away from home at the moment, so maybe there’s a time setting in there that needs changing?

Anyway, thanks for your advice, BB. I have got somewhere now.


#5

The Status Interval setting controls how the data is received and stored. When a 10-minute status interval is set on the system all uploads are rounded to the nearest 10-minutes, even if these uploads are occurring every 5-minutes.

It is probably the open weather data city used which has a better update frequency from open weather map. Certain locations provide more frequent temperature readings/updates.

Unfortunately open weather map does not provide history query to fill in gaps in the data.


#6

I think I may have found least part of the reason why some data is missing. Yesterday it didn’t log any data at all. Then I found that the Powerwall Gateway 2 has two IP addresses, one is DCHP, the other is static. My Powerwall.ini file on my logging PC was set to the DCHP address and the current actual address was different to that which I put in the .ini file. I guess the Gateway must have been changing the dynamic IP address occasionally. I’ve now reset the .ini file to log the static address. Hopefully that will sort out the gaps and logging interval for the Powerwall data. OpenWeatherData is still not logging at 5 minute intervals though, but I can live with that.


#7

You might need to go through and see if you have any rogue second DHCP servers active in various bits of network kit. The usual way of dealing with this is to set the PW2 to use DHCP, but in your DHCP server hard-code a particular IP address to be associated with the PW2’s MAC address - so the PW2 uses DHCP normally, but always gets back the same IP address each time.
If there is another device also thinking it is a DHCP server and responding, then it will be a race as to which response gets to the device first, which is clearly unpredictable. It can be a PITA trying to track down if two DHCP servers are responding, using the same IP address ranges - because most of the time, it will work out ok.


#8

Thanks, willisave. Having sorted out the IP address in the Powerwall.ini file I recovered all the data except battery percentage - I’d forgotten that there is a second occurrence for that at the end of the file. Now I have all the data recording reliably. However, I’ve now found that the old DCHP address has disappeared and the static one is now DCHP. I’ve changed it’s settings to “Always use this IP address:YES” in the hope of pinning it down! Will that work?


#9

I’m a little hazy on your specific setup - In which device have you set ‘always use this IP address:YES’?
There are three separate ‘devices’ that need to all be set compatible with each other:

  • The PW2 config - set to use DHCP not STATIC. If the gateway is connected to a hardwire Ethernet cable, this is part of the Ethernet setup. If its connected to a WiFi network, I think it must use DHCP in any case - I can only see the screens for selecting whch WiFi access point to connect to, there doesn’t appear to be any other config for a WiFi connection.

  • Your broadband router, which is the DHCP server (and there should only be one DHCP server): There should be a table or screen to assign a specific IP address to a specific MAC Address - in mine its called ‘Address Reservation’, but the name and menu item varies between different router vendors. Add an entry in this table to assign a specific IP address to the hardware MAC address of the PW2 gateway. This is the known address the server will send back to the PW2 when it asks for an address using a DHCP request, the same IP every time.

  • the always-on PC with the PVO code and ‘powerwall.ini’ file - set the IP address in powerwall.ini that you assigned in the ‘Address Reservation’ (or whatever its called) in the router.

glad you seem to have it sorted, hope this makes it clearer.


#10

While the IP addresses put into configuration files may be designated as static that does not actually control the IP address settings. You router controls the IP addresses and you can set them to dynamic or static by accessing the function in your router. While some users seldom make changes at that level it is important to know that when you use the dynamic IP addressing in your router the address will change under certain conditions such as rebooting the router or power cycling it. For this reason the nature of the IP address must be set in the router and that setting must be “reflected” in your configuration files.
It may be possible that your programs can detect the change in a dynamic IP and compensate based on you configuration file entries. In either case you need to know whether your router is using static or dynamic IP addressing in your router for your device. Unfortunately each router uses a different user interface and finding your way around and knowing what you are doing is problematic for many users. If you are not sure how to determine how your router was set up for IP addressing is best referred to the manufacturer’s help desk.