Gapps in consumption with solar production


#1

Goodday everyone,

I’m facing a problem with gapps in my data:
https://pvoutput.org/intraday.jsp?id=80953&sid=71730

I’m using a Youless in v4 mode on a smart meter with P1, which is working great. It is uploading data every 5 minutes.
I’m also using the Solaredge API to import my solar production at 15 minute interval, I cannot seem to set it any lower but that may be a donation restriction?

It seems when I’m producing solar my Youless uploads are sometimes failing, and I have no idea why. When I am not producing solar energy, I never have gapps. So I see something in relation why I’m getting gapps due to the solar production.

I think PVOutput seems to skip out on importing my Youless data whenever it is importing from the Solaredge API or something.

I’m kind of stumped, I have tried many things. But I just cannot get it to work. Does anyone have a clue why this is happening?


#2

It may just be a timing discrepancy between the two uploads. It may be the occasional sample is not actually being skipped, but the value is being assigned to the next 5-minute bin, and is then overridden by the subsequent upload being assigned to the same 5-minute bin, leaving a hole.
Have you tried adjusting the ‘shift time’ parameter with one of them, to move the samples forward or backwards by a minute or two, to de-synchronise them? it may help if the samples are received in the same order each time, but if both systems are tryign to upload precisely on the same 5-minute or 15-minute instant, occasionally the upload packets might be received in a different order - solaredge first then youless, and occasionally swapped by a few milliseconds, which might cause them to be assigned to different 5-minute interval bins for display purposes.


#3

Yes for 4 days upon eachother I re powered my Youless in the morning because I was thinking the same. Yet i did not seem any notable difference.

Ill try donation mode to see if I can set the solaredge to 5 minute interval… and perhaps reset my Youless a couple times more to see if I can fix my issue.


#4

In the settings under ‘Automatic Uploads’ is a field for shifting time +/- a few minutes
image

Try using this to ‘delay’ or advance the Youless readings by a minute or two, rather than by repowering the Youless device itself.


#5

Tyvm👍 have not yet noticed this option, thanks a lot.

As of today I have no gapps for now, not yet touched any settings :crossed_fingers:


#6

That option is a donation only option, so I went ahead and donated was planning to anyway.

I now went ahead and used 2 child systems to report to a parent system.

Hopefully this works better, since I also had problems with Solaredge API on PVoutput reporting less than what is actually produced. Noticed that through the SE app and on my Hassio that also taps into the SE API.