Fronius Push


#62

I am using 1 minute already. Some whirlpoolers seem to use &delay=15, is that worth trying? and what about the v3=None that I’ve seen mentioned, is that required?

I also just noticed my inverter stopped reporting at 6:55pm… it’s never done that before (and is definitely still on). hmmm.


#63

Increasing the delay may help, but if the import/export value don’t align with inverter generation then the result will still be 0W. Delay should be added to the meter push, there is already a built-in delay when using auto=1

The v3=None (consumption energy) setting isn’t applicable when using auto=1


#64

OK, today’s output matches fronius data exactly, which is awesome!

however, it still stopped reporting when solar stopped generating… which shouldn’t happen because I have the smart meter and i’m still consuming. last night the same thing happened, and it didn’t kick back in until about 10pm: https://pvoutput.org/intraday.jsp?id=59952&sid=53351&dt=20171011

any ideas on this front?


#65

Seems like a bug when using nodayenergy=1 with auto=1 which has been fixed now.

Thanks for reporting this.


#66

awesome, appreciate your response and help bankstownbloke :slight_smile:


#67

Could you give links to these please? Thanks.


#68

new user - system 1 week old only, have read this thread and numerous on WP, confused!!
have been getting erroneus readings from day one …
some caused by my having the latest problematic fronius firmware (hopefully
fixed using above recomdnations for nodayenergy)
below is the updated settings i just added… tomorrow will be intersting if issues fixed.
would appreciate your help/confirmation on settings required on fronius push service and also pvoutput - to correctly display my house (“sum of both inverters”)
my house has two fronius inverters and two fronius smartmeters - both at feed in point (yes! two smartemeter at same feed in point … some limitation of the
hybrid symo inverter that requires it to have its own … dont ask!)

my latest config for push settings and pvout

fronius symo Hybrid 5kW inverter
fronius inverter push settings
sid = xxxx5
interval 1min
&v3=none
(no push service for meter data from this smartmeter)

fronius symo 10kW inverter
fronius inverter push settings
sid = xxxx4
interval 1min
&v3=none
&nodayenergy=1

fronius 10kW smartmeter push settings
sid =xxxx0
interval 1min
&auto=1

in pvoutput i have three different SID (donation mode enabled)
SID = xxxx0 (the house)
status interval = 5min
net delay = none
net calculations = enabled
net method = average
parent sustem = none
aggregation mode = solar

SID xxxx5 (5kW inverter)
status interval = 5min
net delay = none
net calculations = disabled
net method = average
parent system = the house sid xxxx0

SID = xxxx4
ststus interval = 5min
net delay = none
net calculations = disabled
net method = average
parent system = the house SID xxx0

thanks in anticipation of your help/validation


#69

The setup should be something like -

  • Setup 3 systems (5kW, 10kW and 15kW)
  • Generation push to 5kW system, child of 15kW
  • Generation push to 10kW system, child of 15kW
  • Meter push to 15kW with (auto=1 and delay=15)

This won’t work and it is not possible to combine smart meter data, only one smart meter push should be used and this should represent total house consumption


#70

thanks for response,
smartmeter issue resolved - physically removed one of them.
have them setup per your above

can you pls confirm if the other settings
are correct for the parent system per below

parent system
net calculations = enabled
net method = average
aggregation mode = solar


#71

This looks good, if Net Method average gives 0W consumption results, try using Instantaneous instead.


#72

thanks for confirmation,
worked very well for 24/10, didnt miss any data,
but 25/10 had two large periods of no readings (generation or consumption) - had not made
any changes from prev day,
inverter reported flawlessly to solarweb all day … and is showing correct solar yield (generation) locally.
only conclusion is that for two extended periods on 25/10 , the pvout server had issues?
cant explain 4+ hrs of no data (no generation, no consumption, no voltage or meter data …)


#73

The push stopped at 11:00AM, no server issues otherwise other systems would also stop logging.


#74

Hi, I have a Fronius inverter and meter that’s been installed a few days ago. I was getting usage data until 13:35 today. Here’s my system: https://pvoutput.org/intraday.jsp?sid=54836. I setup another push to http://putsreq.com, captured the json and sent it using curl. The response was OK 200: Added Status but still nothing has updated. Are there any current issues preventing data coming through or is it something wrong with what the meter is sending?

The meter is pushing the data with /service/r2/froniuspost.jsp?auto=1&54836&key=xxx and the inverter with /service/r2/froniuspost.jsp?nodayenergy=1&sid=54834&key=xxx

Any help would be greatly appreciated.

Cheers,
Dave.


#75

It seems to have come back to life just before midnight last night. I think maybe this is due to it being wired wrongly. The original inverter was wired on the grid side of the meter. So it wouldn’t have been seeing the export from that inverter. Maybe it stopped at the point the exports were higher than the initial starting point for the day.

Cheers,
Dave.


#76

The push settings for meter and inverter is correct. The auto=1 setting starts working after the start of a new day as it relies on the start of day total energy import/export reported by the push.


#78

This is configured on the inverter rather than the Fronius’ solar web site.


#80

power graph does not seem right with spikes.
On shed no load 30w pump inverter that on standby as seen during night.

Reading solar web vs pvoutput
production 31.8 kw 31.5 kw
to grid 31.14 kw 31.14 kw
used 0.66 kw 0.63 kw
totals seem to be very close just power seems to have large spikes
power goes to zero at times night never below 24 watts
fronius primo 6
inverter noenergyday =1
meter auto=1&delay=15


#81

The push settings are okay.

There are a few data points where the consumption energy drops, (this is not visible on the graph), which is invalid and the power is recorded as 0W. The next recording the energy jumps back to normal - causing the spike.

The push processing would need to be enhanced to discard these energy drops.


#82

The fix has been applied. Today’s updated data shows 0W when energy consumption is not increasing which is correct.

There isn’t much that can be done on the PVOutput side if Fronius is reporting a drop in energy consumption from the Fronius import/export + generation data.


#83

Hi,

I have a new system with both an inverter and a smart meter, It was running for a week with just the meter, at first the value was too high, this was fixed by inserting v4=PowerReal_P_Sum on the meter push. But now PV has been hooked up (yesterday) I am reading both values, my consumption data is way off, it appears to be reading energy generated as energy used. I tried removing the v4 without success.

There is allot of mention of using “auto” to fix this, but I am not a donor (yet), I want to ensure the system actually works before I start donating, can anyone confirm if being a donor is the only way to make this setup work?

Thanks,


Difference between solarweb and pvoutput values