Fronius Push

added mine in too the testing pot as well :slight_smile:

So when does this take effect? Tomorrow? The power is still about 200w over what the smart meter says is being used.

Sorry, this is not clear to me. My inverter is configured (presumably by my installer) exactly the same as the PVOuput documentation says at There is no “n=1” to replace. So should I just add the “auto=1” parameter?

This setting is for the Meter Push not the Inverter Push.

Yes, replace n=1 with auto=1 on the Meter Push configuration.

The setting only works for donation activated systems.

That would be why i didn’t notice any changes then :slight_smile:

BB, as I said above, there is no “n=1” in the standard configuration to replace. Do we just add “auto=1”? Is there also any change required within PVO settings? I am a donator.

If the meter configuration does not have n=1 i.e. it is uploading Gross Consumption then auto=1 should not be added.

Using auto=1 with a Gross Consumption data will result in incorrect readings.

The auto=1 option should only be used to replace n=1. It takes the Net data + Inverter data uploaded by the Fronius and calculates Gross Consumption.

Hi @bankstownbloke - I switched mine over this morning and ‘energy used’ stopped dead. Switched it back to n=1 and it has updated all of the previous data as well. Have I missed something here?

Was n=1 replaced with auto=1? The auto option only works for Net meters.

Thanks - auto=1 has certainly tightened up the Fronius push results - originally I was getting ~4% accuracy - this is more respectable…

I had 32 x 5-minute pushes dropped according to PVOutput during the 24-hour period (by one end or the other) - so that would account for some inaccuracy I assume?

Question please - what push parameter or internal calculation do you use to get the imported kWh?


I’ll give it another go.

Same thing @bankstowbloke, ‘energy used’ has stopped updating in PVOutput (0.533kWh).

Here’s the string I’ve used -

My data for today is at

I’ll leave it set as is so you can take al ook at it.

Seems to have kicked over and started counting now - maybe the counter start from 0 and had to reach what the existing balance was already showing?

@peterharvie - Good to see this is working.

The following parameter / calculation logic is used -

EnergyReal_WAC_Plus_Absolute - (Lifetime Import)
EnergyReal_WAC_Minus_Absolute - (Lifetime Export)

The first push of the day records the above two as the starting point.

Subsequent pushes during the day -

EnergyReal_WAC_Plus_Absolute (Current) - EnergyReal_WAC_Plus_Absolute (Start) = Day Energy Import at that timestamp.

Gross Consumption (Energy v3) = Current Generation (from inverter push) + Day Import - Day Export

From the above energy data we can calculate the average power.

The configuration looks fine, but you need to have replaced n=1 with auto=1. i.e. Fronius smart meter is measuring Net data.

If it is measuring Gross data, then the auto=1 setting won’t work.

@mrgrumpy83 - If the below is your system, then it looks okay -

Yeah that’s me. Was fine yesterday, was just the kickover partway through the day before which held things up for a bit. After reading your explanation on how it calculates this makes total sense.

I’ve entered auto=1 and the Power Used drops to 0 during some periods. I’ve got a battery connected to my system, so this might have some relevance?
Is there a setting I should change or is this a function of the battery?

If the battery affects the following values then the result would be different -

  • EnergyReal_WAC_Plus_Absolute - (Lifetime Import)
  • EnergyReal_WAC_Minus_Absolute - (Lifetime Export)

The generation green line figures also not look correct as this should be the inverter push value.