Fronius push consumption query

Hi all, I’ve spent the last few days looking around and I think I’ve arrived at a set of push commands that should work well(of course I’m here to be corrected as needed!):

Inverter push additional arguments:

Meter push additional arguments:

Log push additional arguments:

LInk to my data for today: Fronius31430939 7.770kW

I tried various push settings in previous days but decided to stop yesterday and wait for the midnight rollover. So today July 28th onward is the only thing I’m really checking. The thing that seems odd to me is that power consumption is zero. From what I’ve read, consumption should be:

Consumed = Generation + EnergyReal_WAC_Plus_Absolute - EnergyReal_WAC_Minus_Absolute

Querying through http I get what look to be sensible values for EnergyReal_WAC_Minus_Absolute (they increase overnight in line with expectations). Here’s the first few few points from midnight:

“EnergyReal_WAC_Minus_Absolute” :
“Unit” : “Wh”,
“Values” :
“0” : 10571843,
“300” : 10571881,
“600” : 10571917,

EnergyReal_WAC_Plus_Absolute is unchanging before sunrise.
I’m making the assumption that DAY_ENERGY is correct as PVOutput is showing no energy generation.

So I’m wondering how for the first five minute interval 0 + 0 - (-38) is equalling zero as my consumption?

Any peculiarities with my install… Was using firmware 3.23.2-1 (think that is right),and did note this morning that 3-23.3-1 was available. and updated it (after the data posted above was gathered, so the data above is for the older firmware). Meter is on the consumption path (verified it physically) and is marked as such in the fronius settings. If curious, was previously using n=1 and nodayenergy=1 and having no (large) problems. Was looking to try out the improved auto=1 as the motivation for this.

I’ve probably missed some flag somewhere but if anyone can offer help, much appreciated. Solarweb shows correct consumption.

EDIT: The log push seems to be doing something to the consumption data after sunrise, but the values are too low.

Further info: I’ve discovered that EnergyReal_WAC_Plus_Absolute has not changed since July 15th, when I had a switchboard modification done to allow a generator transfer switch to be installed. Should have spotted that. I just expected no increments overnight and saw them that way and assumed it was working.

So this is not a pvoutput problem. Solarweb has been working fine somehow, I guess they get their values in another way. I wonder what could possibly cause EnergyReal_WAC_Plus_Absolute to stop incrementing.

Alright I think I’ve cracked this.

tldr: if you are in the minority and have a Fronius meter on ‘consumption path’ rather than ‘feed-in’, you’ll either have to rely on PowerApparent_S_Sum or donate and use mode=1 on your log push.

When my generator was installed they had to connect the solar upstream of an isolating changeover switch. The smart meter is downstream of that switch. This means I have a setup that is ‘consumption path’ (let’s call it CP from now on) for data measurement vs what almost everyone else seems to have which is the smart meter on the grid side of the inverter.

The previous meter push values I had that were using n=1 stopped working, auto=1 didn’t work and all I had access to was apparent power. I reckon this is because I used to be on feed-in and had to be swapped to CP.

According to the Fronius Solar API V1 table 4.8.6, PowerReal_P_Sum is NEGATIVE for power consumption if you are using CP. So the consumption values pvoutput was reading with n=1 were negative, and consumption was reported as zeros. Mystery 1 solved.

So why didn’t auto=1 work? Fronius says just under the same table in the API guide

The values EnergyReal_WAC_Sum_Produced and EnergyReal_WAC_Sum_Consumed represent the values for the Smart Meter itself. The values EnergyReal_WAC_Minus_Absolute and EnergyReal_WAC_Plus_Absolute represent the values for Solar.web. Now it depends where the Smart Meter is installed (Feed-In-Point or Consumption-Path), so that either EnergyReal_WAC_Minus_Absolute is the same as EnergyReal_WAC_Sum_Produced or EnergyReal_WAC_Sum_Consumed.

In my experience, what it showed was that since export was no longer flowing through the smart meter (the inverter is upstream of the meter now), EnergyReal_WAC_Plus_Absolute just stopped incrementing. It confused me because it was a large number, but evidently it stopped on the day of the transfer switch install, when I probably went from feed-in to CP.

PVOutput is expecting EnergyReal_WAC_Plus_Absolute to actually be consumption for a feed-in setup, and the formula that auto=1 is using:

Consumption = Generation + EnergyReal_WAC_Plus_Absolute - EnergyReal_WAC_Minus_Absolute

results in positive but nonsensical values when I’m producing more power than using, but then zeros (negative values for consumption) under any other circumstance.

So I can’t use n=1 and can’t use auto.=1. Clearing those flags allows PVO to look at PowerApparent_S_Sum and see that it is valid (positive) but in my experience highly inaccurate.

Step forth the saviour, the log push with mode=1. I suppose BB must have written this for some other rare case but I’m glad I found it:

mode=1 Export Meter

Gross consumption recorded on the export meter EnergyReal_WAC_Minus_Absolute. Used in the Meter Log Data push

This seems to be accurately capturing the correct consumption (do I then have an auto=1 type solution? it would seem so), and the only bad thing I have to deal with is PowerApparent_S_Sum values and the energy calcs from the meter push for a max of one hour before the log push corrects it all.

Phew I don’t know if anyone will make it this far but would be interesting to see how much of the above I’ve got right, and if I have, hopefully it helps someone else!

1 Like