Fronius Primo with S0 Meter (kwh Pulse) - SOLVED


#1

I have a Primo 5.0.1 with a external chinese meter that send kwh pulse to the Fronius inverter. It works fine and I have the consumption data on my app and in the Solarweb site.

Can I send the meter data to PVOutput or only the Fronius Smart meter work?

I tried to put the standart configuration on the Inverter’s push service but it show me the “Connection not possible” warning.

Can anyone help me?


#2

Go to your inverter settings/meter page (http://your-inverter-ip/#/settings/meter) and tell us what primary meter is listed and what it’s settings report.


#3

Out of curiosity if you go to http://fronius/#/about_system where fronius is the LOCAL IP address of your inverter what do you see?

I have a Fronius Symo with an attached Fronius Smart Meter.

29

Can you double-check the syntax of your PUSH string for the meter?

You should / might also see a figure for the consumption as I have show in the graphic below.


#4

Hmmm,

I just took a look at your system 72838 and it seems to be populated with CONSUMPTION data.

?


#5

I have solved the problem.

First answering the question:

My Fronius IP is 192.168.15.10

I used the site https://webhook.site/ and directed the PUSH service of the inverter to the WEBHOOK, to “see” what the inverter is sending in the POST message.

So I make the adjustments and that’s the push sintax for the S0 meter:

/service/r2/froniuspost.jsp?sid=XXXXX&key=YYYYY&v4=PowerReal_P_Sum

And the Inverter’s push stay like:

/service/r2/froniuspost.jsp?sid=XXXXX&key=YYYYYY&dayenergy=1

And the LOG push:

/service/r2/froniuspost.jsp?sid=XXXXX&key=YYYYY&v7=Voltage_DC_String_1&v8=Voltage_DC_String_2&v9=Current_DC_String_1&v10=Current_DC_String_2&v11=EnergyReal_WAC_Sum_Produced

And now is working perfect:

Thank you for your interest and help.


#6

Wait so you have meter data getting pushed from the fronius website from a non fronius meter?
And does the extended data work aka voltages etc? I could never get that to work. I figured it was because i have a non fronius meter.

EDIT:

Sweet now I have fronius push handling my S0 meter data hopefully that means it wont drop out when my flukso drops out now… ( i made a pulse splitter so it could go to both the fronius and the flukso)
will test in another system i have and if working correctly i will add it to my main system
got the log data to push the extended data values too. pity they cant be live although i have my Raspberry PI doing that anyway.
last thing for me is getting modbus working to get each string as its own system and then creating a parent/child setup to see what each string is doing independently.


#7

My meter sends only kWh pulses, not extended data.


#8

This says your sending dc voltage and current to extended data v7, v8, v9, and v10


#9

Sorry, this is the push line of the S0 meter

service/r2/froniuspost.jsp?sid=7xxxx8&key=yyyyyyy&v4=PowerReal_P_Sum