Fronius API Device ID

Recently my Frontius Galvo 2.5 had a bios/firmware update and my data logging stopped working.
I use the units API to pull the data I need to upload here and to also generate a graph on my homepage as well as send the data to my own SQL Database.

previously this URL worked for the past 5 years
http://192.168.1.123/solar_api/v1/GetInverterRealtimeData.cgi?Scope=Device&DeviceID=1&DataCollection=CommonInverterData

That now returns an error about the Device ID.
{
“Body” : {
“Data” : {}
},
“Head” : {
“RequestArguments” : {
“DataCollection” : “CommonInverterData”,
“DeviceClass” : “Inverter”,
“Scope” : “Device”
},
“Status” : {
“Code” : 6,
“Reason” : “CGI-Args: Invalid parameter ‘’ for attribute ‘DeviceId’ (must be numeric)”,
“UserMessage” : “”
},
“Timestamp” : “2022-02-02T10:30:45+10:00”
}
}

Keeping this short and sweet, many hours later I find out they changed the DeviceID to DeviceId
Notice the D in ID is now lowercase. I did not find this in any of their latest document updates.

So now when you use DeviceId it works

http://192.168.1.123/solar_api/v1/GetInverterRealtimeData.cgi?Scope=Device&DeviceId=1&DataCollection=CommonInverterData

{
“Body” : {
“Data” : {
“DAY_ENERGY” : {
“Unit” : “Wh”,
“Value” : 3184.5999999999999
},
“DeviceStatus” : {
“ErrorCode” : 0,
“LEDColor” : 2,
“LEDState” : 0,
“MgmtTimerRemainingTime” : -1,
“StateToReset” : false,
“StatusCode” : 7
},
“FAC” : {
“Unit” : “Hz”,
“Value” : 49.950000000000003
},
“IAC” : {
“Unit” : “A”,
“Value” : 7.5700000000000003
},
“IDC” : {
“Unit” : “A”,
“Value” : 7.6799999999999997
},
“PAC” : {
“Unit” : “W”,
“Value” : 1776
},
“TOTAL_ENERGY” : {
“Unit” : “Wh”,
“Value” : 16288770
},
“UAC” : {
“Unit” : “V”,
“Value” : 239.90000000000001
},
“UDC” : {
“Unit” : “V”,
“Value” : 236.5
},
“YEAR_ENERGY” : {
“Unit” : “Wh”,
“Value” : 264955.5
}
}
},
“Head” : {
“RequestArguments” : {
“DataCollection” : “CommonInverterData”,
“DeviceClass” : “Inverter”,
“DeviceId” : “1”,
“Scope” : “Device”
},
“Status” : {
“Code” : 0,
“Reason” : “”,
“UserMessage” : “”
},
“Timestamp” : “2022-02-02T10:33:03+10:00”
}
}

I hope this helps someone.
My Homemade Graph
http://downunder.ddns.net/
My PV Output
https://pvoutput.org/intraday.jsp?id=62356&sid=55485

just wanted to say thank you!! was pulling my hair on that

have a Fronius Primo 5.0-1 with the same problem, changing DeviceID to DeviceId fixed it.

Hi @skozzy that’s not the only change to the API that Fronius have made but NOT documented.