Fahrenheit selected but temps are in Celsius


#1

On my site: https://pvoutput.org/list.jsp?sid=54099

I have Fahrenheit selected for my weather data format, but all the temperatures are showing in Celsius. Why???


#2

Click Settings and select the Temperature Unit


#3

That did it! :slight_smile: Thanks


#4

It’s important to make sure you are logged in as well. Remember your data is public, so you can view your array without being logged in via a bookmark or link but the system will not convert to your preferred settings unless it knows it’s you!


#5

hi your live data seems to be showing inverter temp in deg C as that what solaredge send its temp in,not weather temp as the inverter will override weather temp with its data


#6

My setup seems to only show Fahrenheit when I am logged in. When logged out it reverts to Celsius. Have tried several settings but they don’t seem to affect the resulting display of temperature units. My weather station Temp in extended variables was showing Celsius as well until I used the formula to convert it.


#7

Hi it seems that you can have either the solaredge temp or the weather station temp on the live page in deg F or C if you wish,it is not possable to have BOTH on the same page,solaredge temp and voltage on the live page and weather temp on extended date is possable if you want that way, the reason it changes from F to C when you log out is the solaredge overrights the data from the weather station,see below for how to change solaredge settings.

image

if you have temp disabled as above it showes weather temp on your live page.
I had a similar problem. I wanted to send the WU data to the “Main” page and the inverter temperature to the “Extended Data” page. But because there is no option to send the inverter temperature to anywhere but “Main”, I had to put the WU (ambient air temp and solar radiation Data) on the “Extended Data” page and leave the inverter temperature (and voltage) on the “Main” page. If you decide to do this, note that even if you choose 'Fahrenheit’in the settings, the WU temperature may still be displayed in degrees Celsius on the “Extended Data” page. To get the temperature to display in degrees-F, add the following conversion formula to the “Extended Data Rule” field: vX = vX * 1.8 + 32
I tried different ways to enter the formula, but couldn’t get the syntax right until someone on SolarPanelTalk Forums helped me out (thanks jasonvr).

I know this doesn’t solve your issue about getting WU temperature to display on the “Main” page, but this is how I got around the problem.

or this image


#8

Default temperature is saved as C.

  • When logged out, temperature displayed is always in C
  • When logged in, temperature will be displayed in the selected unit (F or C) under the account settings.

The ‘Temperature Unit’ on the solaredge settings is to enable F, as reported by solaredge, to be converted back to C to be saved on PVOutput.