Error: certificate has expired


#1

Hi,

I am a happy user of pvoutput so thanks for this service. But today suddenly i get the following error on my posts to the endpoint: “Error: certificate has expired”

https://pvoutput.org/service/r2/addstatus.jsp?d={{{date}}}&t={{{time}}}&v1={{{generated_today}}}&v2={{{power_output}}}&v5={{{temperature}}}&v6={{{tension_input}}}

Could it be that the certificate is expired? Or should i disable ssl checking (not my preference)

Has anyone else have this problem?

Regards, Martin


#2

Same issue here. It started at 10:55 UTC.
I just sent them an email to check the error.


#3

Same form me.
For now I use the option -k in the curl command to disable the certificate verification.
Tomorrow I try to figure out how to use the new certificate.


#4

Looks like Rainforest Cloud can’t use service/r2/eaglepost.jsp too… (Eagle-200)


Globalapi.sems.com.cn login problems [Problem found]
#5

Me too. Stuck at initializing on my Eagle-200. Lots of companies and websites have been plagued by this issue today. The certificate authority that expired was AddTrust External Root.


#6

The expired root certificate has been replaced and command line https queries should now be working as normal.


#7

Still broken for me. Not connecting. Stuck at initializing.


#9

Some of my uploads depended on the API. Those uploads have stopped. The PWS data is still being uploaded. However, the standard variables are not being logged as of 21:10 PDT. extended variables from my Neurio stopped being logged since 3:45 PDT except for a short interval in the afternoon.


#10

@bankstownbloke Thanks for the heads-up. For me everything started working again about 8 hours ago. So thanks for your help. For the others, maybe a restart of your system?


#11

How are the requests being made, on which operating system?

Only very old o/s software would be unable to trust the new root certificate.

Alternatively you can switch to plain “http”.


#13

Still no uploading here. Eagle-200, Rainforest cloud says initializing. What cert was updated? Says server expires in 8 months.

SSL test indicates there is an issue with anchor chaining. https://www.ssllabs.com/ssltest/analyze.html?d=pvoutput.org

This may be a fix?
https://discussions.qualys.com/thread/12662


#14

First thing I tried was a power reboot. No help. Still can’t connect to the PVOutput.org in my Eagle-200 device.


#15

Yes, an RPI running and older version of Ubuntu which is presently updated. Back to normal this morning.


#16

Switched to Custom http URL. No change. Still can’t connect to pvoutput.org. Still stuck at “initializing”


#17

The certificate authority that expired was AddTrust External Root.
Fixes on the BOINC forums say that you can just remove the certificate and the trust falls back to the root certificate.
But that is going to have to be done by Rainforest Automation with a new file upload to our devices I think.
I raised a ticket with Rainforest already but have not received any response yet.


Eagle 200 stopped reporting
#18

Thank you, work on this.


#19

I meant, thank you for your work on this.


#20

Same here, http does not work anymore too.


#21

What is the error?


#22

I don’t get an error. I am still sorting this out. Maybe something else broke on my side coincidentally.