Enphase Envoy-S set static IP address as user, not installer


#1

Is it possible to set a static IP address as a user (or via Enlighten manager as a DIY installer) or do you have to get the installer to do this (asked them to do this and gave them a reserved address, the subnet mask, gateway and DNS servers when they installed the system a few days ago but they set it up with a dynamic address).

I had a play today and found out how to change the to a different SSID (had to get a range extender as the connection kept dropping out), but couldn’t see anything that allowed switching to a static IP.

The reason is that I have had issues with my modem router not assigning dynamic IP addresses (router was replaced under warranty but I suspect that the issue will re-appear). I also currently use the home page quite a bit and it’s a pain trying to find the ip address (router often doesn’t show all connected clients). Changing the router isn’t really an option as it’s one of the few that have VOIP included, it’s also the one that the ISP pushes (comes with lifetime warranty).

P.S. my first post :slight_smile:


#2

The other way to do it - in my router, I have a page to assign a particular IP address to a designated MAC address, so that device always receives the same IP address - if you have the Enphase box’s MAC address, your router may enable you to set a static assignment in the router, so the Enphase thinks its getting a dynamic address, but it always receives the same address.


#3

There are instructions on how to set a manual IP in the Envoy-S User’s Manual. I do have an older Envoy that I set a static IP on but the interface appears to be different although it doesn’t look difficult. Just make sure the static IP you set is not in the DHCP assignable range of your router or you will have conflicts.


#4

@pjschaffer thanks, but it only appears that you can set a static IP for and ethernet connection (might go that way if the need arises, just don’t fancy running the cables) not wireless. I tried using local before but it wouldn’t accept the password (kept on saying insecure so used AP mode). However, I can access it now (since I changed to a range extender and then had to change the SSID) so that issue might have been due to the weak signal.

@willisave I tried reserving an IP address to the MAC address, it didn’t do anything (I booted the range extender but not the router, perhaps I need to do the latter). I think the issue I have is that the range extender gets in the way (only got it yesterday so need to have a good read/ask on the vendors support, it doesn’t appear that it can reserve IP’s from the menus though (I might try setting the range to just the 1 and have a dedicated SSID)).


#5

You might try setting the static address in the Ethernet section just to see what it would do even though you are using wireless. That setting may be universal.

You might also try rebooting at least the Envoy and the repeater to force them to get a new DHCP lease if you’re trying the reserved address approach. Possibly your router too. I’ve noticed on some of my devices where I use reserved addresses, they don’t refresh immediately unless there’s a reboot. I don’t know what router you have, but unless the envoy is getting it’s address from the repeater (it shouldn’t be) then reserving an address by MAC should work.


#6

@pjschaffer been trying a few things. Rebooted everything, that doesn’t work. From a little looking around I think the repeater passes/uses a virtual mac address.

I tried setting the static IP via ethernet settings. It appears that it allows wireless connection but stops internet access or visibility of the reported ip address. Had to set ethernet to DHCP to get the ennoy working again.

The range extender manual confirms the use of a virtual mac address and says get it from the router. Router D-Link DVA-2800 shows very limited information regarding clients and then if even at all (make any changes and it shows no clients).

Guess I’m going to have to pray the replaced modem was duff and doesn’t stop relaying the DNS (how I understand the issue), which effectively blocks the IP address being given or hardwire through ethernet.


#7

I Think I’ve solved it and allocated a static address. Found the virtual mac address that the Range Extender allocates using IP scanner. The range extender uses it’s own set of the first 3 octets and the last 3 of the devices.

Using this Mac address to reserve worked.

e.g. Envoys wireless Mac address is 94:E3:6D:7C:8B:08 (not real) thus using the first 3 octets of the RE650’s MAC address) AE:86:C6:??:??:?? and the last 3 octects of the envoy (7C:8B:08) to then get AE:86:C6:7C:8B:08. Is the Mac address to use when reserving the IP address.