Energy used graph not raised correctly after solar system starts


#1

AI seem to have a strange problem.
I use a youless energy monitor connected to the energy meter with p1 connection. It runs custom firmware to update used power to pvoutput. It writes the v3 parameter.
This worked accurate before i had solar as far as i can tell for almost a year.

Solar system is solaredge and pvoutput uses the api to get the solar data from the solaredge monitoring.

Now we have solar i found a issue:
Power from grid after 12:00 am (noon) is not added to energy used for remaining day.
if i export the data to excel, is see that counter for energy used is updated when power from the grid is used (in numbers)
But after 12:00 am (noon) this (energy used) filed is reset to 0 and no matter how much energy from the grid is used after that, it gets never raised again.

Image to explain it:

So from 00:00 the graph energy used is going up till about 0600
At 0600 the solar starts up.
Around 09:00 you see some extra use, and the grapf raises a bit.
Than we have enough solar to cover the day use,
After 18:00 the evening power from grid is not added to energy used at all.


#2

This is just my analysis but here is what I think is going on with your system. Your initial setup with PVOutput was with a system which had no solar input so the meter was a true reading of the power you were consuming. When you added the solar you did not change the settings on your original setup without solar. This original system sees only a positive value for consumption and if any negative value is seen it is reported as ZERO or NA (not a number). However, your meter is now reporting “NET” usage and you will see a negative value when the the PV output is greater than your consumption. Since you did not tell PVOutput that you were now reporting “NET” it still sees it as “CONSUMPTION” and always reports negative values as zero. @bankstownbloke should help you set up your SolarEdge with meter to give the correct output.


#3

Technically noon is neither 12:00am or 12:00pm since it is neither ante ( before ) or post ( after ) noon. Conventionally though, at least in this part of the world ( Australia ) 12:00am would refer to midnight and not midday.

So could the issue relate to the definition of 12:00am? Or a discrepancy in definitions between system?


#4

sorry for the noon term. English is not my native language. I have configured a 24h clock and 12:00 is when the sun is about at his highest position.

I exported the data to excel and i did strip many lines to make it hopefully clear.

around 12:00 it seems to reset the field fort ENERGY_IN to 0 (zero) and after that not longer adds any value what comes in for POWER_IN and to does not raise the graph.

The youless energy reporting device can be configured of reporting either V1 or V3. My unit was alwas setup as V3. Also when i run the device without solar i got the red colored line and energy graph.

The info seems to be correct before 12:00 ish

I scanned through bad solar days and some days it seems to be correct and ENERGY_IN is than no reset. But the graph is not raised on screen either.

So it might have to do with my own settings, but i am unaware i changed something, or i cannot find the setting which seems usefull for that.

As for the meter its reponse. we do have multiple counting registrers in them.
So we have 2 time zones for a day. And than it counts power in and out for each phase (we do get 3x25A)
The meter than adds up the phases energy IN and OUT to totals and you eiter use from grid of send back to grid for that period in time. So even if you have not well balanced usage over the phases the meter will solve that for you and you still use your own solar.

The youless will only report positive numbers for energy coming from the grid.
If there is more solar than use from grid it will report indeed 0 of N/A i assume (in the excel export of pvoutput the fields are empty)


#5

In your Power-in column you see three types of entries. 1. positive numbers, 0, and “null” or blanks. The blanks are actually negative numbers being reported to a variable PVOutput considers only as a positive value which is this case is CONSUMPTION.
This problem is caused by setting the input from your Youless is seen by your settings in PVOutput as CONSUMPTION and any negative values will be reported as 0 or null or empty. The solution to your problem is to designate your reading being uploaded from the Youless as NET. @bankstownbloke should be able to tell you how your system should be set up to correctly use your Youless input. Click on the link to bankstownbloak and send him a message about your problem.


#6

Thank you, so right you are. I read only somewhere it will only send positive numbers.

Loggd on to the youless and what do i see:

18:52 -2628
18:53 -850
18:54 -737
18:55 -992
18:56 -1853
18:57 -2105
18:58 -2365
18:59 -2907
19:00 -3004
19:01 -2994
19:02 -2703
19:03 -2939
19:04 -3155
19:05 -3205
19:06 -3113
19:07 -2977
19:08 -2914
19:09 -1595
19:10 -655
19:11 -331
19:12 -328
19:13 -364
19:14 52
19:15 897
19:16 42
19:17 -3
19:18 1440
19:19 1388
19:20 1478
19:21 1834

It is a sky with clouds, so lots of power and than limited power from the sun.
Clearly it sends positive and negative values. (The dishwaser started at 19:18)

Will contact bankstonebloke as you suggested.


#7

Negative values suggest Net metering, you’ll need to configure youless uploader to send “n=1” in the upload request or measure gross consumption which is always positive.


#8

I could not find a way to insert the n=1, but the newest firmware lets me send V4 power use. I have configured that, and hope it does not send negative numbers and PVoutput can handle it.

Edit: this fixed it. I now see the used energy field built up further like it should. Many thanks for the help.


#9

FI am struggling with the same problem.
Letting the LS120 upload with parameter v=4 the value of energyconsumption is right during the night.
As soon as the solarproduction exceeds consumption, net energy is transported towards the grid. In PVoutput the value is then zero, instead of negative.
Is there a way to export and display the smart meter readings in PVoutput with both positive and negative sign?