Energomonitor to pvoutput


#1

Hi all
I am swapping from using a netbook connected directly to my inverter and consumption meter to using an Energomonitor Gateway. I have successfully connected my consumption meter to the gateway and the gateway is successfully uploading to https://app.energomonitor.com.

My problem is pvoutput is not showing data from https://app.energomonitor.com. I have entered my Energomonitor username and password in the pvoutput settings.

Any ideas on what I have missed?

https://pvoutput.org/list.jsp?userid=4393


#2

Check that the following streams are present in the energo monitor portal for the device:

  • S1 Solar Generation for solar
  • P3 Metered Power for consumption

Otherwise enter in the stream names to retrieve in the PVOutput config:


#3

Hi

This is what I have in the Energo settings…


#4

I have it working… I entered the circled name into pvoutput

Thanks!


#5

Hi
OK new problem. I now have two sensors each clamped to the consumption and solar generation. Both are showing on Energomonitor, however neither is showing in pvoutput. I have used the name as displayed in Energomonitor which solved my previous problem. I reckon it is to do with the pvoutput settings. I have tried a ‘direction’ of ‘both’ and ‘net’ and neither seems to work. Any ideas?
Thanks
Rick


#6

The valid streams for your setup are -

  • P3 Metered Power
  • S1 Solar Generation
  • Import 2
  • Export 2

However, there are two streams both labelled P3 Metered Power, rename one so they are unique. Otherwise the first one will be picked.


#7

I now only have one PS Metered Power. This is what I have:

What should my pvoutput settings be?

(Removed API key image)

Thanks, your support is why I donate!
Cheers


#8

Seems to be working I think.

Need to see what happens after actual power generation, seems like there is about 500w of ghost night generation. I guess I can create a rule or add a ferrite suppressor somewhere.

Not sure why the temperature from my weather station isn’t being picked up???

Thanks


#9

Temperature has been set to v7 and will not show on the main graph.


#10

Hi
Can you tell me why pvoutput.org isn’t showing my data when https://app.energomonitor.com is.

Thanks


#11

Can you confirm there is any data on the configured sensors?

  • Sensor s2t1
  • Sensor s0t1

#12

s2t1 is the solar which is wrong as it’s showing data after sunset
there is no s0t1
s1t1 is the consumption which looks correct

thanks!


#13

The following sensors have been configured on PVOutput -

  • Sensor s2t1
    
  • Sensor s0t1
    

Please change them to the correct ones.


#14

I change the setting in pvoutput.org, it says changes saved, but when I go back in the changed setting is showing the old setting. Also, it’s the consumption sensor name that is wrong, solar is correct so why isn’t solar at least showing.


#15

The energo API for your device will only allow the following streams to be downloaded -

  • Export 2
  • Import 2
  • P3 Metered Power
  • S1 Solar Generation

Anything else won’t return any data.


#16

So what settings should I use?


#17

Stream Out and Stream In should be left blank.


#18

Hi BB, rather than start a new thread i might tack on my issue. I’m having a similar issue in getting pvoutput to upload my energomonitor data. I’ve snapshotted my current settings for pvoutput and energomonitor could you advise what I’m doing wrong? (Note: the PVOutput snapshot ive put the direction to “Both” but no success either).
PVOutput:

Energometer:



#19

The details look correct, change the direction to Both and save.


#20

Hi BB, I’ve changed it and waited for an hour but it hasn’t worked.