Eagle Auto Uploader


#1

Discussion on the Eagle Auto Uploader


#2

I have the legacy Eagle and not the Eagle 200 and I have installed the push code that bankstownbloke has documented. The ability to POST directly from the Eagle rather than going through the rainforestcloud is recommended by PV Output as a better solution. I did have some unknown problems that made the code updates appear to not be working. Here is what I did and the settings and configurations I used as of July 2018.
The rainforest automation eagle I use is the 4 light legacy version with hardware version HW 1.2.3 and firmware version FW 2.3.4.8466. The Zigbee radio is ZB 1.4. The rainforest automation eagle is online and all communications were through the cloud interface rainforestcloud.com:9444. After logging onto the eagle using the rainforestcloud account id and password the eagle is working and reporting the data from the smartmeter. To enable the POST capability several things need to be collected. First to reduce errors from typing I used an editor that supports copy and paste from the internet browser which in my case is Google’s chrome and the editor was microsoft excel and you can use other editors as well such as notepad.
You will need your system ID which you can find from the settings tab on pvoutput. Log on to pvoutput and from the settings tab, scroll down to ‘Registered Systems’ and copy the system ID of your active system. Hilite the system ID number and copy (control c) on my computer and then paste (control v) using your editor. Be sure there are no spaces and you have the complete number. To get the API number look for the ‘API Settings’ which are just above the Registered Systems. Select the API key value by clicking on the text box that contains the key, copy and paste to your editor.
Now select the edit link for the active system ID and locate the Live Settings section and note the setting for the timezone. In my case it is US/Pacific and enter this text into your editor manually as copy and paste don’t work for the timezone pull down selections. Now find on the same page the section for automatic uploads. Locate the secondary device and enter the values for your system. In my case they are Secondary Device Eagle, Direction Net, Shift Time None and History Data Disabled. You will need to enter in the Cloud ID, the User and Password needed for access to your Eagle. Now back to the Eagle web interface page on rainforestcloud.com.
Select the Settings button to bring up the settings page. Select the ‘cloud’ setting with the right triangle icon and then pull down the provider list. I had to clear the old settings by setting the provider to None and set the value with the Set Cloud button. I had to repeat this step several times as the settings didn’t seem to take. To create a PVOutPut provider select the + icon (cloud) and enter in the text to identify the provider. I used PVOutPut. Now to build the URL value string in your editor. Enter the string https://pvoutput.org/service/r2/eaglepost.jsp?sid=&key=&tz= without any spaces. Now copy and paste the system ID after the sid= and the API key after the key= and finally add the timezone value after tz=. Copy this entire string from your editor and paste into the URL field on the rainforest Eagle settings box. Now press the set cloud and wait, keep the rainforestcloud page open. I would see the box turn red and the old provider would reappear so I would repeat the removal of the old provider by setting None and then repeating the cloud adding setup. It took several cycles of this before the PVOutPut settings didn’t revert, more than 4 but less than 10 attempts. I tried to remove the old provider with the - cloud button but I could not remove. I was thinking if I could remove the old provider completely then it would not reappear. I don’t know what I did to make the old provider stop reappearing but waiting for several minutes for the updates to cycle seemed to be part of the solution. Your observations and comments would be helpful to others.