Currentcost channels in PVOutput Intergration Service


#1

My current cost is running fine with 1 clamp on 1 transmitter(sensor 0) for main usage.
I added another clamp into the transmitter(sensor 0) for my hws on channel 2 and set all the settings in the currentcost.ini, saved and rebooted but it just uploaded data to the main consumption graph and the v7 is just a copy not its own reading.

Sensor=0
Channels=1
V7.sensor=0
V7.channels=2

Is there something im doing wrong?
My transmitters(sensors) have 3 inputs (channels) each.
Or am i not understanding the channels.
Im using the genuine current cost cable


#2

I no longer use current cost but received this reply yesterday to an old query
helpme@currentcost.com
A reply to ticket #473387 has been added. This is an automated response.

Regarding PVOutput.
I have been made aware by many customers of the popularity of PVOutput. I confess until recently I didn’t know it existed but I did some research and came up with a solution.

I reprogrammed netsmart bridge to communicate with a raspbery pi zero w on my home network. The raspberry pi posts data to PVOutput.

Here’s a link for description purposes. There are various cases available
https://shop.pimoroni.com/products/raspberry-pi-zero-w?
variant=3147218944010&gclid=Cj0KCQjwof3cBRD9ARIsAP8x70NSocBKdnrUeG5NL7aygP2pYrTNWmvL_no2

Nh3dyFj2ooJ_etH9YPUaAohQEALw_wcB

In practical terms the raspi system lives on an sd card which I can supply pre-
programmed. It is powered by a microsd phone charger and it’s wifi so there’s no ethernet cable to worry about.

The software for the Netsmart device needs customizing for your local network
We need to know what your local network IPs looks like. Commonly this will be 10.0.0.x, 192.168.1.x or 192.168.0.x but there will be others. Mine is 192.168.1.247, 247 being unlikely to clash with any other network devices you may have.

I don’t have solar-panels so I am only monitoring consumption on PVOutput.
As far as Current Cost equipment is concerned it is simply a matter of designating one
of the appliance channels, I suggest appliance channel 9 to monitor the sensor which you should already have attached to your pv-inverter. Chennel 9 will then post to PVOutput as generated energy. You may need to re-pair the pv-sensor to appliance channel 9 on your monitor.
The problem still exists of how to reprogram the Netsmart Bridge or Gateway to
communicate with the raspberry pi. In the UK it may be cost-effective to send me the
device for programming. In other countries it would be economical to have a local agent to do this.
This is not a Current Cost project. There will be subscription fees for the Remoda
server and I don’t know when that will be ready so I am suggesting this as an
alternative to those wishing to use PVOutput.
Please let me know if this solution is of interest to you and if so, in which country do
you live.
I hope this helps you and please don’t hesitate to contact me further.

Kind Regards
Steve
This might be of some assistance


#3

The setting should be in lower case v7.sensor and v7.channels

If this is correct check that there is data on sensor 0 / channel 2. This can be confirmed by using the CC terminal software or enabling debug on the PVOutput Integration Service in log.properties file, update first line to

log4j.rootLogger=debug, file

The pvoutput.log file will display all messages received from CC

Received: <msg>....</msg>

#4

pretty sure it is lower case i just typed in on my phone so it auto capitalised.
I don’t have access to it atm so just going off the top of my head. will check it out and then run that code

doesn’t look like the CC terminal software is available for linux

will enable debugging and see what i get cheers.


#5

ok so i got it working but it keeps dropping out on the transmitter (sensor) one using 2 different channels
https://pvoutput.org/intraday.jsp?id=29186&sid=61410

i also have to re sync the transmitter when i stuff around with it and reboot as it wants to be difficult.

it done 2 outputs at 1:45 and 1:50pm then dropped out. i rebooted and resynced at 3:15pm and worked until 5:25 and now has dropped out again. the other transmitter hasn’t had an issue with any of the stuffing about

i have it setup as

sensor=9
channels=1+3 (as it didn’t seem to work as just 1)
direction=in

v7.sensor=0
v7.channels=1
v8.sensor=9
v8.channels=2

i had previously swapped transmitters (sensors) and clamps as sensor 0 was my main sensor but is now sensor 9 when i tried to set it up with channels last time

Im losing both clamps (channels) on the same sensor so i cant see it being a clamp fault
there’s nothing wrong with the transmitters as they both ran fine before stuffing with channels and were swapped and still have the issues.


#6

without touching anything it started working again about 10pm through to the new day and has stopped at 8:05am for that sensor, main consumption and copy of main consumption in extended data. other sensor is still working fine
https://pvoutput.org/intraday.jsp?id=29186&sid=61410